Network LPD printout garbled after upgrading 10.3 to 11.0

I have this printer connected through a print server:

HP LaserJet 3 / lp
Connected As lpd://printer/lp
With Spool lp

Works fine from my SuSE 10.3 boxes. I’ve just upgraded one box to 11.0, and the output is all garbled. The best result I could get from YaST’s “Test Graphical Printing with Photo” is about 10% of the page it’s supposed to print, followed by a lot of one-line garbage on subsequent pages (until I turn off the printer). Even worse, my 11.0 box does something that makes the print server choke; other boxes get an LPD connection error until I reset the print server.

I’m using the LaserJet 3 Foomatic/ljet3 driver on the 11.0 box (just like on the 10.3 boxes). I’ve tried the new CUPS+Gutenberg v5.0.2 drivers, too, but the result remains the same.

Any pointers appreciated.


Follow-up on the above problem.

On another box that I upgraded from 10.3 to 11.0 there’s a similar problem, albeit not as serious as the original problem described above. I can print from that box, but after one or two pages all subsequent pages come out garbled, e.g. only half the page is printed, or pages might not even get printed.

I checked /var/log/cups/error_log on both 11.0 machines. There’s nothing that indicates a problem with print jobs. I also checked the 11.0 machines’ /etc/cupsd/cupsd.conf against the 10.3 machines’ in my network. The configuration files are identical.

As a temporary solution, I’ve configured my 11.0 machines to send their print jobs to the CUPS server on a 10.3 machine. This works fine, no issues at all. Only problem is I’d like to update my other 10.3 boxes, too. :wink:

Any pointers, anyone?

To close this thread, I’ve managed to solve the problem in the meantime. I’ve reported a bug today:

The guys from SuSE instantly started working on it and pointed out I should try again and use the hpijs driver (provided by HP, and part of the SuSE 11.0 release). I was pretty sure I had tried that driver before, but this time it worked. :rolleyes:

What I did (maybe it matters, maybe not):

  • Stop CUPS
  • Remove everything in /etc/cups
  • Reinstall CUPS with yast; this installed v1.3.7-25.1
  • Install network printer/LPD queue through yast, selecting HP LaserJet 3200 (HP LaserJet 3200 Foomatic/hpijs / lp), hpijs version is