Network goes off when monitor turns off

Hi all – it has been a while…

SO, I just installed Tumbleweed and everything is going great. I installed Gnome as the desktop, and as I am typing in commands via SSH suddenly my terminal is not responding. I go to the server and see the monitor is off, so I tap the keys and pooin gnome, but it still happens. Any ideas? the network is back. I disabled screen lock in gnome but it still happens. Any ideas?

I assume you are talking about two systems, one running the SSH server and one the SSH client. But from your description on what is installed I am not sure that both systems have Tumbleweed.

And do you mean that on the system with the SSH server there is also a GUI session running for some user. And that that user switches off the monitor. Or doesn’t that user switch off, but goes the monitor sleeping for inactivity of the user, or is no user logged in and goes the monitor sleep for no activity on the login screen?

For me the image you try to paint is still rather unclear.

I am using ssh to access the server. The server is running Tumbleweed with Gnome, a fresh install. When the server’s monitor goes dark, I lose network connectivity to the server until I tap a key on the server’s keyboard which brings back the network seemingly because the login prompt appears.

I assume that it should be of no interest if a user can use Gnome on the server. Yo SSH to it and thus get a CLI login shell. It should not matter if desktop software is installed at all, let alone if it is in use by a user.

I can only come to one specific situation and that is when the server’s network isn’t configured by wicked (or by “system connection” of Network Manager. Because when it is only the end-user’s NetworkManager client that will start up the network, then you will have no network unless there is an user login that does use NM. Which would be a weird situation for a server running system.

Network is configured by wicked, and NetworkManager is disabled. It looks like I got it though. As it is technically a server (I use it for some services) I disabled hibernation/suspend:

sudo systemctl mask

To undo:

[FONT=courier new]sudo systemctl unmask[/FONT]