Network fine in Windows, but broken/50bytes-second after reinstalling TW into existing mount points?

Hi there,

Short story:
Six year old X99/5820k/Vega64 system that has been running fine as dual boot for the last year.
Win7-64bit / Tumbleweed-64bit.
It died three weeks ago and it was six years old, so i took the Vega64 out to use in a new PC.

After putting my old 7970 gpu back in the system and playing around with the old PSU connections, hey-presto:
Thing turns on for the first time in a fortnight!

Because I installed an old GPU that doesn’t use the full AMDGPU stack, i decided to reinstall TW into the existing mount points.
That went fine, TW is up and running on a nice clean install.
Win7 works fine too, after i uninstalled the old graphics driver/utilities, and reisntalled the AMD driver afresh.

Only problem; in TW the network is connected (network manager shows a white cable symbol - and it does indicate traffic), but the connection seems to be throttled down to around 50bytes per second.
If I load a web browser i get a broken version of the version suse search page (mainly white - with badly formatted text), but if i try to load a webpage i get a 404 in the broswer window.

Yet windows is happily sucking down Steam updates at 6MB/s…

Anyone know where TW has fallen over?

Many thanks. Jbt

Most common cause of a very slow connection is a misconfigured network adapter,

  • Typically speed set to auto negotiate. Instead, set to a specific speed.
  • Possibly set to half duplex instead of full duplex. Again, fix accordingly.

Other possibilities

  • Of course, although hardware detection works pretty well nowadays, verify you hardware is detected accurately.
  • Verify the other end of your patch cable is correctly set and/or same as before. If the problem is on the other end, that could be what is causing alll the poor settings on your end.

HTH,
TSU

Cheers, is this something that can be done via NM?

I don’t think the problem is the cable (or the powerline 1200 adapter), as a reboot into Win7 will bring perfect network connectivity.

Thank you. Jbt

Yes, use the NM connection editor to set the desired negotiation parameters. From the ‘Wired’ tab, you can adjust speed and duplex as required.

Hi there, thanks.

Network Manager “wired” tab was showing:
Connection = Automatic
Speed = 100MB
Duplex

So I changed the above to:
Connection = Manual
Speed = 1GB
Duplex

But it hasn’t changed anything…

I can see under the General Configuration tab the following:
Connect Automatically with priority = -100

Is this incorrect?

If the above cannot explain the behaviour, how do I go about verifying my hardware is detected accurately?

Use ethtool to verify current negotiation eg

/sbin/ethtool eth0

Check and report back.

Thank you.

“no such file or directory”

Maybe you don’t have it installed?

https://software.opensuse.org/package/ethtool

possibly not.

given that i have no working ethernet on the computer under suse, and that the expert download is offering me a YMP file rather than an rpm (in case I tried to download it on windows and transfer across), is it better to simply re-install tumbleweed into the same mount points again.

and hope that this time it figures out what to do with the ethernet adapter?

As an update to this issue that allows it to be closed:

I did do a clean install of 20200810 (the first kernel 5,8 release), instead of reinstalling into the same mount points, and all of a sudden the network connection is fine.