Network/file paths from command shell

Hello all,

I am using opensuse 11.1, text only install with mysql. I am brand new to Linux, approaching from a Windows background :P.

I am trying to figure out the syntax for network and file paths in Linux. For example, I’m used to typing paths like:


How does Linux want it? I realize Linux doesn’t use the back-slash. My objective here is to load some schemas for mysql. I don’t care if I get them over the network or from a USB flash drive, neither of which I can access.

I have verified that I have network connectivity and even joined a windows domain via yast2 just for testing purposes.

The only posts I’ve found here and in mysql forums all pertain to GUI interfaces which I’m obviously not using. Any help is greatly appreciated.

Hallo and welcome to the forums.
To copy files from a windows/samba share you could

smbget smb://

The file will be downloaded to the actual users home directory. You can try smbclient as well. As you see in Linux we use slash instead of backslash in windows.
When you have problems connecting to a windows share it has very likely to do with your firewall. So, before you surrender switch of your firewall with “rcSuSEfirewall2 stop” and try again. You’ll find instructions on the proper firewall configuration here in the forums.

In openSUSE a USB stick is automounted by default in /media/something. When it’s not automounted you can find your USB stick with fdisk -l. Then you can mount the USB drive to any folder that exists.

When you are familiar with the NortonCommander file manager on DOS/Win you may want to try midnight commander on Linux. When I moved to Linux from windows, mc was a great help to me. Good luck!

Great info, but I fear I’m newer to Linux than you thought.

I tried turning off the firewall with the command you listed, but it returned:

-bash: rcsusefirewall2: command not found

I went ahead and used smbget with the path to my files. After authenticating, nothing happened so I assumed that the files were downloaded to root’s directory (I’m testing things under root until I get a handle on this, just to cut down on troubleshooting).

After running DIR under root, all I found was:

.bash history

I then tried cd /media/<a few guesses> but couldn’t find my flash drive.

Appologies for my noobness. If it helps, I performed this installation acording to the following link (minus the mail and web hosting):

The Perfect Server - OpenSUSE 11.1 | HowtoForge - Linux Howtos and Tutorials

Perhaps something in there changes the typical installation?