Network fails to initialise on reboot


Running OpenSuSE 11.1 and am generally very happy with it.

However, I have an issue where I setup the network to use DHCP, and it worked fine. I shutdown the machine at night, and when rebooted the next day, I had no network again. The log told me the lease had expired (fair enough) but it constantly timed out when broadcasting again.

This initially sounds like a server thing, but this is on our company network with a dozen other workstations (mostly Windows, but I have another linux distro on another machine), all of which work without issue.

I went into Yast, disabled the card completely, then re-enabled it with the same options, and it worked, so I thought it was just a “one-off glitch”. Next day, same problem. I tried setting it statically, which worked initially, but next day failed again.

It seems the only way I can get the network going, is to go into Yast each day and fiddle with it until it starts again!

I initially thought it was networkmanager as that was how I connected initially, but it happens using ifup during boot as well.

Firewall is currently completely disabled.

The card module is the e1000e.

Sorry for the long ramble :wink:


Have a look at the boot.msg file under /var/log and see if it gives you a hint what is going wrong during the initialization of your connection. You may also want to run the ifconfig command after boot (as user root). Do this after booting but before repair with yast and see what the output is.

After having a power cut, rebooting again did not initialise the net.

I checked ifconfig, which showed eth0 (without any IP info) and lo (with IP info) (sorry, haven’t got the output at the moment) and boot.msg told me it had failed to assign an IP address.

I decided to delete the configuration and create a new one from scratch. This time on bootup it actually got an IP address. I’ll leave it another day or two (probably over the w/e) and see what happens, but for now, recreating the configuration seems to have done the trick.

Well, I spoke too soon :frowning:

Bootup this morning did exactly the same thing. Output of ifconfig for eth0:

eth0      Link encap:Ethernet  HWaddr 00:1E:C9:83:1D:77
          RX packets:955 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3586 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:114022 (111.3 Kb)  TX bytes:1229409 (1.1 Mb)

And I extracted this from boot.msg:

Setting up (localfs) network interfaces:
    lo        IP address:
              IP address:
done    eth0      device: Intel Corporation 82562V-2 10/100 Network Connection (rev 02)
    eth0      Starting DHCP4 client. . <notice>checkproc: /usr/bin/kdm 2497
. . . . . . . . . . .
    eth0      DHCP4 continues in background
Waiting for mandatory devices:  eth0 __NSC__
    eth0      device: Intel Corporation 82562V-2 10/100 Network Connection (rev 02)
    eth0      DHCP4 client (dhcpcd) is running
    eth0      . . . but is still waiting for data
    eth0      interface could not be set up until now
failedSetting up service (localfs) network  .  .  .  .  .  .  .  .  .  .failed

Not really sure how helpful that would be, but by killing the already running dhcp, disabling and then re-enabling the network connection in Yast, and it picked up an IP address first time.

All very frustrating.

After a bit of searching, it appears this driver (e1000e) has all sorts of issues, with other postings on other distro’s forums showing the same problem I am having (and, in some cases, worse :open_mouth: ).

Looks like I’ll have to add another network card, or wait patiently for a kernel/driver update that fixes this issue…