Network driver and dependencies

Hi everyone, I’ve used Linux before in various capacities, but am new to OpenSUSE. So far, I like it a lot, but I have a critical hangup: I cannot connect to the internet. My computer has 2 hard drives, one with Windows 7 Pro, and the other with Linux. Windows connects without any problem, and similarly, Ununtu had no issues when I was running that, but Ubuntu has been replaced with OpenSUSE and I can’t get it to connect. It’s connected with an Ethernet cable to a switch, which is connected to my router.

Here’s where my ineptitude probably starts showing. What I’ve tried to do to get online might be the wrong way (in which case, please correct me), but here’s what I’ve tried so far. I’ve downloaded the Linux driver for the Realtek Ethernet thing my computer says it has (download via other computer, and transferred via flash drive), unpacked it, and tried running “” (per the README files that came with the driver), but got an error saying “make: not found”. I tried pulling the “make” stuff from the install DVD I have, and extracted that as well. Now when I execute “” the error I’m getting is

make: *** /lib/modules/3.11.6-4-desktop/build: no such file or directory


…aaand I’m kind of at a loss about what to do. Anyone have any suggestions? I would greatly appreciate any advice the community might have. Thanks!

Powerspec B302
OpenSUSE 13.1, 64-bit

Can you tell us more about your ethernet hardware? Chipset details are always useful.

/sbin/lspci -nnk

Since you have no network connection, you might find it convenient to save this information to a file and put on a memory stick.

/sbin/lspci -nnk > hardware.txt

Then you can post the info here. You can also reduce the output by cutting and pasting only the output pertaining to your network hardware eg

18:00.0 Ethernet controller [0200]: Broadcom Corporation NetLink BCM5787M Gigabit Ethernet PCI Express [14e4:1693] (rev 02)
        Subsystem: Hewlett-Packard Company 6710b [103c:30c0]
        Kernel driver in use: tg3
        Kernel modules: tg3

Maybe you don’t have to compile anything at all. :slight_smile:

Thank you very much for your help deano, and thanks a ton for the tip about saving the results to a file! That made it really easy. Below is the output from the chipset pertaining to my ethernet hardware.

03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 01)
    Subsystem: Intel Corporation Device [8086:d608]
    Kernel modules: r8169

Is there a general repository where I can see whether hardware is supported or not? What is a good way of checking this kind of thing?

In this case you can see that the r8169 driver is loaded. So your device is handled out of the box by the openSUSE kernel. Do you see the interface listed?


Assuming so, now you need to configure it the NIC.

Check that you’re not affected by

YaST > Network Devices > Network Devices

You can choose whether you want to control the interface via Network Manager or ‘Traditional ifup’. If you’re just connecting to one wired network, the latter will be fine.

Hardware support is very dynamic with kernel progression and the large number of driver developers working to make Linux support better all the time. There are a large number of online databases, but they are not all as up to date as they could be. Two to start with: