Network doesn't work in 11.2, works in 11.1!

Note: this is a wired network connection, not wireless

My network settings are easily configured in OpenSUSE 11.1 and my network connection works wonderfully in 11.1. However, I’m unable to get my network working correctly in 11.2, there’s a change made in 11.2 in the Network Configuration settings, here’s the difference:

  • In 11.1:

Yast/Network Settings/Routing/Default Gateway:
I enter my router’s IP here and apply the settings and my
network connection is active and works wonderfully, there
are no options for -, eth0, and lo like there are in 11.2 in this particular area of the settings.

  • In 11.2:

Yast2/Network Settings/Default IP4 Gateway:
I enter my router’s IP here and apply the settings but my
network connection never starts, there are other options which have been introduced into this section, which are the following in a box to the right where you enter your router’s IP: “-”, “eth0”, and “lo”. I’ve entered my router’s IP and selected - and applied settings, nothing works. I’ve tried it again and selected eth0, applied settings, nothing works, and finally, tried selecting lo and applied settings and it didn’t work either.

In 11.1, I simply entered my router’s IP, there were no choices at the right of where you enter your router’s IP to select between -, etho, and lo. It just worked! Why have these entries been added, how do I resolve this? 11.2 is no good for me if I cannot connect to the internet as I am able in 11.1!

What is preventing me from connecting to the internet in 11.2 with these added options? None of these added options works! In OpenSUSE 11.1, I simply type in my router’s IP and apply settings and it works! What is the solution here? I’ve looked through and compared the other network settings and verified this is the section of the network settings which differs between 11.1 and 11.2 and the problem is within the above portion of the network config which introduces the problem with these new setting options.

Try adding the IP addresses of the name servers provided by your ISP, or if you don’t know them, use the nameservers provided by Google (8.8.8.8 and 8.8.4.4). See pic # 7 in this old tute: HowTo Configure a network card in Suse/openSUSE 10, 11 for LAN and Internet Access.

That won’t help. As I mentioned in my OP, I’ve isolated the problem down to the specific section I referenced.

11.1 works and does not include extra options within this section, 11.2 doesn’t work with any options selected in this extra area. How may I bring 11.2 into a workable state within this area? Neither of the three options given work when I enter my router’s IP.

If I cannot get this working, I’ll have to stick with 11.1, as these new options present a problem, and they’ll probably be in 11.3, too, I’m assuming. I don’t know why they were added at all when none of them work (for me).

In ‘Network Devices’ → ‘Network Settings’ → ‘Global Options’ I prefer to use ‘Traditional Method with ifup’. This works for me. Are you doing it with ‘NetworkManager’? And is this DHCP or fixed IP numbers?

When it “doesn’t work” what are the results of

/sbin/ifconfig -a
/sbin/route -n
cat /etc/resolv.conf | sed -e '/^#/d'

When using NetworkManager make sure to use the latest update of it.

On my wired connection I have ‘Traditional Method with ifup’, no need to alter any other the settings at all. This has worked from 10 onwards. I wouldn’t use NM for a wired only connection.