network does not start on virtual machine


I have a rather annoying issue with Leap 15.2 on a VM that is running at netcup.

Whenever I have to reboot the network does not start automatically - I have to manually log in on the console through their management website, log in as root, and run “ifup eth0”.

There are no errors to be seen anywhere, not in the journal, not in the kernel messages.

To add a bit more spice to it: I have a second VM, also at netcup, running the same Leap 15.2, and that one boots just fine with working LAN.

any ideas?

Please post:

cat /etc/sysconfig/network/ifcfg-eth0

I just deleted the network card in yast and configured it again - that didn’t help.

then I set wicked to debug=all in /etc/sysconfig/network/config and after that I found a lot of wicked messages in the journal, some of which looked like timeouts…

now WAIT_FOR_INTERFACES in /etc/sysconfig/network/config is 60 instead of 30, and the network comes up like a charm.

Which option have you chosen for the Network Interface of the VM?

  • Is the VM’s network interface using a NAT or a Bridge?

I’m going to guess this is specific to your netcup deployment, you might want to run this by your netcup support.
In general, any/all OS will test the network connection on bootup and automatically activate when there is a good connection.