Network does not mount at boot

My network drives in fstab no longer mount
at boot, starting with Suse 10.3, before
that they did. i now have 11, and it still does
not work.

mount -a works after boot.

fstab is quite normal, i.e.
puck:/SAN1/jobs /mnt/jobs nfs rw 0 0

can’t see any relevant errors in boot.msg:
Failed services in runlevel 5: routeadd
Skipped services in runlevel 5: smbfs irq_balancer splash

  • gpbartel,

slow network. I have the same problem with Samba shares; though the _netdev option is set, it doesn’t get mounted.
What helps is a crontab entry:
@reboot sleep 10;mount -a


i had to run “crontab -e” as root,
then it works.
thank you!

On 09/22/2008 gpbartel wrote:
> i had to run “crontab -e” as root,

That’s the usual way to edit root’s crontab, sorry for being unclear :slight_smile:
Glad you got it solved. I don’t know if there’s a more elegant way to solve it, keep looking.