network connectivity problem

I just freshly installed my OS yesterday to fix a problem with KVM. This morning, everything was working fine. I shut down the computer for a little while, and booted back up. Now I have no network connectivity to the outside world. I have made no modifications to my system since yesterday, but apparently my network configuration has gotten hosed. if I try to ping outside my LAN, I get:

connect: Network is unreachable

There is nothing unusual in the system logs, and I am able to connect to wifi and can ping and resolve local hostnames within my own network.

I noticed the virtual network in virt-manager has disappeared, as has the /etc/sysconfig/network/ifcfg-wlan0 configuration file. Umm, any idea what would cause these configurations to just vanish? Also, what info do I need in the ifcfg-wlan0 file? I do not have a copy of it. Besides creating a new config file, is there anything else I need to check? Thanks.


netconfig -f update

I tried that, it doesn’t do anything. I also tried doing a rollback with snapper and the read-only snapshots all boot to a console login, no GUI. Some of them don’t even recognize my user. Is my system just hosed up? Maybe I should just go back to ext4, I never had this many problems until I decided to try btrfs.

What do you mean by “freshly installed … yesterday” ? And “to fix a problem with KVM”, please elaborate.

I reinstalled the root partition with BTRFS yesterday (format, and new install) after spending too much time trying to fix the issue described here.

That issue began after a rollback to fix a kernel panic caused by the newest kernel-firmware package, described here.

The rollback fixed the kernel panic, but afterward I was unable to launch virt-manager.

So, I thought hell with it, I’ll just reinstall the root partition (it only takes 10 minutes). Got everything reinstalled yesterday and working fine. Then after a shutdown and reboot earlier today, I basically had no network connectivity and another issue with the virtual network being deleted from KVM. The only thing I can think of is that I did import an openVPN config file so I could connect to a VPN server, but I don’t know why that would have crashed all my network settings. It’s the same file I’ve used previously with no problems at all. Tried a rollback, and got the message that my user is invalid when trying to log in…???

So, since I got the user error attempting to do a rollback (I have only had one user on this computer since the initial install), I have reinstalled the OS again, just now. The network is back. I’m going see if I can reproduce any of these issues to see if I can figure out what’s causing it. But, if I get more problems along these lines I think I’m going to go back to ext4. I had an ext4 root partition for years and never had any major issue that didn’t have a simple solution. ](