Network Connections All Grey except for VPN

Hello there,

First a warning that I’m so clueless it hurts. Initially I entered the Linux world as a solution to my blue screening Alienware Aurora desktop (which later fried anyway ironically enough). I decided to give up on Windows for everyday use cause you can’t strangle an operating system. My first and there after Linux experiences have been fantastic. Internet works without prompting through various distributions of Ubuntu, Mint, and KDE with the exception of enlightenment.

But now I come to openSUSE 11.4 and as my title suggests I’m having a hard time connecting to the internet. I’ve got a wireless card and router and all that jazz but I can’t even select the options for wired or wireless connections under Network Connections in the Network Management Settings. Everything is greyed out except for VPN. I even have the desktop wired to the router and it still is not giving me any indication that it will connect.

I’m wary of trying to enter ip addresses and things of the like because I honestly don’t know what i’m doing here.

My router is a Netgear N150 Wireless WNR1000 and in the Kinfocenter under Device Viewer I found my wireless card to be a RaLink RT2561/RT61 802.11 g PCI and my wired device thingy to be an Intel 82540EM Gigabit Ethernet Controller.

If there’s any more information you guys need from me, hints as to where to find said information would be greatly appreciated.

PS: I have looked through the forum and I’m honestly not sure if there is a solution in the mix. I get a bit lost when they start talking about terminal code. I can make the cow moo and install applications and stuff but I don’t know really anything about terminal beyond that.


If the “Enable Wireless” checkbox is inactive (gray), there are several possibilities: (1) Your wireless device driver is not loaded, (2) the necessary firmware is not available.

For (1), check

hwinfo --network

and check the “Driver” line. If it is blank, then you need to run the command

/sbin/lspci -nn

if the device is connected to a PCI bus, or


if a USB device.

Post the results here.

For (2), look at the output of

dmesg | grep firmware

which will list the name of the file(s) to be loaded.

okay i ran that first code and found the driver lines to not be blank. For Ethernet it says “Driver: ‘e1000’” and for WLAN it said “Driver: 'rt61pci” Andthe pci code came up with a wealth of information containing a lot of zeros, but as strange as this may sound i hadn’t actually tried to open the web browser. And let me tell you it is working. I searched on google went to youtube and several other sites and it’s all working. It even let me do the updates. And i unplugged the cable and it’s reading off the wireless. But it just says that there’s no connection. So before i type all the rest of what i found in, would there be an explanation for it still saying it’s not connected?

Sorry for the delay on this And I really hope i haven’t just wasted your time :slight_smile:


Maybe you are using ifup instead on NetworkManager to manage the connection.

To check if it is the case, go in YaST => Network Devices => Network Settings. Under the “Global Options” tab, verify that the option “User Controlled with Network Manager” button is checked. if not, you are using ifup.