Network Connection Stops Working After Some Time (2 NICs)

Hi all.

My internet connection seems to stop working randomly after a certain amount of time using it. When I say stop working, I mean I can no longer even ping my router.

This happens regardless of whether I set my Network settings to be managed traditionally using ifup or by the new NetworkManager.

I have an on-board NIC eth0 (not connected) and an Intel NIC card eth1 (connected).

If I remove the Intel NIC it works fine in the on-board, however the card itself is not at all faulty as I have tried others with the same result.

When it happens Eth1 still shows as connected, it just doesn’t work. It’s almost like it turns off Eth1 after a while.

If I mess with the settings via Yast, when you save changes it stops and starts the network services - this brings the card back to life!

Any idea’s where I can start looking to fix this?

Using the on-board is not an option as it doesn’t work in Windows but the Intel card does, so leaving my cable in that and switching between the 2 OS’s was an easy win (or so I thought!).

Thanks in advance.

Have you set the on-board nic in yast>network to not configured?
Also, if you are using dhcp via the router, check the lease time or else just set up with a fixed ip address.
I have a similar problem and also have 2 nics, but have never had any problems.

You could try setting the onboard card to never be activated in Yast, Network Devices, Network Settings (your bios may also have an option to disable onboard lan)

Me if I had 2 cards, 2 os’s and each os ‘liked’ a different card, I’d use two cables, and just let each os use the card it works best with, at least until I could figure out why the connection was dropping

You don’t mention why the onboard card doesn’t work in windows, if you have a driver and it still doesn’t work it could be that the onboard one is faulty, which I suppose could be the root of your problem in the first place

You can’t do this because if both work in linux, you end up with 2 cards on the same network which doesn’t work.

Have you triedthe motherboard manufacturer’s site to see if he offers windows network drivers for the onboard lan?

Yes you can

Just disable the card you don’t wanna use in Yast

Even using static addressing would allow you to connect fine when you have two cards both with a cable plugged in