Network connection help needed - point me to articles to study

My cable modem is connected to my Router(Netgear R7000, desktop is Ethernet, both laptops are WiFi).
The router connects to my desktop PC.
The router has a shared external HDD connect to it that is used by three in this house with multiple devices and/or OS’s.

Obviously, I have no problems with getting to the internet. It is fast and steady in Leap 15(and windows)
Every device including our iPads can see that shared drive.

I can mount the Windows drive(s) with no problems usually.

But that shared external HDD is driving me nuts trying to figure out how to get it in the list of devices when I open Dolphin.
I have been through the openSUSE documentation but no real help so far.
Any pointers to How-To’s to give me some learning help?

PS addition information:
OK, Netgear has their ReadyCloud that is ‘supposed’ to make it available anywhere/any how. But it’s Netgear, and that hasn’t worked for me(and a few others I know with R7000 routers). Be Nice if it would, but I’ve been fighting getting it working and with Netgear for a year or more and that is like pulling teeth from raging elephant.

This reads like your router provides a built-in samba server service. Samba discovery formerly relied on using an old NetBIOS discovery protocol using NT1 (SMB1). Due to security issues that protocol has now been disabled.

Some background reading about this

The ‘smbtree’ command can be used to report available shares on your LAN (it uses the NT1 protocol briefly to undertake the discovery communication)


Note that ff you’re using a firewall, you may need to open the appropriate ports (or allow enable samba-client service) for the discovery to take place.

You could try reaching the share via the router IP (gateway) address. Get that explicitly using

ip r

For example, assuming is the gateway IP address, you should be able to browse the share using Dolphin with something like…


Once you can access the shares, you can add a shortcut ‘places’ entry to Dolphin.

Go, in Dolphin to Network in the side bar. ‘Add New Network’ will open kNetattach and allow you to create connections with various protocols, incl. SMB. Once that works, simply drag the shortcut in Places, done.

Thanks much to both!
@deano_ferrari I will keep the links for future reference, and thanks for the individual command line instructions.
@Knurpht Where in here is that Big Red Button with ‘That was easy’ stamped on it?

I set it up as a MS Windows Network Drive.

If it should be one of the other choices:
webdav, ftp or secure Shell(ssh)
Please let me know.

I know I can access it to read via web browser using HTTP or FTP ,but IIRC, I tried that and could read, but not write to it.


I set it up as a MS Windows Network Drive.

If it should be one of the other choices:
webdav, ftp or secure Shell(ssh)
Please let me know.

If you’re happy with reaching the NAS via samba then that is ok.

You made the right choice (MS Windows Network Drive aka smb aka cifs) for what you want to set up, and the proof is if what you set up works in every way you want. The ftp option <might> also work.

FYI since you’re learning…
When you connect using your web browser using an “http” or “https” address, you’d then be using WebDAV… You should also be able to use an “ftp” address which would use the ftp protocol. You’re right that by default WebDAV supports read-only, and additional configuration is needed to enable writing… Your problem might be an authentication problem (You need to provide some kind of credentials to your router) or a configuration in the router.

ssh (Secure Shell) is by default a command line only type of connection although by passing options you can often access a graphical Desktop, so wouldn’t be suitable for either setting up Dolphin or by a web browser.