Network connection from a live CD

I can’t make a network connection from a live CD. I’m behind a DLink EBR router and an ActionTek modem (with NAT), and I can only ping the localhost. Tried with both the openSUSE and SystemRescue CDs. Any suggestions for troubleshooting this?

It’s not always possible because hardware drivers may have to be compiled against the kernel. I’m not familiar with the hardware you quote. If it’s going to work, it usually will be. Have you tried clicking the networkmanager and setting up a new eth0 connection?

I’ve tried ifconfig. I’ll check the Network Manager and see if I have better luck with that.

The Network Manager does not even detect a device.

You have a router, so what is the Action Tek device for - Normally you would plug direct to the router.

ActionTek is the modem. It has a built-in router, but for some strange reason only one connection. The best way to go might be a wireless router, but I already have the D-Link, and the combination works well for other purposes.

I’m not familiar with this setup. I just plug a RJ45 directly in the router from my network card.

I guess I’m not clear. The modem has router capabilities, but for whatever reason has only one port. Don’t ask me why. This is connected to a D-Link LAN port, which in turn connects to my desktop and file server via LAN.