Network connection fails after rebooting to Leap 15.4 from windows on dual boot machine

I am running a KDE desktop on HP Z640 workstation which is set up with dual boot capability so it can also be booted to windows if needed.

I recently had reason to work on windows from this machine so restarted and selected windows from the Grub screen. No problems with this. Windows ran, required updating which was no surprise, completed my work and then restarted the windows OS so I could return to Leap 15.4.

Having logged back into the Leap 15.4 machine I found, however, that I had no internet connection. I have done some simple checks which confirm that I have a connection to the default route but the route beyond there to the wan is not set.

There is never any problem when booting from windows and getting an internet connection but my connection always fails if I do not unplug the machine from the power before restarting in Leap 15.4.

This suggest to me that there is some tool using windows that has not been set in Leap 15.4.

Here are the results from my cli investigations on Leap 15.4, first with a good internet connection and then after a restart from windows.

It may be seen from the second batch of commands that the ip neigh fails. I did try and look at arp tables but in fact arp is not now installed in Leap 15.4.

The route from my machine to the wan goes through several L2/3 switches but I am out of my depth now and do not see why windows can connect but Leap 15.4 not. There is no firewall causing the problem that I can see from:-

alastair@HP-Z640-1:~> sudo iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination         

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination         

I think to problem is related to not resetting cached tables in switches between my computer and the main router and would appreciate some help please.

The cli text files have too many characters for a simple cut and paste so I am posting to susepaste and the resulting link is below:-
Network connection problem

Hoping this works.
Thanks to all.

If you want to use the ‘arp’ command you’ll need to install ‘net-tools-deprecated’.

Hi Dean,
I assume that if “net-tools-deprecated” are so designated that they have been replaced by something else.
Whatever the case I am hoping somebody will help me sort out my problem because I have no idea what to do with these tools once installed. I just want to know why windows works and leap 15.4 does not and what to do to fix it which does not involve unplugging the power lead every time. Is that too much to ask?

What exactly does it mean?

You forgot to show what does not work. All commands you show there are successful.

[quote=“Budgie2, post:4, topic:164612, full:true”]
Hi Dean,
I assume that if “net-tools-deprecated” are so designated that they have been replaced by something else.[/quote]
The ‘iproute2’ utilities replaced them a long time ago, but you’re free to install the former if you want to. :wink:

You keep starting new threads - that just makes for confusion. Likely an issue specific to your network environment (eg DHCP server implementation). I don’t have the appetite to go down yet another rabbit hole at the moment - hopefully others with more time can assist, but make sure that you stay on topic and answer questions with pertinent information.

Having read your numerous posts on networking I doubt that you are willing to find out what causes your problems. With multiple boot configurations subtle interactions between operating systems may arise: Switching to Fedora and back to openSUSE renders wireless interface dormant.

Trial and error won’t work, to my experience of course. You need to figure out how DHCP of your router works. Presumably your problems are caused by leases of Windows being confounded with Linux.

The current version of NetworkManager on Tumbleweed and Leap works virtually hassle-free in multi boot configurations when configured with unique static host names.

Hi and thanks for the reply.
I didn’t forget but I realise the details of my failing connection start at line 600 on the posted text.

On previous occasions I have been condemned for sending too little information so I have sent all the data.
I realise now I should have posted two different files, one working and one not connecting to wan. I apologise for that.

There is very little difference I can see until I get to line 656 when ip neigh shows an incomplete entry. It seems to me that my own setup is OK as far as it goes but beyond the first switch is well beyond my knowledge and since I have not changed anything on the switch vlan configurations I am trying to understand what windows does that at present my Leap 15.4 connection does not.

Thanks for your patience.

And in the first lines everything appears to work. What changed? Just suddenly interface stopped to work?

Sending output of random commands is of little use unless you explain why and when you used these commands.

Hi Karl,
Many thanks for your reply and believe me I am willing, although less able to find out what causes my problem so of course I read the thread you linked for which many thanks. I note that the problem you cited is rather different in that the OP was using a wireless connection and I confess I couldn’t understand the cause of the problem, only a solution which worked but only by setting different hostnames on the same machine which would not be well received here.

The background for this and the environment in which I am working might be helpful. At the UTM, which from my viewpoint is the primary router, all the interfaces and the DHCP and DNS servers are set up on the UTM from the management network. From the UTM there are ten working interfaces set up on different subnets but I am only trying to fix my own private subnet which has a static route set from the management interface.

On my private subnet the DNS and DHCP servers are enabled on the UTM and the subnet which has 128 addresses of which the first 32 are not available for dhcp because they are used for static configurations such as printers and fixed workstations. The rest are for laptops and mobile phones etc. The UTM connects to the first switch (Sw1) which is configured as an access port on my subnet and the route is connected using vlan trunks ending in SW8 in my room where an access port on my subnet connects to my workstation.

Before you ask, no there are not 7 switches in the chain, the numbering is by order of installation not route. My connecting switch is only one hop away or possibly two, I would have to check my notes on site.

For reasons I do not yet understand I had no difficulty until I moved my workstation to my private room which introduced at least one additional switch hop to the route and the problem I have is only now as described in my first post on this thread.

My workstation has a static IP when configured on Leap 15.4 but when the machine is configured using windows I have tried it with both static and dynamic IP. It made no difference and I am thinking the issue is more to do with the binding of mac address and IP in a cache somewhere which is only cleared if the power is disconnected unless forced.

These are just my ignorant thoughts but am stuck for ideas so if you have any suggestions please advise.

@Budgie2 Get a USB to Ethernet device (and a small unmanaged switch) or a PCIeX1 Ethernet card, use each interface for it’s own connection?

So what tasks are you performing in Windows, if nothing hardware critical just use a virtual machine to run? That’s all I use here, virt-manager to attach devices works fine…

What changed was that I restarted after working on windows and re-booted to Leap 15.4. Sorry if I did not make it clear.

The commands are not random but trying to follow the same logic which I recall you have suggested in similar circumstances:-
ip a
ip r
ping -c1
ip neigh

It is possible I might have repeated some or used a slightly different order but my logic has been trying to pin down the problem starting from my NIC. The fact that the route does not extend beyond the default gateway is the problem.

Hi Dean,
Thanks for the info regarding iproute2. I had only asked about arp in ignorance because most of what I had read when trying to understand my problem referred to arp. Thank you for eventually pointing me forward.

I started a new thread because I had dug a deep rabbit hole as you put it while trying to understand what was going on. I felt that starting a new thread might save others from wasting time on my blind holes. Sorry if this has spoilt your appetite and I understand. I do hope this will not discourage you from answering other questions of mine in future.

Hi Malcolm,
Yes, I have the dongle and a spare port on the switch. I did try using the dongle a while ago thinking there might be a problem with my NIC but at that time I had been trying to use the same connection for both systems. I shall need to think a bit more about how to have each system only using a dedicated connection. My initial thoughts are that I would have to make the Leap 15.4 connection remain with static IP and specific to eth0 and have the windows machine use eth1 with dhcp and dynamic address but I can try with both and see how I get on.

There is nothing I do in windows that is at all hardware critical and I do very little but occasionally somebody asks me to do something for the office which requires windows. One recent example was scanning using the new HP printer which as yet I have not been able to set up for Leap15.4. This is no longer an issue as I have now set up the new printer on all the windows computers that are relevant. I have been putting off virtual machines until I have the reorganisation changes finalised.

As ever I am grateful to you once more for making positive suggestions which will solve my immediate problem and now that the machine is in my room I can, if necessary, just unplug it between boots.

I have however raised an issue which has some underlying technical problem and I really would like to understand what is going on and why windows works and leap 15.4 does not. I am reading what I can between work and of course shall post details of the cause and solution as soon as found. Many thanks again,

@Budgie2 In windows, just configure for example the USB->Ethernet device for use, leave the other onboard NIC un-configured. Then in openSUSE Leap 15.4 configure the onboard NIC for use and leave the USB one un-configured (delete from NM).

LAN connections can be shaky for different reasons. On one LAN power-line communication would hang until the user detached the network cable and again attached it. Moving the adapters eventually fixed the problem.

You may try DHCP on Leap 15.4. You may spoof the hardware address: MAC Address Spoofing in NetworkManager 1.4.0 – Thomas Haller's Blog

In this case more usable were two different files with commands before and after restart with clear indication what and when you did.

Anyway - the interface configuration after reboot looks correct. It is possible that configuration from previous lease was reused but those commands do not answer that.

Reboot in “good” condition, capture

journalctl -b --no-pager
ethtool eth0

Then reboot in “bad” condition, do the same. This may give some clue.

It is quite possible that Windows leaves interface in an “unexpected” state. One reason would be Wake-on-LAN. See if you can disable it in Windows and if this changes anything.

You also included extremely long output of ss which does not add anything to troubleshooting outgoing connectivity.

Hi arvidjaar, many thanks. I have done as you suggested and have omitted the ss command. The boot logs are quite long with the additional commands at the end. Sorry I made an error with the working system with the first ping address but corrected it and all the short responses are at the end. Here are the results from the connected system:-

Connected system

I believe the non connected system file has the same commands in the right order, again with the boot log first and short responses at the end. Here are the results:-

I hope this all works OK

Had some trouble with pastes so if they don’t work I shall repeat.
Meanwhile I had a chance to do some reading on iproute2 manual digest. There is a lot to it!

Both are identical as far as I can tell. Actually on working system the first ping fails as well and on non-working system there is only one ping shown. So up to this point they are really identical.

Have you possibility to capture network traffic on your DHCP server?