Network Configuration Help?....

Here is my setup:

Dynex Router:
----labtop - XP Pro (192.168.0.102)
----Desktop - Vista Ultimate (192.168.0.101)
----Server - openSuse 11.2 (192.168.0.100)
--------VBox
------------Guest - Vista Ultimate (192.168.56.100)
------------Guest - XP Pro. (192.168.56.101)
------------Guest - openSuse 11.2 (Drupal Dev) (192.168.56.102)
------------Guest - openSuse 11.2 (Drupal Pro) (192.168.56.103)

Each Guest has a NIC as 1) Host Only and 2) NAT except for the two Drupal CMS’s has the Bridge, because I want to be able to connect to the Web Server from either cpu.

The two openSuse’s IP on the Bridge is, 192.168.0.103 and 4 respectively. My problems, is I want both of them to have Static IP’s, but I lose connection to the internet. Dynamically they work fine. I want the Static, because I will be coding the IP’s in the host’s file.

So, what suggesting can you give me in order for them to work right?

Well I figured out how to statically configure my network. I had to configure and use the Network Manager Mod, and select this option in the Network Card Mod.

BUT! that was easy for the Server, Desktop, Labtop, VM Vista and VM XP…

Now I need to figure out how to use it for the openSuse VM’s, because I’m assuming it will work the same way by creating two network connections and hoping Network Card Mod will properly set both eth0 and eth1 to the right one.

Anyone Guru’s out there, with any input on this?

Alright! I have everything networked! I have my LAN and WAN working on both sides of the network environment! Yeppee!

I had to create network connections using the Network Manager Mod for the openSuse VM’s. So they work just the same as the connections in the Windows environment.

Whew! I’m a happy camper and now I can concentrate on Drupal CMS development!..

How do you create a Loopback Interface with the Network Manager? Is it the same way you create the NIC Connection?

I get the missing Loopback message during bootup.

…because for some reason My Static IP’s are not being assigned to both the openSuse VM’s and I’m getting colliding IP’s and My IP’s are not being assigned, but auto assigned!

Could the absence of the Loopback be the problem?

Why is my NIC remains bound to .101 when my static IP’s are .105 (eth1) and .103 (eth0)? How do I clear this?


Dec  3 10:39:15 mysqlserver kernel: imklog 4.4.1, log source = /proc/kmsg started.
Dec  3 10:39:15 mysqlserver rsyslogd: [origin software="rsyslogd" swVersion="4.4.1" x-pid="1791" x-info="http://www.rsyslog.com"] (re)start
Dec  3 10:39:15 mysqlserver kernel:     9.328566] fuse init (API version 7.12)
Dec  3 10:39:15 mysqlserver kernel:    11.406655] type=1505 audit(1259865545.487:2): operation="profile_load" pid=803 name=/bin/ping
Dec  3 10:39:15 mysqlserver kernel:    11.446730] type=1505 audit(1259865545.527:3): operation="profile_load" pid=804 name=/sbin/klogd
Dec  3 10:39:15 mysqlserver kernel:    11.513237] type=1505 audit(1259865545.594:4): operation="profile_load" pid=805 name=/sbin/syslog-ng
Dec  3 10:39:15 mysqlserver kernel:    11.581377] type=1505 audit(1259865545.662:5): operation="profile_load" pid=806 name=/sbin/syslogd
Dec  3 10:39:15 mysqlserver kernel:    11.647477] type=1505 audit(1259865545.728:6): operation="profile_load" pid=807 name=/usr/sbin/avahi-daemon
Dec  3 10:39:15 mysqlserver kernel:    11.706535] type=1505 audit(1259865545.787:7): operation="profile_load" pid=808 name=/usr/sbin/identd
Dec  3 10:39:15 mysqlserver kernel:    11.767568] type=1505 audit(1259865545.848:8): operation="profile_load" pid=809 name=/usr/sbin/mdnsd
Dec  3 10:39:15 mysqlserver kernel:    11.834897] type=1505 audit(1259865545.915:9): operation="profile_load" pid=810 name=/usr/sbin/nscd
Dec  3 10:39:15 mysqlserver kernel:    11.916258] type=1505 audit(1259865545.997:10): operation="profile_load" pid=811 name=/usr/sbin/ntpd
Dec  3 10:39:15 mysqlserver kernel:    11.981581] type=1505 audit(1259865546.062:11): operation="profile_load" pid=812 name=/usr/sbin/traceroute
Dec  3 10:39:18 mysqlserver rchal: CPU frequency scaling is not supported by your processor.
Dec  3 10:39:18 mysqlserver rchal: boot with 'CPUFREQ=no' in to avoid this warning.
Dec  3 10:39:18 mysqlserver rchal: Cannot load cpufreq governors - No cpufreq driver available
Dec  3 10:39:26 mysqlserver kernel:    32.158338] [drm] Initialized drm 1.1.0 20060810
Dec  3 10:39:26 mysqlserver kernel:    32.163706] [drm] Initialized vboxvideo 1.0.0 20090303 for 0000:00:02.0 on minor 0
Dec  3 10:39:32 mysqlserver ifdown:     eth0      device: Intel Corporation 82540EM Gigabit Ethernet Controller (rev 02)
Dec  3 10:39:34 mysqlserver ifdown:     eth1      device: Intel Corporation 82540EM Gigabit Ethernet Controller (rev 02)
Dec  3 10:39:47 mysqlserver init: Entering runlevel: 5
Dec  3 10:39:48 mysqlserver kernel: Kernel logging (proc) stopped.
Dec  3 10:39:48 mysqlserver rsyslogd: [origin software="rsyslogd" swVersion="4.4.1" x-pid="1791" x-info="http://www.rsyslog.com"] exiting on signal 15.
Dec  3 10:39:48 mysqlserver kernel: imklog 4.4.1, log source = /proc/kmsg started.
Dec  3 10:39:48 mysqlserver kernel:    54.223892] vboxvfs: Successfully loaded version 3.0.6_OSE (interface 0x00010004)
Dec  3 10:39:48 mysqlserver rsyslogd: [origin software="rsyslogd" swVersion="4.4.1" x-pid="3619" x-info="http://www.rsyslog.com"] (re)start
Dec  3 10:39:48 mysqlserver kernel:    54.468797] ip6_tables: (C) 2000-2006 Netfilter Core Team
Dec  3 10:39:48 mysqlserver kernel:    54.750241] ip_tables: (C) 2000-2006 Netfilter Core Team
Dec  3 10:39:48 mysqlserver kernel:    54.786202] nf_conntrack version 0.5.0 (1917 buckets, 7668 max)
Dec  3 10:39:48 mysqlserver kernel:    54.788847] CONFIG_NF_CT_ACCT is deprecated and will be removed soon. Please use
Dec  3 10:39:48 mysqlserver kernel:    54.788852] nf_conntrack.acct=1 kernel parameter, acct=1 nf_conntrack module option or
Dec  3 10:39:48 mysqlserver kernel:    54.788856] sysctl net.netfilter.nf_conntrack_acct=1 to enable it.
Dec  3 10:39:49 mysqlserver SuSEfirewall2: batch committing...
Dec  3 10:39:49 mysqlserver kdm_config[3675]: Multiple occurrences of key 'UseTheme' in section [X-*-Greeter] of /usr/share/kde4/config/kdm/kdmrc
Dec  3 10:39:49 mysqlserver SuSEfirewall2: Firewall rules set to CLOSE.
Dec  3 10:39:50 mysqlserver kernel: Kernel logging (proc) stopped.
Dec  3 10:39:50 mysqlserver rsyslogd: [origin software="rsyslogd" swVersion="4.4.1" x-pid="3619" x-info="http://www.rsyslog.com"] exiting on signal 15.
Dec  3 10:39:50 mysqlserver kernel: imklog 4.4.1, log source = /proc/kmsg started.
Dec  3 10:39:50 mysqlserver rsyslogd: [origin software="rsyslogd" swVersion="4.4.1" x-pid="3744" x-info="http://www.rsyslog.com"] (re)start
Dec  3 10:39:50 mysqlserver auditd[3791]: Started dispatcher: /sbin/audispd pid: 3793
Dec  3 10:39:50 mysqlserver audispd: priority_boost_parser called with: 4
Dec  3 10:39:50 mysqlserver audispd: max_restarts_parser called with: 10
Dec  3 10:39:50 mysqlserver audispd: af_unix plugin initialized
Dec  3 10:39:50 mysqlserver audispd: audispd initialized with q_depth=80 and 1 active plugins
Dec  3 10:39:50 mysqlserver auditd[3791]: Init complete, auditd 1.7.13 listening for events (startup state disable)
Dec  3 10:39:52 mysqlserver kernel:    57.951427] BIOS EDD facility v0.16 2004-Jun-25, 0 devices found
Dec  3 10:39:52 mysqlserver kernel:    57.951427] EDD information not available.
Dec  3 10:39:53 mysqlserver avahi-daemon[3954]: Found user 'avahi' (UID 105) and group 'avahi' (GID 107).
Dec  3 10:39:53 mysqlserver avahi-daemon[3954]: Successfully dropped root privileges.
Dec  3 10:39:53 mysqlserver avahi-daemon[3954]: avahi-daemon 0.6.25 starting up.
Dec  3 10:39:53 mysqlserver avahi-daemon[3954]: Loading service file /etc/avahi/services/sftp-ssh.service.
Dec  3 10:39:53 mysqlserver avahi-daemon[3954]: Loading service file /etc/avahi/services/ssh.service.
Dec  3 10:39:53 mysqlserver avahi-daemon[3954]: Network interface enumeration completed.
Dec  3 10:39:53 mysqlserver avahi-daemon[3954]: Registering HINFO record with values 'X86_64'/'LINUX'.
Dec  3 10:39:53 mysqlserver avahi-daemon[3954]: Server startup complete. Host name is mysqlserver.local. Local service cookie is 3390400936.
Dec  3 10:39:53 mysqlserver avahi-daemon[3954]: Service "mysqlserver" (/etc/avahi/services/ssh.service) successfully established.
Dec  3 10:39:53 mysqlserver avahi-daemon[3954]: Service "SFTP File Transfer on mysqlserver" (/etc/avahi/services/sftp-ssh.service) successfully established.
Dec  3 10:39:56 mysqlserver network: Starting the NetworkManager
Dec  3 10:39:56 mysqlserver modem-manager: Loaded plugin Novatel
Dec  3 10:39:56 mysqlserver modem-manager: Loaded plugin Huawei
Dec  3 10:39:56 mysqlserver modem-manager: Loaded plugin Sierra
Dec  3 10:39:56 mysqlserver modem-manager: Loaded plugin ZTE
Dec  3 10:39:56 mysqlserver modem-manager: Loaded plugin Gobi
Dec  3 10:39:56 mysqlserver modem-manager: Loaded plugin Ericsson MBM
Dec  3 10:39:56 mysqlserver modem-manager: Loaded plugin MotoC
Dec  3 10:39:56 mysqlserver modem-manager: Loaded plugin Generic
Dec  3 10:39:56 mysqlserver modem-manager: Loaded plugin Nokia
Dec  3 10:39:56 mysqlserver modem-manager: Loaded plugin Option
Dec  3 10:39:56 mysqlserver modem-manager: Loaded plugin Option High-Speed
Dec  3 10:39:58 mysqlserver /usr/sbin/cron[4363]: (CRON) STARTUP (V5.0)
Dec  3 10:39:58 mysqlserver smartd[4388]: smartd 5.39 2009-08-08 r2872~ [x86_64-unknown-linux-gnu] (openSUSE RPM)#012Copyright (C) 2002-9 by Bruce Allen, http://smartmontools.sourceforge.net#012
Dec  3 10:39:58 mysqlserver smartd[4388]: Opened configuration file /etc/smartd.conf
Dec  3 10:39:58 mysqlserver smartd[4388]: Drive: DEVICESCAN, implied '-a' Directive on line 26 of file /etc/smartd.conf
Dec  3 10:39:58 mysqlserver smartd[4388]: Configuration file /etc/smartd.conf was parsed, found DEVICESCAN, scanning devices
Dec  3 10:39:58 mysqlserver smartd[4388]: Device: /dev/sda, type changed from 'scsi' to 'sat'
Dec  3 10:39:58 mysqlserver smartd[4388]: Device: /dev/sda [SAT], opened
Dec  3 10:39:58 mysqlserver smartd[4388]: Device: /dev/sda [SAT], not found in smartd database.
Dec  3 10:39:58 mysqlserver smartd[4388]: Device: /dev/sda [SAT], lacks SMART capability
Dec  3 10:39:58 mysqlserver smartd[4388]: Device: /dev/sda [SAT], to proceed anyway, use '-T permissive' Directive.
Dec  3 10:39:58 mysqlserver smartd[4388]: Unable to monitor any SMART enabled devices. Try debug (-d) option. Exiting...
Dec  3 10:39:59 mysqlserver smbd[4450]: [2009/12/03 10:39:59,  0] smbd/server.c:457(smbd_open_one_socket)
Dec  3 10:39:59 mysqlserver smbd[4450]:   smbd_open_once_socket: open_socket_in: Address already in use
Dec  3 10:39:59 mysqlserver smbd[4450]: [2009/12/03 10:39:59,  0] smbd/server.c:457(smbd_open_one_socket)
Dec  3 10:39:59 mysqlserver smbd[4450]:   smbd_open_once_socket: open_socket_in: Address already in use
Dec  3 10:40:00 mysqlserver SuSEfirewall2: Setting up rules from /etc/sysconfig/SuSEfirewall2 ...
Dec  3 10:40:01 mysqlserver kernel:    66.934331] ADDRCONF(NETDEV_UP): eth1: link is not ready
Dec  3 10:40:01 mysqlserver kernel:    66.943683] ADDRCONF(NETDEV_UP): eth0: link is not ready
Dec  3 10:40:01 mysqlserver kernel:    66.957022] e1000: eth1 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
Dec  3 10:40:01 mysqlserver kernel:    66.958032] e1000: eth0 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: RX
Dec  3 10:40:01 mysqlserver kernel:    66.959593] ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Dec  3 10:40:01 mysqlserver kernel:    66.960733] ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
Dec  3 10:40:01 mysqlserver dhclient: Internet Systems Consortium DHCP Client V3.1.2p1
Dec  3 10:40:01 mysqlserver dhclient: Copyright 2004-2009 Internet Systems Consortium.
Dec  3 10:40:01 mysqlserver dhclient: All rights reserved.
Dec  3 10:40:01 mysqlserver dhclient: For info, please visit http://www.isc.org/sw/dhcp/
Dec  3 10:40:01 mysqlserver dhclient: 
Dec  3 10:40:01 mysqlserver dhclient: Internet Systems Consortium DHCP Client V3.1.2p1
Dec  3 10:40:01 mysqlserver dhclient: Copyright 2004-2009 Internet Systems Consortium.
Dec  3 10:40:01 mysqlserver dhclient: All rights reserved.
Dec  3 10:40:01 mysqlserver dhclient: For info, please visit http://www.isc.org/sw/dhcp/
Dec  3 10:40:01 mysqlserver dhclient: 
Dec  3 10:40:01 mysqlserver kernel:    67.176935] NET: Registered protocol family 17
Dec  3 10:40:01 mysqlserver dhclient: Listening on LPF/eth1/08:00:27:84:3a:11
Dec  3 10:40:01 mysqlserver dhclient: Sending on   LPF/eth1/08:00:27:84:3a:11
Dec  3 10:40:01 mysqlserver dhclient: Sending on   Socket/fallback
Dec  3 10:40:01 mysqlserver dhclient: Listening on LPF/eth0/08:00:27:3a:26:3e
Dec  3 10:40:01 mysqlserver dhclient: Sending on   LPF/eth0/08:00:27:3a:26:3e
Dec  3 10:40:01 mysqlserver dhclient: Sending on   Socket/fallback
Dec  3 10:40:02 mysqlserver dhclient: DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 3
Dec  3 10:40:02 mysqlserver dhclient: DHCPOFFER from 192.168.56.100
Dec  3 10:40:02 mysqlserver kernel:    67.920519] martian source 255.255.255.255 from 192.168.56.100, on dev eth0
Dec  3 10:40:02 mysqlserver kernel:    67.920527] ll header: ff:ff:ff:ff:ff:ff:08:00:27:40:41:42:08:00
Dec  3 10:40:02 mysqlserver SuSEfirewall2: batch committing...
Dec  3 10:40:02 mysqlserver avahi-daemon[3954]: Registering new address record for fe80::a00:27ff:fe84:3a11 on eth1.*.
Dec  3 10:40:02 mysqlserver avahi-daemon[3954]: Registering new address record for fe80::a00:27ff:fe3a:263e on eth0.*.
Dec  3 10:40:02 mysqlserver SuSEfirewall2: Firewall rules successfully set
Dec  3 10:40:03 mysqlserver dhclient: DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 2
Dec  3 10:40:03 mysqlserver kernel:    68.929349] martian source 255.255.255.255 from 192.168.0.1, on dev eth1
Dec  3 10:40:03 mysqlserver kernel:    68.929433] ll header: ff:ff:ff:ff:ff:ff:00:13:46:b9:2f:8e:08:00
Dec  3 10:40:03 mysqlserver dhclient: DHCPOFFER from 192.168.0.1
Dec  3 10:40:07 mysqlserver dhclient: DHCPREQUEST on eth0 to 255.255.255.255 port 67
Dec  3 10:40:07 mysqlserver kernel:    72.926114] martian source 255.255.255.255 from 192.168.56.100, on dev eth0
Dec  3 10:40:07 mysqlserver kernel:    72.926133] ll header: ff:ff:ff:ff:ff:ff:08:00:27:40:41:42:08:00
Dec  3 10:40:07 mysqlserver dhclient: DHCPACK from 192.168.56.100
Dec  3 10:40:07 mysqlserver dhclient: bound to 192.168.56.101 -- renewal in 1785 seconds.
Dec  3 10:40:07 mysqlserver avahi-daemon[3954]: Joining mDNS multicast group on interface eth0.IPv4 with address 192.168.56.101.
Dec  3 10:40:07 mysqlserver avahi-daemon[3954]: New relevant interface eth0.IPv4 for mDNS.
Dec  3 10:40:07 mysqlserver avahi-daemon[3954]: Registering new address record for 192.168.56.101 on eth0.IPv4.
Dec  3 10:40:08 mysqlserver dhclient: DHCPREQUEST on eth1 to 255.255.255.255 port 67
Dec  3 10:40:08 mysqlserver dhclient: DHCPACK from 192.168.0.1
Dec  3 10:40:08 mysqlserver kernel:    73.926452] martian source 255.255.255.255 from 192.168.0.1, on dev eth1
Dec  3 10:40:08 mysqlserver kernel:    73.926465] ll header: ff:ff:ff:ff:ff:ff:00:13:46:b9:2f:8e:08:00
Dec  3 10:40:08 mysqlserver dhclient: bound to 192.168.0.101 -- renewal in 1563 seconds.
Dec  3 10:40:08 mysqlserver avahi-daemon[3954]: Joining mDNS multicast group on interface eth1.IPv4 with address 192.168.0.101.
Dec  3 10:40:08 mysqlserver avahi-daemon[3954]: New relevant interface eth1.IPv4 for mDNS.
Dec  3 10:40:08 mysqlserver avahi-daemon[3954]: Registering new address record for 192.168.0.101 on eth1.IPv4.
Dec  3 10:40:12 mysqlserver kernel:    78.184597] eth1: no IPv6 routers present
Dec  3 10:40:12 mysqlserver kernel:    78.363495] eth0: no IPv6 routers present
Dec  3 10:40:18 mysqlserver python: hp-systray[4986]: warning: No hp: or hpfax: devices found in any installed CUPS queue. Exiting.
Dec  3 10:40:22 mysqlserver SuSEfirewall2: Setting up rules from /etc/sysconfig/SuSEfirewall2 ...
Dec  3 10:40:23 mysqlserver SuSEfirewall2: batch committing...
Dec  3 10:40:24 mysqlserver SuSEfirewall2: Firewall rules successfully set
Dec  3 10:40:24 mysqlserver kernel:    90.473168] RPC: Registered udp transport module.
Dec  3 10:40:24 mysqlserver kernel:    90.473251] RPC: Registered tcp transport module.
Dec  3 10:40:24 mysqlserver kernel:    90.538879] Slow work thread pool: Starting up
Dec  3 10:40:24 mysqlserver kernel:    90.539066] Slow work thread pool: Ready
Dec  3 10:40:24 mysqlserver kernel:    90.539220] FS-Cache: Loaded
Dec  3 10:40:24 mysqlserver kernel:    90.588663] FS-Cache: Netfs 'nfs' registered for caching
Dec  3 10:40:24 mysqlserver sm-notify[5219]: Already notifying clients; Exiting!
Dec  3 10:42:02 mysqlserver su: (to root) administrator on /dev/pts/0

This doen’t make any sense at all! I have no control in setting static IP’s in a VM using openSuse!.. >:(

When I use the Network Manager Mod, the IP is assigned Dynamic…, when I use the Network Card Mod I get no Internet connection!

What the heck is going on!

both the Windows VM’s are working fine! So what is openSuse doing, is it having problems as a VM?

I ran a test just to make sure if it was me or openSuse IP is unable to be configure in a VM. I installed th 9.10 version of Ubuntu and it works fine and it’s Network Connection Mod is very simple. Just as simple as Windows.

Hello openSuse! did you read this and mark this down in your this to do? This is critical for businesses that operate in a virtual environment like me.

I need to be able to assign Status IP’s for my network to work the way I need it to be. The server works fine for me, but I need VM’s working… :’(

On 12/05/2009 12:56 PM, VcDeveloper1 wrote:
>
> Hello openSuse! did you read this and mark this down in your this to do?
> This is critical for businesses that operate in a virtual environment
> like me.
>
> I need to be able to assign Status IP’s for my network to work the way
> I need it to be. The server works fine for me, but I need VM’s
> working… :’(

Half of my openSUSE machines use static (I assume that is what you
meant.) IPs. For them, the network is controlled with the “traditional
ifup” method, and the IP, routing, and nameserver info is input with
YaST using the “Network Devices” => “Network Settings” GUI.

Well, I used the ifup, but no clue to how to use it, because when I did I lost connection to the internet. I still need the connection for my VM’s even though there will be no incoming connections directly to them.

However, I will be routing HTTP through my Dynex router to my VM Web Server only.

…and this is a Workgroup network, so simple static IP naming should be easy.

On 12/05/2009 04:16 PM, VcDeveloper1 wrote:
>
> Well, I used the ifup, but no clue to how to use it, because when I did
> I lost connection to the internet. I still need the connection for my
> VM’s even though there will be no incoming connections directly to them.

Using ifup AND static IPs does make you hit ALL the boxes in the
configuration. It is not as easy as just clicking on an NM applet. If
you want that, you will have to set the route and the name server as I
told you in my previous post. No, I cannot make it any clearer.

Remember that in VBox VM, if you want an interface to have a static IP, you need to choose Bridged adapter for its interface, not NAT.

Static IPs work fine in openSUSE, and have for as long as the distro has existed. It’s something your end.

All my VM’s have two NIC’s…, 1) for Host Only, and 2) for Bridge Adapter…, everything works fine with ifup until I enter the IP’s manully as so:

192.168.0.105 - 255.255.255.0 - myhostname

what else am I missing, where do I enter the “Default Gateway” and the “DNS Server”?

because without these two settings there is no way I can connect to the internet!

I like side before I don’t have a clue as to how to use this ifup! I came from a Windows environment and I am use to the Network Manager style of networking.

I have one Ubunto 9.10 and three Xubuntu 9.10 VM’s running with a snap using the Network Manager with no problem, and just using one NIC as a “Bridge”, so why doesn’t it work for openSuse?

I chosed to use the Network Manager in the settings of “ifup” and it doesn’t work and it needs to be fixed! I like openSuse, but I can’t use it…

and I am not talking about hitting all the VM’s…, I’m talking about connection to the internet using Static IP’s from all the them! Please read my post carefully so we can resolve the problem…, it shouldn’t have taken this many posts to solve this…

On Sat December 5 2009 08:06 pm, VcDeveloper1 wrote:

>
> All my VM’s have to NIC’s…, 1) for Host Only, and 2) for Bridge
> Adapter…, everything works fine with ifup until I enter the IP’s
> manully as so:
>
> 192.168.0.105 - 255.255.255.0 - myhostname
>
> what else amd I missing, where do I enter the “Default Gateway” and the
> “DNS Server”?
>
> because without these two settings there is no way I can connect to the
> internet!
>
> I like side before I don’t have a clue as to how to use this ifup! I
> came from a Windows environment and I am use to the Network Manager
> style of networking.
>
> I have one Ubunto 9.10 and three Xubuntu 9.10 VM’s running with a snap
> using the Network Manager with no problem, so why doesn’t it work for
> openSuse?
>
> I chosed to use the Network Manager in the settings of “ifup” and it
> doesn’t work and it needs to be fixed!
>
>
VcDeveloper1;

Go to YaST–>Network Settings. You can then choose the tabs
for “Hostname/DNS” and “Routing”. Under Hostname/DNS assign a hostname and
enter your ISPs DNS server’s IP(s). Under “Routing” enter the gateway IP.
You can find your ISP’s DNS server(s) from their web site.


P. V.
“We’re all in this together, I’m pulling for you.” Red Green

On 12/05/2009 08:06 PM, VcDeveloper1 wrote:
>
> All my VM’s have to NIC’s…, 1) for Host Only, and 2) for Bridge
> Adapter…, everything works fine with ifup until I enter the IP’s
> manully as so:
>
> 192.168.0.105 - 255.255.255.0 - myhostname
>
> what else amd I missing, where do I enter the “Default Gateway” and the
> “DNS Server”?
>
> because without these two settings there is no way I can connect to the
> internet!
>
> I like side before I don’t have a clue as to how to use this ifup! I
> came from a Windows environment and I am use to the Network Manager
> style of networking.
>
> I have one Ubunto 9.10 and three Xubuntu 9.10 VM’s running with a snap
> using the Network Manager with no problem, so why doesn’t it work for
> openSuse?
>
> I chosed to use the Network Manager in the settings of “ifup” and it
> doesn’t work and it needs to be fixed!

NetworkManager DOES work, but it is difficult to get a static IP
with it.

To use ifup, use YaST “Network Devices” => “Network Settings” and
select “ifup” under the “Global” tab. Also unselect the “Change
Default Route with DHCP”. Next select the “Overview” tab and highlight
the NIC you want to configure. Click “Edit” and select a static
address. Enter the desired IP and the subnet mask. I am assuming that
you know how to do that. After you finish that section, press next. On
the next screen, click “Routing” and enter the default IPv4 Gateway
address. Next select the Hostname/DNS tab and enter your
nameserver(s). At this point you can close the screen.

aaaawh Finally! Why you waited so long…, could saved me a lot of nail biting and hair pulling… :open_mouth:

Thanks lwfinger and venzkep! Your My Heroes! :wink: