Network card problem. Atheros 1803

Hi everyone,

I'm a new linux, opensuse user. My network card doesn't work in opensuse 11.4. The device is an Atheros 1803. In someplace I've read that the kernel of opensuse 11.4 doesn't work with this kernel. Anyone knows why? Which is the solution?

Now, I’m writting all the things that I did. Firs I installed opensuse 12.1. It works perfectly. After that I tried to install the problematic software (Labview). This software only works with kernel 2.4.x or 2.6.x. Opensuse 12.1, as you know, has a 3.x kernel. I removed it and I installed opensuse 11.4. Then, I installed the nvidia graphic card and the Labview. All works fine, but my network integrated card didn’t work. I red that I need upgrade the kernel. Then I learnt how and upgraded the kernel to 2.6.38. The network card works but the nvidia doesn’t work. Anyone know why? Which is the solution to work all the hardware in the computer. My computer is Dell XPS 14Z.

Thanks and sorry for my english.

Well not sure why you can’t get both to work, but you could take your kernel version up to 3.4.4 if you wanted using this: S.A.K.C. - SUSE Automated Kernel Compiler - Version 2.75 - Blogs - openSUSE Forums

You could install the latest nVIDIA driver with info from these two sites: Installing the nVIDIA Video Driver the Hard Way - Blogs - openSUSE Forums AND LNVHW - Load NVIDIA (driver the) Hard Way from runlevel 3 - Version 1.45 - Blogs - openSUSE Forums

I am running the latest kernel and nVIDIA driver and both work just fine, but I don’t have the same network interface as you do.

Thank You,

Hi all,

I solved it compiling a driver from