Network card - Kernel device not present

Dear all

I am trying to install 10.3 on a new HP Pavilion box, dual booting with Vista. The install proceeds until it reaches the network config, when it fails because the ‘kernel device is not present’. Trying to configure the card post-install with Yast produces the same result.

Vista tells me that the card is Nvidia, so I’ve downloaded the latest drivers from their site as rpm’s and run them (although they’re labelled 10.2), but no success.

‘Hardware Information’ in Yast finds the card OK.


are you trying to install the drivers post-install of SuSE or pre-install ?



Thanks for your quick response. I tried to install the drivers post-install. I don’t know how to install them pre-install - I downloaded an ISO onto a CD. How do you put the drivers onto the CD?


before we deal with drivers, is this an wired or wireless device ? if the device is recognized by YaST - hardware, have you had a look in YaST - network devices - network cards ? post the output of **/sbin/lspci -v ** as well, just so we can check


The device is wired. Yast ‘Network card’ shows one device - Ethernet Network Card Not configured. The detail shows

Ethernet Network Card (not connected)
BusID 0000:00:0f.0

Unable to configure the network card because the kernel device is not present

I can’t paste the output of /sbin/lspci -v, but it says:

00:0f.0 Ethernet controller> nVdia Corporation Unknown device 07dc (rev a2)
Subsystem: Hewlett-Packard Company Unknown device 2a65
Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 15
Memory at efffd000

… etc etc…

I have tried adding a new card in Yast, but no effect, as:

Ethernet Network Card DHCP

Detail shows:

Ethernet Network Card (not connected)

Device Name: eth-eth-bus-pcmcia
Started automatically at boot
IP address assigned using DHCP


It may be possible to use ndiswrapper with your card. Even though ndiswrapper is designed for use with wireless cards, it does work with some wired cards.

When you have installed the driver with ndiswrapper, run as root: ndiswrapper -l. This will should say “blah blah blah alternative driver: XXXX”. Blacklist “XXXX” by adding “blacklist XXXX” to /etc/modprobe.d/blacklist. (XXXX is the name of the driver as displayed by ndiswrapper). Restart, and it might work!


Edit: configure in YaST before restarting


I’ll try this tomorrow. I’ll have to play boot and boot because I don’t have ndiswrapper, so I’ll have to download it in Vista and copy it over. I’m not a command-liner, but hey, ‘where fools fear to tread’ etc etc.

Or should I wait for 11.0???

Thanks very much


I would wait for 11.0 anyway.

The command line for ndiswrapper is very easy to use, because it can be as simple as copying text of the ndiswrapper howto into the console.

Also: I would get familiar with the command line anyway, because it is REALLY useful.


Did you solve this issue? I am having the same problem (not connected), and it is driving me crazy. Any helps are highly appreciated.

Thanks so much,