Network but no Internet > OpenSuse 11.0

Running OpenSuse 11.0 on VMWare Server 1.0.10 on a windows 7 embedded.

The windows 7 machine has network and internet,
the OpenSuse on VMWare has network but doesn’t have internet.
DNS Setup:

IP Setup:


Network Settings on VMWare:

Anyone got any ideas as to why the VM won’t connect to the internet? I’ve searched all over and tried all sorts of the proposed solutions to problems like this, but they never seem to fix it.

openSUSE 11.0 has been discontinued since 2010, it has no support and there are absolutely no security patches or software for it - it’s dead as a rock.

I figured that much out myself when I found nothing on the entire internet that could help, but I also figured that there MIGHT be someone who’s worked with an error like this in the past.

Funny mine did the same thing since an update, network was showing, but no email or web. I am not sure you can even get an update with version 11 though?

Aside from reluctance which might encourage you to continue to build a <new virtual machine> based on openSUSE 11.0 (wouldn’t it be just as easy to create a new machine using 13.1?) and the fact that VMware Server itself has not been supported for… over 5 years?

The problem almost certainly is a virtual networking configuration since you have another Guest that works. Compare the two. You’ve made screenshots of your openSUSE configuration, compare with careful detail what your Windows networking configuration looks like.

Some common troubleshooting steps you should try…

  • Know that name resolution can be an issue on top of a working or non-working IP network so should be considered separately. So, Ping the DG by IP address and then beyond the DG <by IP address> and not names to verify basic networking is working. Once you’re certain there isn’t an IP address networking problem you can repeat your tests pinging names.

  • Try a different network. You’re configured for bridging mode at the moment. Try NAT (using DHCP). You can always switch back but you’re narrowing possibilities.

  • If the problem is DNS, verify the following file displays the correct ip address (run the following command)

cat /etc/resolv.conf
  • If the problem is DNS, try a different DNS. You’re currently pointing to a DNS in you network. Remove or change the order of your DNS. In general, only the first entry will be used, the others are rarely if ever used.

Good Luck,

Here’s a sample of pinging the router and then pinging’s IP address from the VM.

I tested changing the DNS to be another set, and no change. I even had it mimic the settings from our image and nothing worked.

Using NAT didn’t seem to change anything at all from what I could tell.

As for upgrading it, not exactly as easy as it sounds cause we’re running a MySQL database for a store on the OpenSuse in VMWare, but I can see if it’s possible to do.

Let me know if there’s any other ideas!


Your main difficulty when considering upgrading isn’t the version of openSUSE, it sounds like it’s the version of MySQL you’re running. Although it might be possible to install and run an old version of MySQL, that also has its own issues but should be investigated. If that version of MySQL is still supported, then you probably won’t have any issue running that on a supported version of openSUSE. Assuming you’re running MySQL vintage used in 11.0, a major issue is that database connections are no longer created the same way so if you upgrade MySQL (again, highly recommended) you’ll likely need a MySQL Developer or Sr Admin who knows how to configure what you need.

Your screenshot is cropped, all I see is that you successfully pinged another address in your local network, nothing more.

Since you are running virtualization, it should be very simple to clone your existing openSUSE guest and explore a number of ways to upgrade… There is no reason to risk your Production Guests while you create an upgraded clone, fully tested.

  • You can upgrade step by step. If this is 11.0, it’s a long upgrade path. I don’t remember all the specifics over the years but around that version there was a special repository which supported skipping versions when upgrading, otherwise the advice then was the same as now… Upgrade one version at a time. So, you’d have to download DVDs for 11.1, 11.3. 11.4, 12.1, 12.2,12.3 (which currently is still supported) and optionally but recommended 13.1 (with 13.2 to be released shortly).

  • It looks like you don’t have a workable Evergreen option ( The only version selected for current Evergreen support looks to be the current latest (13.1).

  • You can build a new 13.1 and install the appropriate version of MySQL you need. If necessary, you can even install an old version of MySQL no longer supported if necessary, it’s not a good solution but is still much better than your current situation.

Plan extensively. You should be able to do this with practically zero risk if your VMware Server has sufficient resources, and even if you can’t do your building and upgrading Guests on your VMware Server, you can do it on another machine running something like VMware Workstation… You just need to be certain that any new Guests are created specifying the version of technology used for VMware Server.


Here’s a thought…

Is your networking inside the container configured correctly?

Within your problem container post the results of

ip addr

And to be certain what is your openSUSE Guest

cat /etc/*release | grep PRETTY_NAME= && uname -a


On 2014-08-28 00:36, Miuku wrote:
> openSUSE 11.0 has been discontinued since 2010, it has no support and
> there are absolutely no security patches or software for it - it’s dead
> as a rock.

And VMWare Server was also discontinued long ago, too. They stopped on
version 2 on 2010. The OP is using version 1.0 (last release on 26
October 2009).

Everything there is obsolete… except the W7 host.

Cheers / Saludos,

Carlos E. R.
(from 13.1 x86_64 “Bottle” at Telcontar)