Network adapter found but no interface.

Hi! I’m new with suse and I’m having some troubles with my wifi connection. It used to work but it suddently… didn’t.
OpenSuse Ver: 13.2

I’ve tried several commands which prove the card is found and plugged to the PCI.

lshw -C network
  *-network UNCLAIMED
       description: Ethernet controller
       product: AR5212/AR5213 Wireless Network Adapter
       vendor: Qualcomm Atheros
       physical id: 1
       bus info: pci@0000:03:01.0
       version: 01
       width: 32 bits
       clock: 33MHz
       capabilities: pm cap_list
       configuration: latency=168 maxlatency=12 mingnt=10
       resources: memory:eebf0000-eebfffff

My network is managed by wicked, and when I check my config on YaST says the following:

AR5212/AR5213 Wireless Network AdapterBusID : 0000:03:01.0

Unable to configure the network card because the kernel device (eth0, wlan0) is not present. This is mostly caused by missing firmware (for wlan devices). See dmesg output for details.

Now I remember it used to work, and there was another interface (called wlp3s1) which doesn’t appear anymore. I tried to add a new wireless device (wlan0) which doesn’t appear when I try the commands iwlist or ifconfig.

linux-mqsv:~ # iwlist scan
lo        Interface doesn't support scanning.

enp1s0    Interface doesn't support scanning.

linux-mqsv:~ # ifconfig
enp1s0    Link encap:Ethernet  HWaddr 00:19:66:37:BF:74  
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::219:66ff:fe37:bf74/64 Scope:Link
          RX packets:45566 errors:0 dropped:1 overruns:0 frame:0
          TX packets:40887 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:39947026 (38.0 Mb)  TX bytes:4921544 (4.6 Mb)

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:110 errors:0 dropped:0 overruns:0 frame:0
          TX packets:110 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:11746 (11.4 Kb)  TX bytes:11746 (11.4 Kb)

Also dmesg returns the following error

dmesg | grep ath

   11.495662] ath5k 0000:03:01.0: registered as 'phy0'
   11.551863] ath5k: phy0: failed to wakeup the MAC Chip
   11.552826] ath5k: probe of 0000:03:01.0 failed with error -5

ath5k is active and rfkill is blocking nothing.
I don’t know where the problem could be. Any suggestions?

Please post:

/sbin/lspci -nnk | grep -iA3 net

I would recommend to install Leap 42.2 because openSUSE 13.2 is out of Support and Leap 42.1 will be the next without Support.
Also the drivers in Leap 42.2 might be newer.

I agree with Sauerland. Moving to a supported openSUSE version is the best option and will provide a newer kernel as well. A quick search turned up a number of bug reports for those running 3.x kernels, and the only workaround seems to be completely powering down the machine and booting again.

Hey! Thanks for your suggestions.
I installed openSUSE in an old computer to keep it working, but it’s a 32b machine so it can’t run the Leap 42.2 version :confused:
I’m going to format my computer and reinstall everything again to see what happens. Thank you anyway.

You’ll probably find the act of powering it down and back up will resinstate it anyway (based on the comments I read in bug reports about it.)

… you could consider Tumbleweed, though, as it has a 32-bit version.

But, that certainly must be an old PC! I am running a few 12-or-more-yr-old PCs that all have 64-bit capable processors (newer ones, as well, of course).

What brand and model is it?