netgear WPN111+11.3 assistance please!

hi guy’s, ive read the sticky’s and attempted to follow them,:dont-know:
i dont need the wifi for internet…but to network with my laptop and more importantly my wifi printer,
the screenshot below shows that at least it’s recognised in the usb under hardware…but being a proverbial IT numpty
i don’t know how to configure it :’(
any advice ( including command line’s to copy and paste would be much appreciated :wink: )

It’s an Atheros based device, so should work.

Networkconfiguration is done in Yast - Network - Networksettings. You’ll see the Wifi card, click it, click Edit, enter values needed.

cheer’s Knurpht, the problem is it doesn’t show in the network settings,!! iv’e tried every edit option to try and force it but no go!!

I missed the fact that you have openSUSE 11.3… it’s no longer supported. It might even be that the 11.3 kernel does not support the specific Atheros device yet. Since you’re just starting, I suggest you download an openSUSE 12.1 LiveCD of your choice -looks like you’re on GNOME or XFCE now- and boot from it with the Wifi devices inserted. It will use the Networkmanager, if the device is recognized, it should be configurable. If that works like it should, you may expect it to work after install.

i tried that as well but had additional prob’s with my nvidia graphics card so abandoned the idea …not much use am i??

Please note, that we all started at the point where you are now. And had to learn things, sometimes by banging our heads against unwilling machinery :D.

My advice:

  • go for an openSUSE 12.1 LiveCD. If it doesn’t get to a graphical desktop, try “nomodeset” on the options line in the boot menu. It should run if the hardware is OK.
  • Install from it, you may temporarily have to add “nomodeset” on the options line.
  • Get back here, and we’ll help you get the NVIDIA driver to work if you don’t manage by yourself.


  • Because 11.3 is past it’s life’s end. You may get the Wifi to work with a lot of efforts where it should work out of the box on 12.1
  • Because most of us here run 12.1 and thus compare / test on their own systems to help you.

sorry for delay…had to go off line to collect wife…i will try again with 12.1 as suggested and return with reply,
many thank’s!!

Recommend you address this problem (the nVidia drivers) instead of alternatives.

There is a known problem with the default drivers installed for nVidia GPU.

I’ve posted a fairly easy way to address this, the general idea is to boot to the Failsafe Desktop, add the nVidia repo, then do a system update which will install a working nVidia driver. The specific steps are described in the following post, skip down to the code “zypper dup” and follow each step <after that> (Do Not Execute a zypper dup!)


thank’s for the input ts,
sadly ive already done it…managed to get my wpn111 working,but still got some prob’s to solve IE:- no video on youtube (not sure if flash and/or nvidia prob ) also having problem connecting to my epson 440 wifi printer,so any further help would be appreciated!!