Netgear MA411v2 not able to connect

I just installed the OpenSuse 11.0 on my desktop which already has xp installed on it. The very same adapter seems to work just fine on windows.

I did read the very first thread in this section. When I issue the command lsusb in /usr/bin/, the cursor comes to next line and nothing happens. Hitting ctrl C doesn’t kill the command either. I haven’t had too much experience on linux systems. A printer is connected via USB and that doesn’t get listed either.

However, the lspci does work and returns and bunch of lines. I also read about ndiswrapper and installed that using the package manager. I think I installed the ndiswrapper-default.

I then went to windows device manager and located the USB adapter and found the driver file. Then found the corresponding .inf file and copied these two files on to the linux drive and then issued the command

ndiswrapper -i /home/dagarshali/MA111v2.inf

After all these thing when I got to the network settings, I see MA111 (Not connected), I can’t delete it or do anything. Not sure what to do.

The problem is that, wireless is the only way I can connect that comp to the internet. any help would greatly appreciated. Again, I would appreciate if you could give suggestions in detail as I am a novice when it comes to using linux


Have you actually been in to Yast - Network Devices - Network Settings?

Yast - Hardware - Printer

Hardware - openSUSE

Yes,I did go to Yast and then the Network Settings. There it list MA111 and in parentheses it says not connected

So highlight it

Then edit and enter the settings

what happens

Not sure what to enter there… I use a Netgear wireless router and I enter a WEP key to connect to the router. Can you give me some suggestion as to what to enter there?


Are you connecting via wireless access point by assigned MAC address and IP.? If you don’t understand this - go to Netgear web site and down the manual for your model.

The MAC from your laptop will be on the base usually. This needs adding as a trusted station in your routers wirelss access points. Assign an IP to your laptop in the range allowed in your router.

Your WEP key will be listed in your router config. You need that key to enter in the network settings. Basically accept the defaults in Yast, which should be DHCP. You will need to set up the connection in the desktop systray network manager too.

I initially use to set the mac address in the wireless router so that I don’t have enter the password to connect to the internet. Since I started facing some problems, I disabled mac filtering and it is just encrypted now. I enter a password to connect to the router.

As I was reading in this forum and others to find a solution to this problem, I also came across installing some wlan. I checked the desktop and it doesn’t have that packing. Do I need that for this to work?


I checked the desktop and it doesn’t have that packing.
Not sure what you mean here.

My look at the suse HCL suggests the answer is: You need to use the Windows XP driver with Ndiswrapper. Ndiswrapper - openSUSE