Netflix doesn't work, says there's a network error.

Hi, download the Wine package for Netlfix from here but when I try to play a video I get this screen.

Any ideas how to fix it?

Wild guess maybe you need to open a port in the firewall

Yes there seems to be a bug which I haven’t reported. Netflix Desktop is quite buggy and I got the same error. What you need to do is uninstall Netflix Destkop and then install Pipelight. After you do that then open up your Firefox and go to and everything should be automated from there on, including installation of silverlight windows version in Wine.
I got my netflix working through Pipelight so let us know if it worked for you.

I also recommend pipelight, it indeed works way better.
Just post if you have any issues with installing it and using it as there are a few drawbacks to pipelight
such as needing a user agent switcher for what browser you are using.

I’ll try opening a port if this pipelight thing doesn’t work.

OK Suse as usual is awkward, I opened Yast, went into software management, found netflix desktop, clicked the green tick next to it until it became a red cross and click accept. IT said briefly onscreen that netflix was being removed but Silverlight and Firefox are still in my K Menu. Is that normal?

They may be leftovers, I wouldnt worry about it.

I must be missing a step, I installed pipelight, now I need to reinstall Netflix Desktop right?

This is from my notes, works on my 13.1 installs. :

Uninstall the netflix packages you’ve installed so far. Next, use this one-click
and perform the install.

The package will also pull in some other packages. After the install restart your Firefox or Chrome, and you will be presented with a Silverlight installer. Perform the install, it will be done in ~/.wine-pipelight. Next go to your local netflix url.
Contrary to other packages this also works for other Silverlight based applications.

In Chrome yep, Firefox does the job ootb.

It didn’t work, I get the exact same error.

I reinstalled Netflix desktop to see if that would help but I still get the same error.

What browser did you try?

Netflix desktop DOES NOT work You have to interface using a browser and pipelight

Oh, I didn’t know that. I thought I was installing pipelight to get Netflix Desktop working.

I’m using Firefox. But I get the “You need Windows, Mac, or Chrome OS to use Netflix” page.

You need a user agent switcher to identify Firefox to Netflix as the Windows version. I use User Agent Overrider 0.2.3 and set it to “Firefox 22/Windows”. This should let you in to Netflix.

User agent switcher doesn’t work, you need to use User Agent Overrider 0.2.3.

Yes this worked perfectly, thanks a lot guys.