Netbean + JDK + modules

I am using openSUSE 11.1 and netbeans 6.5 from the Education repository.

I’m getting this error whenever I run netbeans.

The JDK is missing and is required to run some NetBeans modules
Please use the --jdkhome command line option to specify a JDK installation or see NetBeans Wiki: FaqRunningOnJre for more information.

I went to the netbeans site and I came across a solution that doesn’t seem to work for my installed Java run-times.

/usr/bin/netbeans --jdkhome /usr/lib64/jvm/jre-1.6.0-sun

I tried changing the path to the jdkhome many times but netbeans still does not load properly.

These are the following directories in my /usr/lib/64/jvm

java
java-1.5.0
java-1.5.0-gcj
java-1.5.0-gcj-4.3-1.5.0.0
java-1.6.0-openjdk-1.2_b11
java-1.6.0-openjdk-1.6.0
java-1.6.0-sun-1.6.0
java-gcj
jre
jre-1.5.0
jre-1.5.0-gcj
jre-1.6.0
jre-1.6.0-openjdk
jre-1.6.0-sun
jre-gcj
jre-openjdk
jre-sun

I’m not sure which one I’m supposed to use because I’ve tried many of them and still I get the same error.

Hi
If you post your query in the Education sub forum, one of the
developers is hanging out there now (lrupp), so should be
able to help :slight_smile:
http://forums.opensuse.org/obs-projects/obs-education/


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.29-0.1-default
up 0:19, 2 users, load average: 0.43, 0.22, 0.16
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

It’s enough to post just once:
Netbean + JDK + modules - openSUSE Forums
Here is the answer^^.