Netatalk broken since zypper update

I am using 2.6.29-rc7 and were using it in a mac environment with netatalk. Zypper did the following updates:

The following packages are going to be upgraded:
dbus-1 ConsoleKit

The following NEW package is going to be installed:

The following NEW patches are going to be installed:
ConsoleKit dbus-1

The following packages are going to change vendor:
dbus-1 ConsoleKit

The result was that I could not connect to my shares anymore. Thereby 10+ afpd were suddenly visible with ps. I read somewhere that a kind of security issue appeared as consolekit was to permissive. Now it seems I cannot connect to my shares anymore. Was this intended or is it going to change soon again? The developers of netatalk probably won’t work on the problem till the kernel is finalized.

Any help?

As you are using factory (pre-release) software, you should file a bug report.

Thx, did that straight away. I just thought there would be someone facing the problem as well here.
By the way, just in case someone using netatalk stumbles along this thread: How come netatalk and OpenSuse 11.1 won’t work? All I get there is a freeze and I reproduced this with 2 linux machines and 2 macs in any combination.

Did you find bug reports concerning netatalk not working under 11.1 or what makes you say so?

As you are using “non 11.1”-components (Kernel) your problem with 2.6.29-rc7 is not automatically 11.1-related.

No, I did not file a bug report on this one as this bug (if it is one) goes along with the already noted inotify-bug (samba). As I did not rely on having 11.1 installed I reverted back, hoping it will be solved someday. As this was highly reproducible by any system I did not see any reason to push this topic any further. But so far neither it was solved by the system nor by the netatalk developers. At least as far as I know.
The problem with this specific “bug” is the complete freeze, so there ain’t no logfiles whatsoever.