Nepomuk/strigi in 4.4

Hi all,

Since 4.4 pretty much forces kmail/korganizer/kaddressbook/etc users into using nepomuk+akonadi+mysql+virtuoso (netbook users will love that :P) I thought that I may as well get strigi running and see how that thing works. Enabling it was painless - just checked the appropriate option in SystemSettings, strigi did it’s initial indexing without any errors and switched itself into idle mode. So now time for some testing. I launched dolphin and typed “jazz” into search bar but got no response - dolphin (launched with --nofork option) didn’t throw anything into konsole and dbusmonitor doesn’t show anything either. Second thing I noticed, is that in information panel, I don’t have options to rate/comment/tag files (it only displays size/owner/date/permissions data) that I see in all those screenshots in nepomuk praising articles. Adding metadata in gwenview works fine. Next I tried nepomuk kio. In krunner typed

nepomuksearch:/jazz

which resulted in dolphin showing some results. Bad results unfortunately - it looks like it displayed all files indexed by strigi (most of which doesn’t have anything to do with jazz) + some rubbish with nepomuk icons. Same happens when i type:

nepomuksearch:/?query=jazz

Ok - lets try another search:

nepomuksearch:/artist:“bjork”

which results in dolphin saying: “The process for the nepomuksearch protocol died unexpectedly” - bummer. I took some jpeg, added tag “test” in gwenview, and tried to find it with nepomuk:
nepomuksearch:/hasTag:“test”
nepomuksearch:/?query=hasTag:“test”

both result in the same dolphin response: “The process for nepomuk protocol died unexpectedly”.

I haven’t used nepomuk with strigi before, so I’m not sure if my problems are kde4.4 related, or I’m just doing something wrong (am I ???) Does strigi/nepomuk work fine on your 4.4 kde setup ? I glanced at kde bug tracking system, and on first look it seems I’m alone with my problem, so I tend to believe that I’m doing something wrong :confused:

Any suggestions?
Thanks in advance :slight_smile:

cheers,
Bart :wink:

Actually, nepomuk (with virtuoso) + akonadi worked fine for me in 4.3.4. Strigi - sort of. I got it running, and it completed the initial indexing just fine. It started re-indexing the entire thing upon next login though, so I disabled the strigi part.

Upon upgrading to 4.4 beta 1 (factory repos) I get exactly the same symptoms as you do. Nothing nepomuk-related in the sidebar, and using the search-kio slaves I either get the “process died unexpectedly” or results that have very little to do with the query.

The nepomuk-processes are running though, and gwenview can read previously entered tags and ratings (from 4.3.4) just fine so I suspect there’s a bug in either Dolphin or the nepomuk kio-slaves. I’m not sure whether it’s a upstream or packaging problem though.

Edited to add: I used this search in Dolphin to find all images tagged with Wallpapers (okay, silly example but I used it just for testint) nepomuksearch:/hastag=Wallpapers

Worked fine in 4.3.4, but now seems to find everything nepomuk has ever touched.

In 4.3 Nepomuk was using soprano. It was indexing my files but when I tried to search, no result!. After I updated to 4.4 nepomuk stopped working and after looking around I noticed that it needs virtuoso, so I installed it. Now Nepomuk is indexing and I can see rating and tagging in dolphin but I still can’t search!

In a review I just read in Linux Format it received a rank of 1 out of 10
What does this mean.
Basically it’s ‘Brown and Steaming’ and like something a dog just dumped.

Ranked 9 out of 10 but not quite top: Close your eyes when you read this: Beagle!!

*In a review I just read in Linux Format it received a rank of 1 out of 10
What does this mean.
Basically it’s ‘Brown and Steaming’ and like something a dog just dumped.

Ranked 9 out of 10 but not quite top: Close your eyes when you read this: Beagle!! *

This says it all!

Couldn’t agree more (although I see a big improvements in beta2 - we’ll see how it end up in 4.4 rc or final). BTW they reviewed nepomuk/strigi from 4.4beta or 4.3.x ?

Well, beagle might be a good solution if you are not using kdepim apps (kmail, kaddressbook, etc.), which right now require nepomuk/akonadi/mysql/virtuoso either way (strigi indexing is optional). Installing beagle is another bag of services and resources (including mono that is also not much liked in linux world) - ergo more things to start on boot + more ram usage. For these reasons, I prefer recoll over beagle, although the best solution would be working nepomuk+strigi (better kde integration).

cheers,
Bart :wink:

strigi 0.6.3
no detail on kde version

FYI: recoll came out top

Looks like the Nepomuk started working back (file searching) with the RC1 version.

Sort of. I still can’t get the integrated dolphin-search to provide any results, but pasting something like the following in the location bar works.


nepomuksearch:/hastag=Wallpapers

Even if it’s somewhat slow if there are lots of files tagged with that (could be a concern if you use the digikam->nepomuk sync option for example)