Nepomuk semantic desktop is not working

Hello :wink:

Could you please help me understand what’s going wrong with my Nepomuk ?

i have a “nepomuk is not running” error message :

“Nepomuk Indexing Agents Have Been Disabled
The Nepomuk service is not available or fully operational and attempts to rectify this have failed. Therefore indexing of all data stored in the Akonadi PIM service has been disabled, which will severely limit the capabilities of any application using this data.
The following problems were detected:
Nepomuk is not running.”

and also “nepomuk was not able to find the configured database backend ‘redland’. Existing data can thus not be accessed …”

by the way while launching kontact it gives the following errors :
mysql server journal with errors
nepomuk service not registered at D Bus
no ressource agents have been found

Thanks :wink:

Disclaimer: I am using kde 4.3.85 with opensuse 11.3 dev release 0. The following should apply to your situation.

First, check your installation and ensure that you have redland installed.
Second, In your /.kde/share/config directory check the nepomukserverrc
configuration file. It should look something like this:

[Basic Settings]
Configured repositories=main
Start Nepomuk=true



[main Settings]
Maximum memory=200
Storage Dir$e]=$HOME/.kde4/share/apps/nepomuk/repository/main/
Used Soprano Backend=virtuosobackend
index version=2

Next, Redland is required for the viruoso backend. The virtuoso package is mandatory
for the latest versions of nepomuk. Once you check for these, then go to the
systemsettings - advanced- Desktop search config panel. Uncheck nepomuk and strigi buttons.
Hit apply. That will stop them. Wait a few and then check the two and hit apply to restart. Wait a few to see if the service starts. If it doesn’t, then close kontact (KMail, kalendar, etc) and log out. Reboot and see what happens. After restart, open kontact. That is when you should see the resource errors but nepomuk/strigi should be running, despite the messages.

The error message about indexing agents is (I think) from the Akonadi resource manager. Open Krunner with alt-F2. Type in akonadi. Then scroll down to and select resources configuration and check which resources are active. If the are not green lighted then modify the files which the resource points to.

Kontact is not completely nepomuk’ed yet so there will be errors, especially with local folders and the mail app. Even with the error messages, nepomuk/strigi should be active. To check: hit alt-f2, click the monitor icon and check all the active processes. You should have akonadi, nepomuk, and viruoso processes listed.

Also, google “mandriva nepomuk” and you will find a very nice tutorial on the mandriva website. Most of it applies to opensuse’s version. Lots of tips, like using tasktop app to create projects that dolphin and kde apps can attatch files, websites, etc to. Lotsa bugs but it is a start to a very promising future.

Hello :wink:

Thanks for these informations :slight_smile:

here’s what i’m using :
opensuse 11.2 and kde Platform Version 4.3.85 (KDE 4.3.85 (KDE 4.4 Beta2)) “release 8”

i had redland and virtuoso installed ok already (1)

But in .kde/share/config i have nothing but a hidden .directory file with this content :


How come i don’t have a nepomukserverrc file ?

After unchecking nepomuk and strigi in desktop settings i saw strigi icon and a message saying it is indexing files in /usr/lib
, then moving on, i checked almost all files to be indexed (left default amount of used memory : 50 mb ).

in select resources configuration of akonadi i have :

std.ics, (ready), green button

local folders, (no status), green button

std.vcf, (offline), no button but a plug

birthdays (offline)

i have these processes running : akonadi control and server, nepomuk server but found nothing with virtuoso in the quick search field.

i read an explanation of nepomuk semantic desktop on the french wiki yesterday , but no tutorial so far, i found this right now NEPOMUK

(1) :

i | libredland0 | a set of free software libraries that provide support for the Resource Description Framework (RDF) |

i | redland | a set of free software libraries that provide support for the Resource Description Framework (RDF)

i | soprano-backend-redland | C++/Qt based interface library for RDF

i | soprano-backend-virtuoso | C++/Qt based interface library for RDF | paquet

i | virtuoso | Relational database server with RDF

i | virtuoso-drivers | Virtuoso ODBC Driver | paquet

i | virtuoso-server | Virtuoso server | paquet

you need these



i have strigi indexing right now, i added these 2 you gave, what is it supposed to change ?

Is there a kmail-nepomuk package or an equivalent (as i saw in mandriva) ?

Is the taskwidget (2) i have already the same as the taskwidget for nepomuk ?

(2) showing tasks running, like firefox …

When you check system processes from krunner (alt-F2) look for either sesame2 or virtuoso -t in the list of user processes. Should also have akonadi and nepomuk processes running. My understanding is that kde 4.3.85 is the pre-release version of kde 4.4 which will require virtuoso. Either way, if one of those processes is running and strigi is running then your nepomuk server is running. The akonadi resources can be modified to point to the addressbook for kmail, or the calendar for kontact. I have ./kde4/share/apps/kabc/std.vcf fot the addressbook resource and .kde/share/apps/korganizer/std.ics for the calendar file. the kmail component isn’t working correctly in opensuse. For opensuse, the kmail-nepomuk has not yet entered factory or update repos (last i checked). If you download nepomuk tools from kde playground you will have a couple of command-line apps that work (somewhat) with nepomuk: tasktop and nepomukshell.

p.s. the task widget for nepomuk is not the same as the tasks widget.

Hi :wink:

what’s strange is i still have an error message each time i start a session (mentionning redland database backend is wrong, though i have it).

Also strigi is off if i do not start it manually from kde’s preferences.

I looked in the processes and i can’t see sesame nor virtuoso (i saw akonadi)

I’ll try to see if i can find some interesting tools in kde playground :wink:

I think the title of this thread says it all. Maybe by the time KDE 4.5 comes around…

I’m using Google Desktop
Cringe all you like, but it’s pretty good.

I’m tempted too. The alternatives are Beagle and Strigi…

I was getting similar errors and found the answer here:

Nepomuk doesn’t seem to be working • KDE Community Forums

i.e you need to add the directory home/.kde4/share/apps/nepomuk/repository/main/data/redland/

It’s worth a try because it can’t hurt to add it if it’s not there. Worked for me anyway.


I installed redland, added the libraries per caf in this thread, added the above folder, and ****ed if it didn’t start working ! Always something simple !

I tried all these suggestions. Before I did, search found only 1 file starting with xyz when there were actually 2 files xyza and xyzb. Now, searching on xyz brings up both files twice! It also brings up the files a third time with the nepomuk icon instead of the OOo icon. Nepomuk seems to have a way to go yet.

Works like a charm on KDE4 4.4 RC3. Did a lot of testing on my homedir, and it’s great.

Same here with KDE 4.4 RC3. No problems whatsoever during testing.

Upgrading to 4.4 from rc3 broke nepomuk again. After trying suggesions in this thread and others found solution in:

Nepomuk doesn’t seem to be working • KDE Community Forums

i.e. deleting the config files…


Yep, that could solve matters. You did:

rm ~/.kde4/share/config/nepomukrc
rm -rf ~/.kde4/share/apps/nepomuk

( best when logged out.)

I’ve got the two directories you mention Knurpht, but still got that nepomuk disabled error on logon.
The config file has:

[Basic Settings]
Configured repositories=main
Start Nepomuk=false


[main Settings]
Storage Dir$e]=$HOME/.kde4/share/apps/nepomuk/repository/main/
Used Soprano Backend=redland
rebuilt index for type indexing=true

What do I’m missing here?

Problem solved by Virtuoso v6 installation…