Nepomuk Notifications

Opensuse 12.1 64 bit KDE clean install.

I have disabled Nepomuk in configure desktop > Desktop search
unticked ‘enable nepomuk semantic desktop’

I have no need for this (or at least believe I have no need for this)

However, every time I boot (or reboot) my computer, after a few minutes I get around three instances of the notification . . .

Nepomuk Indexing Agents Have Been Disabled
The Nepomuk service is not available or fully operational and attempts to rectify this have failed. Therefore indexing of all data stored in the Akonadi PIM service has been disabled, which will severely limit the capabilities of any application using…

The following problems were detected:
Nepomuk is not running.
Additional help can be found here: userbase.kde.org/Akonadi

how can I make these go away (not happen)?
Should I uninstall nepomuk?

It’s been a controversial issue for a while now: https://bugs.kde.org/show_bug.cgi?id=258171

There is a workaround that might help you for now, but it may be undone after updating certain packages, in which you’ll have to re-apply the workaround again:

This is my re-write adopted from comment #3 on the bug report:

  1. Go to /us/share/akonadi/agents/
  2. Edit any files named nepomuk*.desktop with a text editor (vim, nano)
  3. Search for and remove the option “Autostart” on the “X-Akonadi-Capabilities” line
  4. Run akonadiconsole (or find it in the menu) and delete the Nepomuk-related resources
  5. Stop the Akonadi service if it is still running (not really required)
  6. Log out of your KDE session and switch to TTY2 (CTRL + ALT + F2)
  7. Login as your normal user and run: rm -rf /var/tmp/kdecache-username && kbuildsycoca4 --noincremental
  8. Log out of the TTY2 session and go back to KDM (CTRL + ALT + F7, usually) and login to KDE

I find it just as annoying as everyone else. When we disable Nepomuk intentionally, we don’t want to be nagged about it every time we login.

Yes, quite right.

I solved that, but good. I edited “/home/rickert/.config/akonadi/akonadiserverrc” and change the “StartServer” line to “false”.

Presumably, that’s a bad idea for people using kmail or other applications that depend on akonadi.

(So now, how do I stop “tracker” from running if I log into gnome?)