Nepomuk: it works !!!!

Installed KDE4 4.4 RC3 today, and without changing anything in my ~/.kde4 folder, the Nepomuk search works in Dolphin.

Tried a lot of the options, and did some “manual checks”. It’s becoming what I hoped it was going to be.

There’s been a lot of ranting about Nepomuk, now is the time to take a new peak and admit it’s there and working.

I got “no items found” after several searches of files I know are in my home folder. .ogg, .flv, .pdf returned nothing.

Is there any clear tutorial on how to use nepomuk? I’ve googled but can’t find anything that explains in simple terms how to perform queries. Do I need to have tagged all my files or does it search for filenames and file content too?

Nepomuk can be used in Dolphin. From the hidden icon in the systray you can configure which folders you want in to index. It does not tag files, but keeps a database instead.

If you start a search in Dolphin, some extra buttons will appear. Just play around a bit and you’ll find out.

Maybe has some documentation.

Hmmm…seems like I have a bug. I tried adding the search bar to dolphin’s toolbar but it didn’t appear so I renamed dolphinui.rc and dolphinrc and tried configuring dolphin again. This time the search bar appeared in the toolbar but as soon as I close dolphin the search bar doesn’t display any more even though it’s set to show in the toolbar settings.

Also when I did have the search bar displaying it didn’t find any of the files I searched for.

OK, I seemed to have resolved it. Instead of adding the search bar from the too configure toolbars option I selected show toolbars>search bar. The search bar now remains visible although searches are still not working.

I’ve tweaked the files to be indexed so will wait for indexing to complete before trying again.

To add: I threw away my dolphin settings a week ago, to see if old settings were interfering with Nepomuk. Maybe clean settings help you to get it working.

I’ve now deleted my nepomuk/strigi db as I found it got to 750MB and was still growing! It seems that if you uncheck folders/files from the index list that were previously indexed that they are not actually removed from the DB.