Nepomuk constant crashing

I am running KDE 4.10.3 from the KDE-410 repo. Nepomuk crashes immediately after launching and continues to crash no matter how many times I hit restart. I have tried downgrading and deleting the config files in my home directory, but have had zero success getting Nepomuk to stop crashing. I currently have Nepomuk disabled. I know that it has a long storied history of problems, but most of what I have read about it say that a lot of issues cleared up around 4.10.1, but it seems that is not so. Anyone else experiencing the same issues? Anyone have any potential fixes.

The error that it gives upon crashing is:

Application: Nepomuk Service Stub (nepomukservicestub), signal: Segmentation fault
Using host libthread_db library “/lib64/”.
[KCrash Handler]
#5 0x0000000000000000 in ?? ()
#6 0x0000000000000000 in ?? ()

I am facing the same issue and tried the same things with the same (no) result. :frowning:

Tried with debugsymbols installed but still no meaningful backtrace :’(

Glad I’m not the only one. I wouldn’t mind leaving it disabled for now, but I need it on otherwise Kmail complains that the semantic desktop is not enabled and certain features are disabled as a result. I have use Thunderbird for a long time, but I recently flipped to Kmail and the Kontact suite because of it’s integration and syncing capabilities with my Google contacts and calendars.

Are you guys using infinality patches for freetype? As i only today found nepomuk is crashing here with freetype 2.4.12 + infinality
I’m not familiar with any other crash with 4.10.3 (or master, which i’m using)

Don’t have the issue, KDE from the KDE:Release/410 repo.
A question: how did you people perform the upgrade. I have seen Nepomuk crashes on systems where a mix of distro packages and those from the KDE repos was the cause of it, since not all KDE packages were from the same repo.

I am using the infinality repo. Very interesting. I will try removing this repo and downgrading the packages later when I get home.

No need to remove it, cartman already downgraded freetype to 2.4.11, which “resolves” the problem

Downgrading fixed it! Thank you very much.

It fixed it for me as well. Great! :slight_smile: