negative df over NFS only?

Hi all.

I’m having a strange issue here. I have a NFS server and several clients for two raid drives with XFS filesystem on them. On the server, df -h yields me:

Filesystem            Size  Used Avail Use% Mounted on
/dev/md1               79G   47G   29G  62% /
udev                  1.9G  244K  1.9G   1% /dev
/dev/sda1              54M   18M   33M  35% /boot
/dev/md2             1000G  332G  669G  34% /home
/dev/md3              4.2T  255G  4.0T   6% /share
/dev/sdb1              54M  4.9M   46M  10% /spareb
/dev/sdc1              54M  4.9M   46M  10% /sparec
/dev/sdd1              54M  4.9M   46M  10% /spared
/dev/sde1              54M  4.9M   46M  10% /sparee

while on any of the clients I get:

Filesystem            Size  Used Avail Use% Mounted on
/dev/sda2             145G  5.9G  132G   5% /
udev                  375M   72K  375M   1% /dev
                     1000G  332G  669G  34% /home
                       79G   47G   29G  62% /opt/AMD64
                      165G -1.8T  2.0T   -  /share

I googled this issue and I couldn’t find much. Even the few that I found concerned file system errors, but then there would be a problem also on my server. More interesting, it just affects my really huge /share, a raid5 xfs system, but not the smaller /home, also a raid5 xfs system.

Does anybody has any idea on this one? :frowning:

thanks a lot in advance! :slight_smile:

Never saw this before, but search to see if there is some kind of limitation in the filesystem size in the NFS protocol concerning the NFS call that gets the filesystem size (are you using v3 or v4?). Could also be a bug in the handling of the argument. Probably harmless though.


I haven’t choose it to be v4, sou I think it’s v3. Should I upgrade it?

Another strange behavior found on XFS+NFS here: root user CAN’T access users areas in the clients, just in the server. The root can’t even do a “ls /home/user” without failure on the clients. Backup with tar, just errors!

I tried to see if there is something using XFS and NFS, but then google just points me to an old problem that happenned and made both unusable together. It’s perfect usable as user, the problem is a few things that I need root powers to do! :slight_smile:

That’s normal and can be changed with the no_root_squash option. If the remote end is untrusted, it’s a security hole to allow remote root to be local root.

Thanks ken-yap! :slight_smile: That worked. I was needing that solely for one backup server, and that’s the first time I try something like this, which is why I would never get it. Specially after the whole problem with the "sub_tree_check being unneeded here for some odd reason.

But the issue with “df” keeps on. And I’m really not finding any limitations still for NFS reporting disk sizes. :stuck_out_tongue:

Ok, now I found it.

It was a single cause of different problems, ranging from this df error towards firefox not working on clients, and including “no_subtree_check” being unrecognized.

The problem was, indeed, with NFS. But, to be specific, was a mistaken package. A few days ago, while installing the system, I commited a mistake and installed quota-nfs package (I was still unaware of the specificness of XFS filesystem), which in turn removes nfs_kernel_server and install nfs_server, which does nothing right. :slight_smile:

The final clue came from here:

Thanks a lot for all help, and may this mistake stays here for someone else who needs this clue. :slight_smile: