Need to update to Xorg Intel 2.16 Driver- Wine Graphics Problem

i need to use Microsoft Excel for my work. but after installing it using wine in my OPENSUSE TUMBLEWEED, there were blackened spaces in Excel (see the link below):

Black or Corrupt UI Artifacts Under Wine - Ask Ubuntu - Stack Exchange

i had posted a Thread in the “Applications” section for a solution and got the reply that installing Intel Driver “2.16.0” will solve the problem. he also gave me a link to the package but it was for 11.4. can anyone direct me to tumbleweed version of the same?

Details of my OS:
openSUSE 11.4 (i586)
VERSION = 11.4
CODENAME = Celadon

Just ask the user (email) to add and enable the tumbleweed repository…

@ malcolmlewis,
thanks for the reply.
got to admit one thing. this forum is much more responsive than the ubuntuforums. keep up the good work guysrotfl!

I’d use it as is (if your Tumbleweed is based on 11.4). I usually make a backup copy beforehand if I plan to do anything dodgy, then if necessary I can write it back to how it was before I did the dodgy thing.
There are many ways to do a backup, here’s one: openSUSE Forums - HowTo Backup and Restore the Tumbleweed Root/System Partition Quickly & Simply

An advantage of malcolm’s suggestion, is if it’s “problematic” to enable package for Tumbleweed & Factory, it would catch conflicts with Xorg updates.
Can’t see anything installed on my system that makes me suspect the 11.4 package wouldn’t work same with current Tumble.

I don’t think the 2.16 is in Tumbleweed yet. Maybe soon ?

Is it in Factory? If not it cannot percolate to Tumbleweed.

Correct, but since the packager is an Intel person, may be staging before inclusion?

Its not clear to me that I understand this thread, but wrt the Intel driver in Tumbleweed, it is version 2.14 with lots of patches. Here is some of the change history of xorg-11-video-driver rpm from tumbleweed:

Name        : xorg-x11-driver-video        Relocations: (not relocatable)
Version     : 7.6                               Vendor: openSUSE
Release     : 53.58.1                       Build Date: Thu 12 May 2011 10:27:45 PM CEST
Install Date: Fri 20 May 2011 12:44:48 AM CEST      Build Host: build18
Group       : System/X11/Servers/XF86_4     Source RPM: xorg-x11-driver-video-7.6-53.58.1.src.rpm
Size        : 7124303                          License: MIT License (or similar)
Signature   : RSA/8, Thu 12 May 2011 10:30:44 PM CEST, Key ID b88b2fd43dbdc284
Packager    :
URL         :
Summary     : X.Org video drivers
Description :
This package contains X.Org video drivers.
Distribution: openSUSE 11.4
* Wed May 11 2011
- xf86-video-intel-946GZ-is-a-965G.patch
  * 946GZ is a 965G! (bnc #690428, bfo #35854)

* Fri Apr 15 2011
- xf86-video-intel-gen6-Invalidate-texture-cache.patch
  * fixes partial screen distortion on Sandybridge visible in KDE
    (bnc #680921, bfo #35808)

* Wed Apr 13 2011
- xf86-video-intel-damage-fix.diff
  * upstream commit da990536eca09c6de74627541cd56ecfad925eda
    uxa: Undo damage translation before appending
  * our bugzilla 666704
  * freedesktop bugzilla

* Mon Feb 14 2011
- removed TV-in support for All in Wonder 128 again (bnc #671623)

* Mon Feb 14 2011
- support dell backlight via /sys/class/backlight/dell_backlight

* Sat Feb 12 2011
- remove no longer applied patch 'xf86-video-intel-copy-fb.diff'

* Fri Feb 04 2011
- xf86-video-ati-6.14.0
  * KMS EXA/Xv support for evergreen asics (requires kernel 2.6.36
    or newer)
  * KMS EXA/Xv support for ontario fusion asics (requires kernel
    2.6.38 or newer)
  * KMS EXA/Xv support for northern islands asics (requires kernel
    2.6.38 or newer)
  * UMS support for ontario fusion asics
  * KMS pageflipping support for all radeons (requires kernel
    2.6.38 or newer)
  * Major man page cleanup
  * Lots of bug fixes

* Fri Jan 28 2011
- xf86-video-xgi-symbols.diff, xf86-video-xgixp-symbols.diff
  * (xf86)LoaderReqSymLists no longer supported/required; fixes
    "X -configure" run (bnc #667877)

* Sat Jan 22 2011
- xf86-video-ati (2011-01-21, fadee04)
  * latest git version of radeon driver, which includes Evergreen

* Sat Jan 08 2011
**- xf86-video-intel 2.14.0**
- removed obsolete

The Intel 2.15 is in factory. The 2.16 is not. Is the 2.16 even released yet ?

If you look at the factory xorg-x11-driver-video and check out its change history, you find this:

Name        : xorg-x11-driver-video        Relocations: (not relocatable)
Version     : 7.6                               Vendor: obs://
Release     : 229.2                         Build Date: Fri 15 Jul 2011 03:06:17 AM CEST
Install Date: (not installed)               Build Host: build11
Group       : System/X11/Servers/XF86_4     Source RPM: xorg-x11-driver-video-7.6-229.2.src.rpm
Size        : 6638204                          License: MIT License (or similar)
Signature   : DSA/SHA1, Fri 15 Jul 2011 03:08:20 AM CEST, Key ID bb1af2330f2672c8
URL         :
Summary     : X.Org video drivers
Description :
This package contains X.Org video drivers.
Distribution: X11:XOrg / openSUSE_Factory
* Sun Jul 10 2011
- added U_xgi-Fix-build-on-bigendian.patch:
  Fixed a big endian issue in xgi, extracted from xgi GIT (found by
  Marcus Meissner).

* Sun Jul 10 2011
- renamed xf86-video-geode-Stop-including-linux-videodev.h-in-z4l.c.patch
  to U_geode-Stop-including-linux-videodev.h-in-z4l.c.patch.

* Sat Jul 02 2011
- xf86-video-geode-Stop-including-linux-videodev.h-in-z4l.c.patch
  * Stop including "linux/videodev.h" in z4l.c V4L1 support was
    dropped as of Linux kernel 2.6.38

* Fri Jul 01 2011
- commented out xorg.conf.d snippets by default, since
  "use-last-screen.patch" of xorg-x11-server package hasn't been
  accepted upstream and we want to get rid of it; documented the
  issues in the conf.d files themselves, when make use of these
  sections (fdo #32430)

* Tue Jun 21 2011
- xf86-video-ati 6.14.2
  * support for new GPUs
  * a bunch of fusion/cayman fixes

* Tue May 31 2011
- remove support for HALlib for Matrox driver.

* Wed May 25 2011
- remove xf86-video-intel-buildfix.diff:
  The function type has been adjusted already.

* Wed May 25 2011
- remove xf86-video-fbdev.diff:
  Noone uses this code path any more today.

* Wed May 25 2011
- remove xf86-video-vmware-10.15.2.diff:
  According to
  this bug has been fixed in the vmware driver in version 10.16.9.

* Wed May 25 2011
- remove xf86-video-rendition.diff:
  Doesn't seem to be required for build any more.
  Let's see where it breaks in the build system.

* Wed May 25 2011
- Minor cleanup in spec file.

* Mon May 02 2011
- xf86-video-ati 6.14.1
  * add cayman support (shadowfb, kms-only, requires kernel 2.6.39)
  * fix build against xserver 1.10
  * big endian support for r6xx+ (kms)
  * bug fixes
- obsoletes xf86-video-ati-kms-don-t-rotate-if-acceleration-is-not-enabled.patch

* Fri Apr 15 2011
- disabled xf86-video-intel-copyfb.diff for now (bnc #687802)

* Thu Apr 14 2011
**- xf86-video-intel 2.15.0**
- obsoletes xf86-video-intel-uxa-Undo-damage-translation-before-appending.patch
- adjusted xf86-video-intel-dell_backlight.diff,

@ oldcpu,
which command did you use to get those xorg driver details?

so what do you guys suggest? what should i do? any other way i could remove those black patches from microsoft office programs?

Like malcolm said ask if that OBS project can be built for Factory & Tumbleweed to, that will help the changes get into 12.1.
You will probably be OK with the 11.4 version because there’s not Xorg updates in Tumbleweed yet.

The rpm commands I use only work if the appropriate fields in the rpm have been populated. If the packager did not populate the fields then it does not work.

For the version on Tumbleweed, since I ran the command from a tumbleweed install, I only had to type:

rpm -qi xorg-x11-driver-video --changelog | less

For the version in factory, I when here " Index of /repositories/X11:/XOrg/openSUSE_Factory " and downloaded (but did NOT install) the rpm xorg-x11-driver-video-7.6-229.2.x86_64.rpm and then I ran the command (which is different as it has a ’ p ’ in it ) :

rpm -qip xorg-x11-driver-video-7.6-229.2.x86_64.rpm --changelog | less

I have no suggestion. Only a caution.

The intel drivers are typically posted here: Intel Linux Graphics and typically only packagers and NOT regular users go there for the drivers. when I go to that site I note 2011-4-14: Intel 2011Q1 graphics package released which when I click it refers to the 2.15. driver.

No where do I see reference to a 2.16 Intel driver on the Intel site being released. As far as I can tell its still in development. Note often a new version of an Intel driver will require a new version of Mesa , and/or a new version of the X server, and/or a new version of the kernel. Its typically NOT an easy driver install.

i have mailed to the developer asking him whether this is still in development stage and also requested him to make one for tumbleweed. waiting for his reply.