Need to remove Nvidia driver to start over

I just updated the kernel then tried to update the Nvidia driver too (the “hard” way, as I have many times, no help needed with how to do that), but I carelessly screwed up the Nvidia driver installation with a simple typo that I didn’t spot 'til it was too late.

How do I remove the Nvidia driver, so I can start over? (CLI please)


If you were installing the driver the hard way, I can’t think what typo you got wrong? There is only the Nvidia package name to type and TAB auto completes that anyway.
Just re-install it

I simply typed -q instead of -K

Now Sax2 will not run with 0=nvidia, and attempts to reinstall result in “ERROR: installation has failed”

Re-install from level 3 boot.
Never fails for me

Here is my how to:

Alright so here is how to install the nvidia driver manually, in case the one in the repo doesn’t work or u just want to use the latest.
Go to Yast>Software>Software Management
Search for and install if you don’t have these:


Now download the latest Nvidia driver:
Place the file in your /home/username
Now restart and at the boot screen, pause the boot by moving the down button, then move back up and clear any text in the boot arguments by holding backspace. Then just type the number: 3

At the login
Type “root” then enter and then your root password and press enter.
now type
cd /home/username
*Now remember you can use the {TAB} key to auto complete
so type:
and the whole file name should auto complete
eg: sh
Follow the installer and let it compile the kernel module for you.
Say Yes to everything
Use TAB to move around

Sorry to say that’s exactly what I’ve been doing, several times in fact. Interesting though that the precise errors received when running Sax2 are not always the same. That doesn’t make sense, butt there it is.
Anyhow, I just tried two more times. The second time the error message from Sax2 pointed to /var/log/SaX.log. Most of that file appears unremarkable (to my untrained eyes) except for the line 4 below “(II) Loading /usr/lib64/xorg/modules//dirivers/” that says “FATAL: error inserting nvidia (/lib/modules. No such device”

Does that offer any clues?

I’m running now on 0=nv, but I’d really like to get back to using the proprietory Nvidia drivers as I had been for the past 2 years or so. Can I remove the faulty installation and start over, or failing that can I roll back to the previous version somehow?

Try rolling back all the kernel packages to the previous versions and re-install the driver, see what you get.

If that works, you could then try going forward again.

Other options:
Backup xorg.conf
Then try starting a new one


(just the high points)

  1. uninstalled new Nvidia driver using #sh --uninstall

  2. installed earlier driver (version that worked ok before) using #sh

no improvement

  1. uninstalled new Nvidia driver using #sh --uninstall

  2. rolled back kernel to earlier version (with yast)

  3. installed newest Nvidia driver using #sh

result: New driver now installs and Sax2 configures successfully.

conclusion: The new kernel update ( did not solve the problem I thought it would and literally prevented the installation and configuration of proprietary Nvidia drivers. It has serious flaws, and is not ready for prime time.

Thanx caf4926 !

Nicely sorted. Well done!

There’s a typo in my entry #8 above that could be rather confusing if not repaired. The first word of line 5 should be “installed” not “uninstalled”.

Perhaps a moderator could correct this error for me? Thanx.

What a pile of rubbish, as this was clearly a user’s error.

Wanna know why?

I just updated the kernel then tried to update the Nvidia driver too (the “hard” way, as I have many times, no help needed with how to do that),


"FATAL: error inserting nvidia (/lib/modules.**weak-updates**/updates/nvidia.ko): No such device"

If you really had used “the hard way” exclusively, then there wouldn’t be that file, because the location tells us, that this is a module from one of the RPM-packages of the nvidia-repository and not the “hard way” installed kernel module.

And of course then removing the nvdida driver via the installer could not help, because it did not remove that file (why should it? It didn’t install it in the first place).

In my defense please note that I never claimed that I “had used the hard way exclusively”. I only claimed that I had tried to "update the Nvidia driver the hard way, “as I have many times…”

That having been said, I’m truly saddened that my logic so offended you that you felt you had to resort to such a rude and offensive tone in your reply.

Oh by the way, you might be interested to know that OpenSUSE was loaded on this PC only two months ago. It was loaded on an empty, newly created partition, and the NVidia repo’s have NEVER been added, enabled or accessed from this computer.

Well, this is certainly not true, otherwise that file would not exist.

In my defense please note that I never claimed that I “had used the hard way exclusively”.

Well, then what else did you do?

As there is only one other way (using the repos either via YaST or via One-Click) the above statement must be false.

Calling something “not ready for prime time” although it clearly was your fault is the real offence, I am not offended at all, it’s just always the same, that people blame anything but the most obvious reason, themselves.

The real problem with this is not that somebody talks rubbish, that happens all the time, but some other people might read and believe that rubbish, so I had to state the obvious facts (also being slightly puzzeled that nobody else saw it although it was very clear when reading posting Nr. 3).

Oh and also by the way:

On my systems (OS 11.1, one i586 the other x86_64) the nvidia drivers worked without any glitches for the new “not ready for prime time” kernel, no matter if i used them from the NVidia-Repo or if I did it “the hard way”, but as indicated above, I used only one of the two methods exclusively at a time.

That’s a typo, relevant posting is Nr.5 and not Nr.3.

(And the “no such device”-error even indicates more, not only installing RPMs from nvidia repo but also choosing the wrong one for the respective graphics card).

Sorry you feel I’ve been talking rubbish. I’m 61 years old, and I’ve worked on almost 20,000 PCs is my career, and that 's the first time I’ve ever been accused of that. I guess I’ll have to be more careful in the future ;-).

My old Granny used to tell me I should keep my mouth shut if I’ve nothing useful to say, so I guess I’ll take her advice now and withdraw from this pointless dialogue.