Need to log out to play DVD's

Hi
Just wondering if someone can help me, i have looked for this problem in the forums but i haven’t managed to find anyone with the same but apologies if it has been asked before.

I have opensuse 11.1 installed and it is set to autologin to a user upon boot. When i try and play a DVD in Xine i get the following error:

xine engine error
there is no input plugin available to handle ‘dvd:/’ maybe MRL syntax is wrong or file/stream source doesn’t exist
The source cant be read: maybe you dont have enough rights for this, or source doesnt contain data. (/dev/dvd)

I also get this error when trying play a DVD in Kaffeine:

The source cant be read: maybe you dont have enough rights for this, or source doesnt contain data. (/dev/dvd)

At first i thought i was just missing some packages, i discovered that if i log out and back in again they play perfectly in both Xine and Kaffeine, so i am pretty sure i have all the necessary packages installed.
Does anyone have any idea’s about what is going on, no matter how obvious they seem as I am very new to suse.

Pasted the 10 steps below

Many Thanks
James

media@dhcppc6:~> LC_ALL=C zypper ve
Loading repository data…
Reading installed packages…
Dependencies of all installed packages are satisfied.
media@dhcppc6:~> rpm -qa --queryformat '%{NAME} → %{VENDOR}
’ | grep -i VideoLAN
libdvdcss → VideoLAN Project (VideoLAN - Free and Open Source software and video streaming solutions for every OS!)
media@dhcppc6:~> rpm --verify --query --all ‘libav*’ ‘libpostproc*’ ‘libswscale*’
media@dhcppc6:~> rpm --query --queryformat '%{NAME}-%{VERSION}-%{RELEASE}-%{ARCH} → %{VENDOR}
’ libxine1 libxine1-codecs
libxine1-1.1.15-44.pm.2-i586 → packman.links2linux.de
libxine1-codecs-1.1.15-44.pm.2-i686 → packman.links2linux.de
media@dhcppc6:~> rpm --verify --query --all ‘xine
media@dhcppc6:~> rpm --query --queryformat '%{NAME}-%{VERSION}-%{RELEASE}-%{ARCH} → %{VENDOR}
’ gstreamer-0_10-ffmpeg gstreamer-0_10-fluendo-mp3 gstreamer-0_10-fluendo-mpegdemux gstreamer-0_10-fluendo-mpegmux gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-base gstreamer-0_10-plugins-good gstreamer-0_10-plugins-good-extra gstreamer-0_10-plugins-ugly
gstreamer-0_10-ffmpeg-0.10.6-42.pm.1-i586 → packman.links2linux.de
gstreamer-0_10-fluendo-mp3-0.10.7-42.pm.2-i586 → packman.links2linux.de
gstreamer-0_10-fluendo-mpegdemux-0.10.15-42.pm.1-i586 → packman.links2linux.de
gstreamer-0_10-fluendo-mpegmux-0.10.4-42.pm.1-i586 → packman.links2linux.de
gstreamer-0_10-plugins-bad-0.10.8-42.pm.2-i586 → packman.links2linux.de
gstreamer-0_10-plugins-base-0.10.21-42.pm.1-i586 → packman.links2linux.de
gstreamer-0_10-plugins-good-0.10.10-42.pm.3-i586 → packman.links2linux.de
gstreamer-0_10-plugins-good-extra-0.10.10-42.pm.3-i586 → packman.links2linux.de
gstreamer-0_10-plugins-ugly-0.10.10-42.pm.1-i586 → packman.links2linux.de
media@dhcppc6:~> rpm --verify --query --all ‘gst
media@dhcppc6:~> rpm --verify MPlayer
media@dhcppc6:~> rpm --verify --query --all ‘vlc
media@dhcppc6:~> rpm --verify w32codec-all
media@dhcppc6:~> rpm --query --all ‘libav*’ ‘libpostproc*’ ‘libswscale*’ ‘xine’ ‘gst’ MPlayer ‘vlc’ | grep -v avahi | sort
gstreamer-0_10-0.10.21-3.11
gstreamer-0_10-ffmpeg-0.10.6-42.pm.1
gstreamer-0_10-fluendo-mp3-0.10.7-42.pm.2
gstreamer-0_10-fluendo-mpegdemux-0.10.15-42.pm.1
gstreamer-0_10-fluendo-mpegmux-0.10.4-42.pm.1
gstreamer-0_10-java-1.0-42.pm.1
gstreamer-0_10-plugins-bad-0.10.8-42.pm.2
gstreamer-0_10-plugins-bad-lang-0.10.8-42.pm.2
gstreamer-0_10-plugins-base-0.10.21-42.pm.1
gstreamer-0_10-plugins-good-0.10.10-42.pm.3
gstreamer-0_10-plugins-good-extra-0.10.10-42.pm.3
gstreamer-0_10-plugins-ugly-0.10.10-42.pm.1
gstreamer-0_10-plugins-ugly-lang-0.10.10-42.pm.1
gstreamer-0_10-schroedinger-1.0.5-2.19
gstreamer-0_10-utils-0.10.21-3.11
gstreamer-utils-0.10.21-3.11
kaffeine-gstreamer-0.8.7-2.pm.2
libavc1394-0-0.5.3-129.3
libavcodec52-0.4.9.16240svn-20081219.pm.2021
libavdevice52-0.4.9.16240svn-20081219.pm.2021
libavformat52-0.4.9.16240svn-20081219.pm.2021
libavutil49-0.4.9.16240svn-20081219.pm.2021
libgstapp-0_10-0-0.10.8-42.pm.2
libgstinterfaces-0_10-0-0.10.21-2.20
libgstreamer-0_10-0-0.10.21-3.11
libpostproc51-0.4.9.16240svn-20081219.pm.2021
libswscale0-0.4.9.16240svn-20081219.pm.2021
libvlc2-0.9.8a-0.pm.2
libvlccore0-0.9.8a-0.pm.2
libxine1-1.1.15-44.pm.2
libxine1-codecs-1.1.15-44.pm.2
MPlayer-1.0rc2_r27637-3.pm.3
phonon-backend-gstreamer-0_10-4.2.0-40.18
phonon-backend-xine-4.1.3-4.1
python-gstreamer-0_10-0.10.13-42.pm.1
vlc-0.9.8a-0.pm.2
vlc-noX-0.9.8a-0.pm.2
vlc-qt-0.9.8a-0.pm.2
xinetd-2.3.14-129.28
xine-ui-0.99.5-221.41

do this

YAST >> Security and Users >> User Management >> “select your user” >> Edit >> Details >> Groups >> check “cdrom” and “disk” and then click on “ACCEPT”.

you may need to reboot

cheers caf4926, works brilliantly now.

just out of interest, does that add permissions to use ‘disk’ and ‘cdrom’ to my user? If so why did it allow me to use those resources if i logged out and back in again?

Thanks again

James

The instructions I gave you are a work around for a bug. It should not be necessary to change those settings normally.

As for your login /logout experience. It’s the first I have read about.

Thanks caf7926, solved the DVD issue for me. :slight_smile:

Good to hear. Well done;)