Need to downgrade a package

I encountered several bugs from the latest flatpak package (v1.14). On the other hand, another machine running Leap with flatpak (v1.12) has not those issues.
Any idea on how I can downgrade to v1.12, as I can’t find it in TW repos or the Factory repo(suggested by the New Bing chatbot…)?

As Tumbleweed is a rolling release, old packages wont be retained . But you may have luck by searching the history snapshots…

What are those issues? Which DE? They might be from many dependencies and directly from flatpak.

Why do I see only the very recent snapshots? I bet v1.12 is in months ago.
Forget about solving the many flatpak issues. I’ve done that for weeks and I figure the only way to try is installing v1.12 or v1.13.

Because as already told, Tumbleweed is a rolling release. If you would keep all historic data, the needed storage space would exceed peta/exabytes…
If you need a special package version which isn’t available anymore, you need to compile it yourself…
Or try if you can install the Leap 15.4 version without breaking to much deps…

The only supported way to fix issues on TW is by fixing it forward, not backward. If you are looking for a different distribution including an older flatpak with dependencies, you could try your luck running Leap 15.x on distrobox.

@bonedriven Hi, the ‘latest’ flatpak (v1.14) has been in the release for around 6 months? Have you only just installed this package, or have you only recently upgraded this system (with zypper dup)?

Can you clarify what these bugs are?

AFAIK, with an openSUSE Build Service account you can check out a specific package revision and then rebuild locally with osc.

Very slow download speed, failure to download etc. The issue started last November but I found some work around. Recently the work around is even broken for unknown reason.
But a few other machines running Leap have none of these issues.

@bonedriven I would suggest running something like wireshark on a Leap system and also on the Tumbleweed system and see if a packet capture identify what may be going on. Maybe related to the change to a curl backend.

Have a look at the flatpack changelog as well.

I did try to see the changelog around that time but couldn’t decide what was it. Not sure if it’s the release that aimed to fix some ssl bug. Not familiar with wireshark analysis.

I just tested a fedora KDE installation in a virtualbox hosted on the current problematic opensuse TW. Fedora also has flatpak 1.14 but has not this issue. So it seems to be specific to opensuse TW.

@bonedriven then I would suggest a bug report: openSUSE:Submitting bug reports - openSUSE Wiki

What applications are causing issues, I run MicroOS and flatpak.

You can go to [https:/] and select “all distributions” from the dropdown. Then put flatpak in the search window. Look in either “experimental” or “Community” packages in the Tumbleweed section (note: if Tumbleweed is pre-selected in the dropdown, only the most recent version will show). After the install, set the added repository to either not refresh, or disable it. You can also set a “do not modify” instruction for the package. After a time, you might allow it to upgrade once a newer version is available that you are willing to try.

I’ve been banging my head trying to figure out what’s causing this these days. I came to have some understandings. I use a system proxy, but recent update render flatpak unable to download (when pulling) while still able to search. As you said, it uses curl as the back end, but somehow when it calls curl to download, curl fails to go through system proxy. I set a .curlrc in my home folder with proxy settings, but flatpak doesn’t care about it. The file flatpak fails to pull (timeout), can be downloaded in a second when going through the set proxy.

FYI, all my flatpak app installation were done with “flatpak --user …” I wonder if I had used “sudo flatpak --system” to install stuff, it would recognize system proxy without issue.

The solution might be finding a way to force curl (called by flatpak) to go through my system proxy (which is to accelerate my internet connection). But I don’t know how to do it.

I’m giving up downgrading flatpak. Today I mistakenly deleted all my flatpak apps. If I still can’t find a way to fix it, I’m going to embrace snapcraft instead.

1 Like

@bonedriven Install flatseal and have a poke around there and in the environment section set your proxy settings for the application.

Ain’t flatseal used to configure flatpak apps? I however need to change the behavior of flatpak itself, e.g. how it connects to the internet, or how it uses curl to connect to be exact.

@bonedriven I never used the --user option (it’s the default AFAIK), I’m assuming if no proxy involved it works…

Likewise you would need to set the proxy for applications that need it…

@malcolmlewis The default behavior of flatpak is without --user but --system. And again, I’m not having trouble with apps getting through proxy. It’s the flatpak itself (not downloading apps from flathub repo).

@bonedriven not here… all are installed as user (On MicroOS). Are proxy settings needed in NetworkManager (Default for Tumbleweed not Leap).