Need tips to upgrade 10.3 directly to 11.1

My lab rat (test machine) appears to have come to the end of its useful life :’( I cannot install 11.1, primarily I think, due to its low ram. The live CD for 11.1 is asking for 1 GB and I don’t have it.

Right now, I am reinstalling 10.3 even though I was running 11.0 fairly well. I cannot get 11.0 to reinstall, easily anyway. So, when the 10.3 is finished, what should I do to get an online update to 11.0 or 11.1? If it’s a matter of new repos, which ones? Can I get a version of zypper that will give me zypper dup?

I don’t think that is correct. … I plan to install 11.1 on my mother’s PC in January 2009 (she has only 512 MB on her PC) and I’ve been watching the update threads carefully, and I have seen no such requirement for 1 GB of RAM. My understanding is 11.1 will have pretty much to the same requirements as 9.3.

Her PC is an old 1.1 GHZ Dell with 512 MB of RAM (currently running openSUSE-10.2).

Sorry to read about your 11.0 problems.

Still, if this is a test box, why not attempt to install 11.1 RC1 from liveCD and write a bug report if it fails to install.

There is no need to do an online update, and online updates are not without risk, as an interuption can leave your pc in capable of booting, forcing you to start over.

Still, to answer your question, if you go here you will see the 11.0 repos:
Package Repositories - openSUSE

If you click on an 11.0 repos, and then go up a few levels, you will see the 11.1 RC1 repos: Index of /distribution

Giving you this for

I do not know if the “zypper refresh” followed by “zypper dup” works in the zypper version in 10.3

I believe zypper dup was introduced in 11.0, but I could be wrong. If you have a DVD drive, you might have better luck installing from that source vs a live disk.

Thanks for the replies.

When I used the LiveCD for RC1, (twice) I got the message that I might not be able to install since I have less than 1 GB ram. Both times I said go ahead anyway. Both times it failed

This old machine has only a CD drive; no floppy, no DVD. It is an HP and so is my laptop. I have an external DVD drive, also from HP, that I used with the DVD to install 11.1 RC1 to the laptop. I cannot get the pc to recognize the DVD as a boot device although it has recognized other disks in that drive and booted from them. In bios, I went so far as to disable all other boot devices. Still no luck.

I still haven’t gotten 10.3 installed on the old machine. It was having trouble with the repos not finding software until I told it to check 2 or 3 times. I am on my third reboot and still trying to install 10.3 Yast is downloading about a bazillion delta rpms. The first go-around, it tried to install a new zypper. When this finishes, I will compare the installed zypper on the lab rat and on the working installs of 11.0 and 11.1

P.S. I am too intimidated, and ignorant, to use bugzilla.

How much less than 1GB of RAM do you have?

I’ve installed openSUSE-10.2 (with KDE) on a PC with 256MB of RAM. I’ve installed openSUSE-10.1 and 10.2 (with fvwm and also xfce) on a PC with only 128 MB of RAM. 11.1 should not have a bigger RAM foot print/requirement.

Did you try a text install ? During the text install, depending on how much RAM you have, chose a desktop that does not need much RAM.

There is not much too it. If it does not like the fields you fill in, it will not let you submit the bug report.

But if you have too little RAM (ie only 128MB to 256MB) then you may NOT be able to install KDE or Gnome.

Don’t forget to check the installation media on your old PC. You can do that, in the initial green selection menu, by selecting F3 and choose text mode, and then select “check installation media”.

Note old CD drives can be badly out of calibration. When I installed openSUSE-10.2 on my mother’s PC 2-years ago, I had to purchase a new CD-Drive in order to get the CD to load.

This weekend, I installed 11.1 RC1 on two different PCs. A brand new laptop and a 7-year old PC. I burned an installation CD and DVD on the old PC. It worked for the old PC, but neither the CD nor DVD would work for the new laptop. I then burned an installation CD and DVD with the new laptop’s burner, and the new laptop would install 11.1 with that. So then out of curiosity, I took the CD and DVD burned by the laptop and checked them with the old PC. The old PC would not recognize them.

So there is no easy way to upgrade from 10.3 to 11 or 11.1 from the online updates? I know with Ubuntu you can do updates from one version to another using the Update Manager. openSUSE doesn’t have a way to do this until you are running 11.0? I have a 10.3 box that I would like to update but would like to avoid installing via a CD or DVD. The answers in this thread weren’t real clear if this can be done or not. If so, could you explain how to do so?


This old machine is running with 256 MB. Before you laugh, remember that my principal goal is to get a modern, up to date, opensuse to run on minimal hardware that would be discarded. I have a plan to get these old machines used in schools where they would be trashed otherwise.

I tried changing repos to 11.0 and putting an 11.0 dvd in the usb drive. (remember, this drive will not boot for some reason) That gave me irreconcilable dependency hell. I next tried to update zypper so I could try zypper dup. All the packages failed for “bad Magic.” A google search suggested I needed to update my “rpm package” via zypper in rpm. I did that and then the new version of zypper installed. As I type, zypper dup is starting to work.

There are 600 MB to download. Let’s see if this works! As a final option, I downloaded the mini-iso (and opened an old 650 MB blank CD that is too small for other iso’s) something I never tried before, to see if that will do the trick.

That should work, but it will be very very slow with KDE and with Gnome. Only run one or two apps at a time. No more. fvwm or xfce will be faster, but will not be as slick nor as shiny.

Updating rpm is brave. It could “break” your current 10.3. I have my fingers crossed for you.

If you do try a CD install again, try the text mode install, and also go for a small desktop.

Again, old CD drives can have all sorts of weird compatibility problems and errors.

Progress report: (this thread is getting like Twitter for me :wink: )
The zypper in rpm worked without a hitch. It allowed me to do a zypper dup that went smoothly as well. I was left with a nicely working 11.0, except no kde4, no plasma.

I decided to experiment (this is my lab rat, after all) to see if I could get plasma going. I tried to burn the mini-iso on the old CD media but it wouldn’t work. So, I put in new media and burned the iso. Right now, I appear to be installing openSUSE 11.2 with kde 4.1 :\

It has almost 2 hours to go… so, we shall see.

For direct upgrade from openSUSE 10.3 to openSUSE 11.1 using ‘zypper dup’ you can use my instructions at Upgrade a running openSUSE 10.3 system to 11.1 using zypper dup - PvdMWiki