Need some reassurance here...

Hey everybody, I want to dual boot openSUSE 11.2 and Windows 7. I already have Windows 7 installed but I have encountered multiple issues in the past with trying to make dual boots. Usually when I install Linux, GRUB decides it wants to go into world domination mode, and “breaks” my Windows installation. I have reason to believe this is because the distros I use come with legacy GRUB, (v0.97) and for some odd reason it lacks commands such as “update-grub” etc. This means I cannot add Windows 7 to the boot menu without going into extreme complications, which have NEVER, I repeat NEVER succeeded. When I boot the Windows drive directly, I get some error about GRUB not finding the device, and it puts me into a grub rescue command line. Now I am no expert in this field at all, but wouldn’t that mean that GRUB wrote itself to the MBR of…oh I don’t know, ALL of my hard drives? I really want to install openSUSE 11.2, but from bad experience I am really put off as I know that it ships with legacy GRUB v0.97…

I am also running Fedora 13 at the moment, I have quite an experimental dual boot running…been trying to get GRUB 2 for hours now, it is definitely there but no commands work, “upgrade-grub-from-legacy” and “update-grub” return with command not found. I’ve heard this is just a bug but can anybody confirm that there will definitely be a way for me to “fix” my windows installation after it gets “broken” by GRUB?

EDIT: Second idea, unplug my windows hard drive while openSUSE installs?

Well i’m a complete newbie in linux and i installed both SUSE and Ubuntu without them messing up windows… :wink:

Install CD detects windows loader and at some point in installation asks what bootloader you want to keep… I set up that SUSE bootloader installs and it reckognizes windows without problem…

The only thing is, it sets linux as default so i had to change windows to default boot, so everyone else in the house can not get confused by the extra screen. :wink:

I have only SUSE now, no room for 3 systems lol (and no need to), and i never had any problems with linux messing up windows… Few years ago too, when i installed SUSE, it detected and coexisted with windows perfectly…

So, what i’m saying is… If a complete newbie like me can do it, so can you… And you seem to have more knowledge about linux than me… I don’t know enough to tell you why you might experience problems, but i’m also dual booting Windows 7 and openSUSE 11.2 and didn’t get those problems…
Maybe because i have them both on 1 drive, just different partitions, and you seem to have Windows 7 on a different drive (if i understood your post correctly)…

Anyway, all i had to do is manually set partitions and everything worked!

Good luck!

EDIT: About that second idea… I think that wouldn’t be good, since linux wouldn’t find Win7 bootloader and then it would think it’s the only system… Meaning you’d have more hassle with it…

You should need update-grub with the “legacy” version of grub that everyone but *buntu ships. Just edit /boot/grub/menu.lst

This would indicate that it grub got written to the MBR of your windows drive. As I recall, 11.2 does not default to installing grub in the MBR (like some other distros do), instead it installs on whatever partition /boot is on and then sets itself as the active(boot) partition. That is unless you are installing on /dev/sdb in which case it will default to putting it in the MBR on /dev/sda. Assuming your windows drive is seen as /dev/sda (or hd0 in grub), I see two options for you:

  1. Put a 10-20Gig partition on your windows drive for / (or smaller if you just want /boot) and the rest on your second drive
  2. Swap your drives so that that your Linux drive is first. Then install normally, SUSE should be smart enough to find Window and add an entry. If you have to reinstall windows you’ll then need to disconnect the Linux drive.

I have one of each setup here, both worked without a hitch.

Yes, I do have a feeling that it was my distro just being a pain. From what you guys have said it sounds like openSUSE gives me way more options on install rather than “Welcome to Linux!” then asking what my name is, then “Please wait while GRUB breaks everything!”.

If I can choose where to install GRUB that is fantastic too, but yes I think the problem is that it is across drives…

I am happy with just Linux, but I do need Windows at some point, I can usually last 1 or 2 weeks without. As long as the installer does not write anything to the MBR of my Windows drive, everything will be fine, as I can just press ESC at boot, and use the boot menu built into my bios to choose what hard drive to boot. But this is not often the case…usually I have to use certain applications to try and “Fix MBR” and this isn’t always 100% successful.

I think I’ll go ahead with the SUSE installation! (Early morning here)

And even if it breaks, return here, there’s loads of people that will help you through it.

I am expecting to have problems, but if I don’t, this will definitely be my favourite distro. I am already very interested in it, it is RPM based like Fedora except it seems to have more features and good support. Downloading the openSUSE 11.2 ISO now, I will be back in a few hours with a nice new shiny install. :slight_smile:

Just be sure you don’t burn a corrupted ISO and try to install from that like i did… :stuck_out_tongue: rotfl!

Don’t worry, I use USB to install, it tends to corrupt far less and it is reusable, and easy to copy files.:wink:

Don’t worry, I use USB to install, it tends to corrupt far less and it is reusable, and easy to copy files.

The DVD or a liveCD? The size of DVD alone increases the chance of some corruption occuring during the download, ALWAYS check the md5sum (liveCD or DVD)

Ok guys…having a bit of a problem during install…right at the beginning of the actual install.

It errors while trying to remove one of my logical partitions, which is apparently open. I was on the “Live CD” and I thought maybe I had a file browser window open? So I checked and yep, there was. Ran install again. Same error. This time I rebooted and chose to just “Install” openSUSE 11.2…same error. Is this my past installation of Linux being awkward or is it a common error…or what? I am going to hunt down the drive on my windows and see if i can format it on here…

Thanks in advance.

On a sidenote, right before install, I did look at the GRUB options and it detected Windows. Looks like I am going to enjoy this distro a LOT.

If I can choose where to install GRUB that is fantastic too,

This seems to be a main concern, along with how GRUB seems to behave, with that in mind, from a liveCD and from a terminal (konsole for example) can you do this, type

su -

enter the root pasword, then type this,

fdisk -l

please copy and paste the output here.

Ok small update, I used Windows to completely nuke my Linux drive ( bye bye Fedora! >:D) and now the installer for openSUSE11.2 is working greatly. Fingers crossed that GRUB will work properly and display my Windows. From what the installer tells me, it will. If it does, I will love this distro so **** much. dvhenry, I will post that info here right now because we know that it might be needed soon:

Disk /dev/sda: 750.2 GB, 750156374016 bytes
255 heads, 63 sectors/track, 91201 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x0002e468

Device Boot Start End Blocks Id System
/dev/sda1 1 262 2104483+ 82 Linux swap / Solaris
/dev/sda2 263 2873 20972857+ 83 Linux
/dev/sda3 2874 91201 709494660 83 Linux

Disk /dev/sdb: 500.1 GB, 500107862016 bytes
16 heads, 63 sectors/track, 969021 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes
Disk identifier: 0x69c43ea9

Device Boot Start End Blocks Id System
/dev/sdb1 * 1 969018 488385040 7 HPFS/NTFS

Disk /dev/sdc: 4003 MB, 4003463168 bytes
64 heads, 32 sectors/track, 3818 cylinders
Units = cylinders of 2048 * 512 = 1048576 bytes
Disk identifier: 0x8c71ad6e

Device Boot Start End Blocks Id System
/dev/sdc1 * 1 689 705536 83 Linux

Disk /dev/sdc1: 722 MB, 722468864 bytes
64 heads, 32 sectors/track, 689 cylinders
Units = cylinders of 2048 * 512 = 1048576 bytes
Disk identifier: 0x8c71ad6e

 Device Boot      Start         End      Blocks   Id  System

/dev/sdc1p1 * 1 689 705536 83 Linux

/dev/sda/ is my Linux drive.
/dev/sdb/ is my Windows drive.
/dev/sdc/ is my USB drive.

Oh my intense swearing !

It actually works! First time around, Windows is recognized by GRUB and my dualboot works flawlessly. Thank you guys for sticking around and being kind in welcoming me here, I’ve had a quick skim over the OS and it looks like I will really really enjoy it. Thanks for all the help once again! lol!

I am going to offer a link that I believe you will find usefull in understanding how and why GRUB (and boot loaders in general behave, It also contains a link explaining how to use the windows boot
loader to multi boot with linux ( I would not do this, but it seems some prefer it ).GRUB Boot Multiboot openSUSE Windows (2000, XP, Vista) using the Grub bootloader.

Edit: a bit late with this then ? Glad it was not needed,and all is well !

Glad to hear it works!