Need some help re alsa/sound card

Hello all –
I installed openSUSE 10.3 last week on a brand new computer. Because it is new and has never run any other OS, I can’t say for sure that the sound hardware works, but I am assuming it does.

I have been unable to get any sound out of the system. I have run some standard diagnostics, which I have posted. One clue is that alsamixer will not work. It returns:
"alsamixer: function snd_mixer_load failed: Invalid argument:

Here are diag info links:
general pastebin - dmiller - post number 1052817
tsalsa.txt - (beta)

Thanks for your help
Dave M

First, upgrade ALSA by adding this repository:
Index of /repositories/multimedia:/audio/openSUSE_10.3

Then go and update ALSA via YAST, reboot and run alsaconf (as root).

For more help and information, take a looksee here:
SDB:AudioTroubleshooting - openSUSE

Further to what Chrysantine recommended, I note that you made an effort to upgrade your alsa. But you were not completely successful. From the scripts I see that you have utilities 1.0.17RC2, and libraries 1.0.17RC2, but only the driver version 1.0.14.

Also, I notice from the scripts your Biostar laptop has an ALC662. Searching the alsa site on the ALC662 I find this (which notes updates made in alsa 1.0.17RC1): Search results for ALC662 - AlsaProject

Note, you have a “bigsmp”, so when running the zypper commands to update your alsa, you need to be careful to use the bigsmp setting.

To update your alsa, try these 3 commands in a konsole with root permissions:

zypper ar multimedia-bigsmp
zypper install alsa alsa-driver-kmp-bigsmp alsa-utils alsa-tools alsa-firmware libasound2
zypper rr

Note those are 3 separate commands.

Restart your PC after the alsa update.

And if sound still doesn’t work, we can try pasting a model=something to a specific section of your /etc/modprobe.d/sound file. Limited guidance for that is here from the ALSA-Configuration.txt:

	  3stack-dig	3-stack (2-channel) with SPDIF
	  3stack-6ch	 3-stack (6-channel)
	  3stack-6ch-dig 3-stack (6-channel) with SPDIF
	  6stack-dig	 6-stack with SPDIF
	  lenovo-101e	 Lenovo laptop
	  eeepc-p701	ASUS Eeepc P701
	  eeepc-ep20	ASUS Eeepc EP20
	  m51va		ASUS M51VA
	  g71v		ASUS G71V
	  h13		ASUS H13
	  g50v		ASUS G50V
	  auto		auto-config reading BIOS (default) 

The troubleshooting guide gives some hints as to the exact syntax needed.

Good luck, and please post here if you get stumped, providing output of:
cat /etc/modprobe.d/sound
rpm -qa | grep alsa
rpm -q libasound2

Please forgive me if I make some typos in this post because I am doing it while listening to a podcast on my computer. The sound seems to be working well – thanks for the help and the fast response.

You are correct that I had tried to update the alsa tools and driver, and I couldn’t get the driver to update. I was using the one step updaters on the suse site and I also tried the “install software” option in GNOME. I am not sure why I failed – perhaps because I didn’t use the bigsmp option? In what cases do I need to use this option?

One unrelated question: Where should I go to figure out how to compile/install packages if I choose to do that or if there are no RPMs for what I want to do. I don’t think I have the compilers and libraries installed.

Thats great news. Congratulations!

Quite possibly. A bigsmp is not very common, so most “automated” configurations are set for default.

I see the one click install as being good for newbies for the occasional app, but my view is for a regular user, it is still best to set up one’s repositories (dynamically if need be) and update that way.

For example, if I am looking for an application that is packaged as an rpm, I will often go to web: Webpin and in the “search” type in the application that I am looking for. It will show the application, and just as important (for me) it will show the repository where the application is located. Hence when the packaged rpm application is found, I do not use the “one click install”, but rather I add to my Software Package Manager of choice (zypper or smart … ) the repository to which the application is associated. Then I install the application with my Software package manager. This gives me more control and visibility into the process. … Perhaps not one click in nature, but if there is a hiccup, I have a better idea as to what happened.

I do not know a good reference. I learned too long ago, and the web sites (from which I learned) are no longer active.

Typically on openSUSE-10.3 one needs: make, gcc, gcc++, gcc42, gcc42++. For drivers one also needs kernel-source and the linux-kernel-headers. Other “devel” rpms will be needed for various applications being compiled, which is application specific.

Once again, thank you, thank you, thank you. Your answers have not only helped me get the sound going, but have saved me countless hours as I learn the system by pointing me in the right direction on a number of fronts.

I have one more question. We used zypper instead of YaST to correct the install. Am I correct in assuming that is because zypper gives one better control than YaST which seems like more of an automated tool? I did use YaST a lot while I was flailing away trying to get the sound going because it was in the steps of the Audio troubleshooting guide. It could do some configuration steps with the hardware it seemed, and I also used it to add my account to the audio group which I found I needed to do once everything else was working. I need to figure out more about YaST and zypper.

Once again, thanks for your time and your generous help.

Dave M

Sort of correct, in that it gives ME (the person making a recommendation) more control over what the user being helped actually does. To describe GUI navigation can be slow and tortuous. In truth, the GUI front end to zypper (which is YaST) is just as capable (but much much slower).

Zypper in 10.3 is useful, but it pales in comparison to the zypper that comes with 11.0. The zypper in 11.0 is faster, and has features that make it competitive from a functional point of view with other package managers … I confess I don’t use zypper myself, … I use a package manager called “smart”, which has similar capabilities to zypper in openSUSE-11.0. But I’m taking a hard look at zypper in 11.0, as it may eventually convince me to leave “smart”.

Something you might find of interest to read is the openSUSE concepts wiki page. I spent some time starting it, then a bunch of folks who know more than I about Linux dove in and corrected my inaccuracies, and improved the format and content of the page. Last I looked it was linked from one of the main openSUSE pages. And it is being kept up to date. If you have some computer background with Windows or another Linux distribution, I think it can be useful to read:
Concepts - openSUSE