Need Samba help 12.3-32 with xp-32 Pro on Local net

Hello list, moderators! I’m new to samba.

I’m trying to set up samba on an Hp Pentium4 with 12.3-32 to communicate with a Dell Pentium4 with XpPro-32, both connected with wire to the same router. Both boxes are dual boot Xp and 12.3. With both booted to 12.3 the boxes communicate with ssh.

The Dell usually runs Xp and has the printer. I’ve enabled file sharing on the Dell with the share being it’s E drive. The Hp usually runs 12.3 and I’ve installed samba on it. Both of the 12.3 installs use lxde desktops, but have dolphin also installed. The Hp has the kde4-fileshare installed to get the dolphin share tab to display.

I used this link for samba installation instructions: How To Network openSUSE 12.3 And Windows » TweakHound

The instructions for the samba setup look like this: "Start-Up tab: ensure During Boot is enabled, check the box next to **Open Port in Firewall **Shares tab: check the box next to Allow Users to Share Their Directories, optional is to check box next to **Allow Guest Access **
Identity tab:
Enter your Workgroup name (the actual workgroup name from your Windows machine) and the name of your computer.

Click the OK button".

One question from this is “the name of your computer”? Here I put the Dell Windows Xp computer’s name.

The Dolphin smb share setup is a Linux drive named /share formatted as FAT32.

When I browse with dolphin to Network > Samba shares there’s nothing there. Similarly smb://windowsworkgroup or smb://windowscomputername also find nothing.

nnb and smb daemons are running on the Hp.

Did I put the samba on the wrong machine? Is there more I need to do on the Xp box to make this work? Heboland.

Hi heboland,

This is what I understood so far (correct me if I’m wrong):
[li]You have a Dell box which is (mostly) using Windows XP[/li][LIST]
[li]This box have a SMB share [/li][/ul]

[li]You have an HP box which is (mostly) using openSUSE 12.3 [/li][li]All box are connected to the same router[/li][ul]
[li]They are in the same LAN [/li][/ul]

[li]The goal is to access the Dell box SMB share from the HP box using Samba [/li][/LIST]

For clarity, I’ve done a schematic of the situation below. I named the Dell box bill and the HP box lezard.

           +---------------------| Router |-------------------+
           |                     +--------+                   |
           |                                                  |
           |                                                  |
+----------------------+            LAN              +-----------------+
|        bill          |                             |     lezard      |
|     (Windows XP)     |                             | (openSUSE 12.3) |
+----------------------+                             +-----------------+
|         SMB          |
| workgroup: workgroup |
| share: sharename     |

I guess you are talking about the “NetBIOS Hostname” field shown in the screenshot below (this screenshot was taken from the website you followed and will be available here for 1 week).

This field is used to set the NetBIOS name of the current machine. So in your case it would be HP openSUSE 12.3 computer’s name (lezard according to my schematic). Note that if you leave this field empty, the unqualified hostname (${HOST%%.*}) of the current machine will be used as NetBIOS name.

You have two different computers which have the same NetBIOS name: SMB network browsing can’t work in that conditions. You should see errors in /var/log/samba/log.nmbd.

My recommandation is to change the NetBIOS name you openSUSE 12.3 box. If it still doesn’t work, please give us a copy of you smb.conf file so we can investigate more.

Thank you Kalten! You gave me a wonderful explanation of my environment and you have it correct.

I had my doubts about the computer name entry, but I thought the samba setup would know the name of the computer that was running the setup.

I’ve changed the name now to the HP computer now and will try to get connected.

When I have some results, I’ll report back again! Heboland.

Hello kalten, list!

I’m back with some results. Part of my problem here was that I didn’t know what to expect. There’s a lot of rambling that follows.

That rambling can be summarized as dolphin sort of works now. dolphin displays bill’s share expept for printers, and I can access them from lezard. The lxde file manger pcmanfm will display bill’s shares including printers, but reports bill’s shares are not mounted.

If possible I would like to get pcmanfm to access bill’s shares and to access bill’s printer. Can I get more help for those topics in this thread? Heboland.

Ramblings follow:

Over the weekend, I was able to test a windows network connection between bill and lezard both running Xp Pro. In this process I had to install the windows network drivers on lezard running Xp. At the same time I reloaded those drivers on bill.

Attempting the windows network connection between them, I noticed that bill wanted lezard with Xp to give bill’s guest password. With that I got a connection to bills share drive, shared folder and printers. I was able to print from lezard running Xp on bill’s printer.

Following your advise, I deleted the netbios in the lezard samba server setup. That didn’t change much. I got to thinking about the guest request from bill, so I ran lezard (running 12.3) samba server setup and check the guest box.

Following the reboots described in the TweakHound link, I expected to browse with dolphin to my Samba Shares but it was empty. Network is also empty.

I went to the dolphin location bar and started hacking. I found that smb://username/bill would open up bill’s share except for the printers. username could be me or guest, but only the guest password would make bill happy.

I tried to add bills share as a network folder, but I haven’t been successful with that.

Remembering that lezard is a 12.3 syetem with lxde and dolphin, I tried the same location bar hack with pcmanfm. It gives the same display of bill’s shares as dolphin, plus a Print folder.

Unfortunately pcmanfm will not open any of bill’s display. pcmanfm responds to any attempt to open bill’s folders with “The specified location is not mounted”. This suggests to me that I may have to create mount points for bill’s folders. Maybe I need to install nautilus-filesharing.

Also there are “keyrings” and “wallets” resulting from these location bar entries. I think I’ve been able to dodge them, but maybe these password contraptions are stepping on something.

So now you can see bill shares in Dolphin, Samba browsing must have been fixed. It seems however that you are confused about what does what. I don’t know for pcmanfm so I will mostly talk about Dolphin.

Dolphin is a file manager which, as a feature, allows to browse SMB network. As far as I know, Dolphin never shows a printer shared using SMB (it makes sense to me, Dolphin is a file manager after all, not a printer manager). Anyway, an important fact is that Dolphin doesn’t mount SMB shares. You can see the share, you can get and put files but the share isn’t part of you computer file system. This is why you can see the share from Dolphin but not from other applications.

If you want to access to an SMB share with all applications in a transparent way, you must mount the SMB share into you computer file system. There are several options to do so, including gvfs (Gnome “click-and-mount”), smb4k (KDE GUI for mounting SMB shares), pam_mount and of course fstab. Note that YaST module “Windows domain membership” can configure pam_mount for you (but for some reasons wont install pam_mount for you, so do it first!).

If you want to add to your computer an SMB shared printer, you can use YaST printer module or you favorite desktop environment tool (I know for sure Gnome and KDE configuration tools can do it).

Some clarification first in order to be sure:

  • bill is an SMB server sharing a share sharename and a printer printername.
  • lezard is an SMB client.

Checking the guest box in lezard YaST Samba server setup only allows guests to access lezard SMB shares, which is not what you were looking for. In fact, you don’t need to use YaST Samba server setup module at all in order to access bill shares from lezard. Neither do you need to have smb deamon running. You only need to use YaST Windows domain membership module and give the workgroup name. But as you started to configure Samba using YaST Samba server setup module, I didn’t see in my first post the need to make you start over with another tool.

Following what you described before, I was expecting that. Apparently, bill expects a password for the SMB guest. This is a Windows XP feature and has nothing to do with Samba. Maybe you should check bill configuration.

I remember that in the not so quite old time (I don’t use Windows XP in my network for years), Linux boxes wanting to access Windows (XP I think) SMB shares needed to provide a password for the guest account. Not a password in particular, just any password.

You can set a default Samba account and password in KDE settings. Dolphin will use those for browsing and accessing SMB shares.

This is very weird it worked because as far as I know smb://username/bill opens the share bill on host username… smb://username:password@bill/sharename opens the content of the SMB share sharename on bill host using username username and password password.

I guess pcmanfm tries to use gvfs to mount the share in a transparent way but fails for some reason. I can’t help you here as I don’t use gvfs or pcmanfm.

nautilus-filesharing will only allows users of lezard to share local files using SMB. This wont help to access bill remote shares.

I don’t think they are the problem. If authentification fails, you will be prompted for another username and password.

If you are still encountering issues, you should post here the content of lezard smb.conf file and the output of the following command line:

$ smbclient -NL bill

This command line intends to list the SMB services offered by bill without using a password (guest access).

Hello again kalten!

Thanks so much for your detailed responses and your earlier suggestion to change the netbios name.

Let me again summarize my accomplishments overnight. In fact I’m thinking I can mark this thread Solved altho some issues of low importance to me remain.

Now I do have bill shown in lezard’s dolphin > network > samba shares, but curiously lezard’s share is not shown there. I was able to create a dolphin network folder for bill after I got the syntax correct.

To me, lxde has a wonderful printer configuration tool, which configured bills All-In-One printer. For the scanner that goes with the printer, I had to use Yast > HW > Scanner. That gui has a network radio button, but not a samba button like lxde’s printer config tool.

Yast > HW > Scanner never found bill’s scanner,for me. This is a low importance issue to me.

Thanks for your explanation of how dolphin handles smb shares! Last night I installed smb4k and mounted bill’s share drive E. pcmanfm recognized the mount, but didn’t use it. Turns out that adding E to the pcmanfm location bar smb path causes pcmanfm to mount the share!

Then pcmanfm shows two mount points with different names for the same drive. With pcmanfm, I was able to bookmark bill’s share, so I have easy access to that now.

So configuring the smb printer, creating the dolphin network folder, and accessing bill’s samba share with pcmanfm is all I asked for and that’s solved.

A couple of rambling comments follow. The first deals with lezard’s firewall and the second with bill.

The yast > scanner got into a gui page apparently scanning for bill’s printer share. It complains about the firewall. I went to the yast > firewall to see if I could see a problem.

In the process of installing the samba server on bill, there were some hyperlinks, one of which was a elegant description of openSuse firewall 2. It described zones and how the LAN interconnect was kept internal. My impression was that samba traffic was all internal.

I was shocked to see all the samba ports configured in the external zone! I followed the TweakHound link carefully and this seems to be what I got. It works so I’ll use it as is.

Perhaps I should ask you for a link to the YaST Windows domain membership module.

Regarding bill, there are several things behaving weirdly! bill does not see lezard! That’s OK in my case as my interest is in accessing bill from lezard. bill’s guest account is not activated, but I can access bill from lezard with user guest!

Another authentication weirdness I think comes from lezard is the default user name that comes with an authentication pop-up. Wherever pop-up comes from it has my lezard user name filled in.

On bill my user name is the same except for my last name initial appended. Of course there is less to type as things are, but to me it’s misleading to give the wrong user name with the password prompt.

The password I gave to lezard for the smb-password is different from bill’s, but I don’t think I’ve ever had to use lezard’s smb-password.

kalten, you gave me a great deal of your time and patience, and I’m very grateful for it! Heboland.

Great! Except for the low importance issues of course.

In order to see lezard in Dolphin Samba shares browser you need to launch the nmb deamon as root:

# systemctl start nmb.service

You can also make it start at boot witch systemctl enable nmb.service and checking its status by using systemctl status nmb.service.

nmb is the deamon of Samba which screams over the network “I’m here!”, like Windows machines do by default.

I don’t think SMB can share scanners (this is why you don’t see Samba button in YaST -> HW -> Scanner) and I have limited knowledge of Windows (any editions) server capabilities. But I do know that the saned deamon can be used for network scanning on GNU/Linux. Maybe a Windows port exists. But this is another topic, so another thread ;).

I’m not sure, but I believe by default YaST Samba server setup opens Samba ports in the current firewall. If at this moment the firewall of your network interface was “external zone” (which means “I’m in an untrusted network, do not let anything go through!”), YaST opened SMB and NMB ports in the external zone configuration so your Samba server can be reached by other computers in the network.

Note that by default, all network interfaces in openSUSE belong to the “external zone” (security first).

bill doesn’t see lezard for the same reason lezard can’t see himself in Dolphin Samba network browser. Start on lezard nmb as described above and it should be ok.

Windows guest account isn’t the SMB guest account, those are a totally different thing. I don’t know what account (if any) is used for the SMB guest on Windows. With Samba, this is by default the user nobody.

You can configure a server on your network so one username and one password work on all computers… But this is far beyong the topic of the current thread. For details, search for NIS, LDAP or SMB domain controllers. openSUSE security guide contains a part about authentification. Without such a service available on your network, your are forced to rely on manually syncing usernames and passwords between each computer or remembrer all usernames and passwords needed.

You are welcome!

Have fun with openSUSE,

Thanks again kalten!

You don’t need to reply to this.

In order to see lezard in Dolphin Samba shares browser you need to launch the nmb deamon as root:

The Tweak Hound instructions enable nmb and smb from Yast > Services > Runtime. I enabled both with simple mode and selected them to start at boot.

When I checked them just now in simple mode, both were shown as running, but showed yes*. Going to expert mode showed nmb not running. I restarted nmb but that didn’t change the workgroup MSHOME display on either bill or lezard.

bill (XP) does not use dolphin. dolphin on lezard can find lezard’s share using fish:// in dolphin’s location bar, but lezard is not displayed in dolphin’s samba shares. Using fish:// the username, password are the ones for lezard.

FWIW, I tried to share bill’s All-In-One (AIO) scanner with lezard booted up to XP (XP to XP over Windows Network). That didn’t work either, so I concluded bill is only sharing the printer function from his AIO hardware.

This is probably the place in the openSuse forum for firewall questions, of course on another thread! Is it worth the moderator resources to pursue the following?

In the firewall1 document I read in the process of setting up the Samba and Ssh network functions, the doc described a means of moving ports between zones.

I have the time to experiment with such moves if it makes sense. The samba and ssh installations put those ports into the external zone for a reason, and maybe samba and/or ssh wouldn’t work if those ports got moved to the internal zone.

What I have now, I can make do what I need, but I do have time to experiment and learn if it’s worth the effort.

kalten, thanks again for your explanations and time! Heboland.