Need Privoxy to start up during boot on 11.3 kde4.

I am completely fed up trying to do it. I had no problems with 11.0. It refuses to start up during boot like tor. I added tor to the kde start menu and it works just fine after boot. Privoxy refuses to start up during boot. I have to go into SU mode in terminal, then it works. I need to be able to start Privoxy the same way. I tried everything from chown / chmod commands, and it made no difference. I have it set for 777, and my name along with root. I also added the group privoxy to my user ID. I need the computer to disregard that it is a root program. Any help would be appreciated.

usually rpms that come from opensuse repos have all the proper scripts installed with them so i’m at a loss to try and explain how you ended up in this situation.

Usually the rpm will install a service startup script in /etc/init.d that does the job of starting the service during boot. Sometimes you have to go to Yast>SystemServices and find the entry for the service (privoxy) and enable it by highlighting the entry in the list and hitting the “Enable” button on the lower left.

If privoxy is not present in the services listing, then i would suggest you get a rpm from the standard repo.

good luck.

I installed it on 11.3 from the suse repos the only anomaly I noticed is the init script was renamed to /etc/init.d/privoxyd and I did have to set it to start in Yast>System Services (Runlevel)>privoxyd

I use mobile broadband which is basically dialup so I had to use /etc/init.d/privoxyd restart with a sleep timed to let the networkmanager connection get domains in resolve.conf before starting privoxy. Else privoxy couldn’t find the connection.