Need help with wireless card 4965ag

I can not get wireless card to work. any ideas

linux-ekat:~ # /usr/sbin/iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11g ESSID:""
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Tx-Power=27 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Encryption key:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

linux-ekat:~ # /usr/sbin/iwlist scan
lo Interface doesn’t support scanning.

eth0 Interface doesn’t support scanning.

wmaster0 Interface doesn’t support scanning.

wlan0 Scan completed :
Cell 01 - Address: 00:13:10:C9:C8:3A
ESSID:“dink”
Mode:Master
Channel:6
Frequency:2.437 GHz (Channel 6)
Quality=96/100 Signal level=-32 dBm Noise level=-127 dBm
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Extra:tsf=00000426b48d7360

Here is an update of Iwlist

linux-ekat:~ # /usr/sbin/iwlist scan
lo Interface doesn’t support scanning.

eth0 Interface doesn’t support scanning.

wmaster0 Interface doesn’t support scanning.

wlan0 Scan completed :
Cell 01 - Address: 00:13:10:C9:C8:3A
ESSID:“dink”
Mode:Master
Channel:6
Frequency:2.437 GHz (Channel 6)
Quality=96/100 Signal level=-30 dBm Noise level=-127 dBm
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Extra:tsf=0000042a0285628e

/usr/sbin/iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11g ESSID:“dink”
Mode:Managed Frequency:2.437 GHz Access Point: 00:13:10:C9:C8:3A
Bit Rate=54 Mb/s Tx-Power=27 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Encryption key:20CD-C650-01
Link Quality=100/100 Signal level=-32 dBm Noise level=-96 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

linux-ekat:~ # lsmod |grep iwl
iwl4965 116448 0
firmware_class 13696 2 microcode,iwl4965
mac80211 178196 1 iwl4965

It seems like it should work. I am using an HP Pavilion laptop with Suse 11.

I was just wondering if this wifi driver has been improved? When I first installed openSUSE 11 on a HP Compaq 6910p which uses an Intel Wireless WiFi Link 4965AG the wireless card wasn’t detected. I was able to use ndiswrapper but the wireless was hit or miss and when it did work I would get disconnects. One solution was to compile the driver myself from Intel’s website but I am not sure how to do that. I ended up reinstalling Windows since it was necessary that I have wifi working. I noticed that beta 11.1 was out so I am revisiting this to see if I install openSUSE 11 on thie 6910p if the wireless will work alright.

Look forward to any and all responses.
Thanks!

What does dmesg show


linux-nocz:/home/don # dmesg |grep iwl
iwl4965: Intel(R) Wireless WiFi Link 4965AGN driver for Linux, 1.2.23ks
iwl4965: Copyright(c) 2003-2007 Intel Corporation
iwl4965: Detected Intel Wireless WiFi Link 4965AGN
iwl4965: Tunable channels: 11 802.11bg, 13 802.11a channels
phy0: Selected rate control algorithm 'iwl-4965-rs'

And lspci


linux-nocz:/home/don # lspci |grep 4965
03:00.0 Network controller: Intel Corporation PRO/Wireless 4965 AG or AGN Network Connection (rev 61)

Mine works just fine.

Yes, it should. Did you set encription correctly, i.e., same protocol (WPA, WEP) and password both in the router and in Suse. Or better, try first without encription, just to see if it connects.

I have a Pavillion dv6000 series with a broadcomm wireless, after some tinkering it works ok.