Need help with wireless adapter

I have a Belkin f7d1011 usb adapter. After some digging I found out that it uses the Realtek RTL8188SU chipset. I found this Realtek after a LOT of searching and my question is:

Will this work? And if so how do I install it? I’m a pretty big linux noob. I want to get this working so I can download some programming libraries :slight_smile: Thanks in advance ^^

No replies so far but I found this:

howto: Belkin F7D1101 with RTL8192SU from staging - Ubuntu Forums

can someone give me equivalent instructions for opensuse?

Such as does “network_drivers.rules” = “77-network.rules”? And I see nothing equivalent to “network_drivers.conf”

I’m not sure, but I would guess you could skip the whole first section of the link you posted. Those instructions were written in July, and there’s been a new kernel released since. The reason they need the whole first part is because the kernel doesn’t have the USB id. I would update your system with all the latest updates and then see what happens.

It doesn’t matter what you call the network.rules and network_drivers.conf files as long as they’re in the correct directory. I would suggest you make it rtl819su.rules and rtl819su.conf. (but once again, this may not be needed if the kernel recognizes your device and knows which firmware you need)

Does your network card come on at all?
If you use the command

dmesg | grep -i firmware

does it show that it’s looking for a firmware file?

Try installing kernel-firmware and see if it makes any difference.

zypper install kernel-firmware

I see there’s some realtech firmware in there, but I’m not sure if it’s the same one your card needs (dmesg should tell us).

Awaiting your reply…

Well I couldn’t get the command you listed to work, nothing happened, but I ran dmesg | less from one of the stickies and got this:

usb 1-9: USB disconnect, address 4
usb 1-9: new high speed USB device using ehci-hcd and address 5
usb 1-9: New USB device found, idVendor=050d, idProduct=945a
usb 1-9: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 1-9: Product: Basic Wireless USB Adapter
usb 1-9: Manufacturer: Manufacturer Realtek
usb 1-9: Serial Number: 00e04c000001

I also installed kernel-firmware off of the install disc.

So, it’s not asking for firmware. That means it’s probably not even turning on. You don’t see a light come on or anything, right?
I would follow the instructions you gave in the link above, to create the network rule and network configuration.
Then, you can restart your system and look in dmesg again, and you should see it asking for firmware. Then, you just need to supply it the firmware it’s looking for and you should be good.

I think the problem I’m running into now is:


doesn’t exist… it probably does in ubuntu but not in opensuse. So, where to from here?

This file is created from the rule you create. I had to do essentially the same thing for my card until the kernel was updated. Mine uses the rt2870sta chipset.
Personally, I would create the file as rtl8192su.conf.

touch /etc/modprobe.d/rtl8192su.conf

Then edit it and add in the rule.

install r8192s_usb /sbin/modprobe --ignore-install r8192s_usb $CMDLINE_OPTS; /bin/echo "050d 945a" > /sys/bus/usb/drivers/rtl819xU/new_id

Also create the other file network_drivers.rules. I would also create a custom name for this.

touch /etc/udev/rules.d/rtl8192su.rules

Then edit it and put the rule in it.

ACTION=="add", SUBSYSTEM=="usb", ATTR{idVendor}=="050d", ATTR{idProduct}=="945a", RUN+="/sbin/modprobe -qba r8192s_usb"

Once you have all that in place and reboot, if the network card comes on but dmesg shows missing firmware, all you should have to do is put the firmware in the correct place. If it’s still not coming on we’ll have to look at things again.

Thank you SO much. I’m responding from my Linux partition. My card is up and running! Anyone else with this card, just download the firmware from the link I had, put it where the Ubuntu tutorial said to, and follow the instructions rodhuffaker gave to get it working.

Once again, thank you so much. ^^

I also had issues using the udev rule. It didn’t seem to load the module properly.
The workaround for that was to add the module to the /etc/sysconfig/kernel file so it looks like this.


That will solve the issue if it’s not loading. To tell if it’s loading you can use

modprobe -l |grep r8192

You should see your module in the list. Rebooting may be required.

Awesome! Congratulations, I’m glad to have helped.

By the way, you probably won’t have to go through all this in the future. Your nic is fairly new. Once that usb id is added to the kernel, you’ll just have to install the firmware.