Need help with Tumbleweed update.

Hi guys,I’ve pulled in Tumbleweed repo,when I update the thing,this show:

Which option should I take? :slight_smile:

You are using vmware kmp packages, and they are not being built for Tumbleweed.
Neither are the closed source broadcom kernel module (where did you get that?)
or the ndiswrapper kmp.

In short, if you are going to have to rely on closed source kernel modules,
like broadcom, you can’t use Tumbleweed, sorry.

If you remove those kernel module packages, you should be fine to update and
use Tumbleweed.

Good luck,

greg k-h

Ya my wireless chip is Broadcom 4312 14e4:4315,I have to pulled in certain kernel modules to work it.
Thanks for yr advice fren.

Maybe you have already, but try your broadcom wireless chip without the modules. I used to have to use the same closed-source modules to make mine work, but with 11.4 I don’t because of the new open source brcm80211 firmware included. The indicator light does NOT come on, so at first I missed it and tried to build the modules.

Hi fren,u mean u have same Broadcom wifi chip 4312 14e4:4315? 11.4 KDE already support it? So I can uninstall the broadcom-wi & broadcom-wl-kmp-desktop I pulled in and still get the wifi work? Mind explain further? :slight_smile:

I don’t have that chip, so I can give you no guarantees. I would try it (uninstall broadcom-wl but be prepared to reinstall if it doesn’t work). With mine, that is what happens with 11.4. Wireless works, but the wireless indicator light on my laptop does not come on. With previous versions, wireless never worked out of the box like this.

Ditto , me too.