Need help with system hanging

I’ll start off saying that i’m new to opensuse. I have 13.2 installed on a 2009 imac. I did a base install with 13.2 also have the latest plasma 5.2 installed. I have been experiencing a system that will not come back to life when i come back to it the next day. Nothing i do wakes it back up. none of the basic keystrokes i’ve tried does anything. The syslog isn’t showing me anything either. This has been happening prior to the recent 5.2 release as well. I installed this system a few weeks ago and it has happened more often than not when i leave it for the night and come back.

Here are my repos:

KDE_Frameworks_5 -

Any thoughts?

Is the system completely frozen or just the X-windows server?

If you’re not sure, you can try flipping over to a virtual terminal using CONTROL-ALT-F1 (Maybe CONTROL-OPTION-F1 on the imac? – I don’t have one in front of me). You can read about switching between multiple virtual terminals and window servers at the link [1] below.

If it’s the Window Manager, maybe CONTROl-OPTION-BACKSPACE will be a temporary workaround (restart X-windows server).

You can also look at the X-windows server logs in /var/logs (Mine have shown up at /var/logs/lightdm/* and /var/logs/Xorg.*)

If it’s the whole system, you might be able to discover something by leaving “top” running. Ideally, you’d probably want to do that from a remote ssh login on another system, but you might be able to get away with leaving it running on the virtual terminal with the virtual terminal open.

I’m no expert, but these are some of the troubleshooting steps I’ve tried in the past.


You do know that Plasma 5.x is still very much beta right??

I appreciate the tips! I ended up starting over from scratch in the hopes it would take care of the problem. It did not. :frowning: However, the info you posted should help me troubleshoot further. One interesting thing to me is that not even a ctrl+alt+del works. No key sequence i’ve tried so far works. I haven’t tried the SysRq key sequences yet as i only have mac keyboards. I found some potential workarounds for this though.