need help with openssl

so, I have a file i encrypted with openssl version 1.1.1d with this command line

openssl enc  -md md5  -e -aes-256-cbc -salt -in in_file.txt -out out_file.bin -pass pass:<password>

and that was working fine, i could decrypt it with no problems
But now on TW when i try to decrypt it i get gibberish because my openssl version is 1.1.1h

openssl enc -md md5 -d -aes-256-cbc -salt -in out_file.bin -out temp_file.txt -pass pass:<password>

How can i adjust my command line to decrypt the file properly with this new openssl or alternatively how can i install the old openssl version?
Just to be clear, this all worked flawlessly under openssl 1.1.1d

I have no issues decrypting files encrypted by much older OpenSSL versions, so unless there was very specific issue in 1.1.1d I’d rather suspect file corruption.

Yeh, so, i am not sure whats going on but in the end i just started over and got my command lines to work, fortunately i had the unencrypted data still to work with so i could try it out and verify things worked as expected. The man page is next to useless and doesn’t even document the switch “-in” amongst other missing info but googleing around got me going eventually.

openssl enc  -md sha512 -pbkdf2  -e -aes-256-cbc -salt -in <plain_text_file> -out <encrypted binary file> -pass pass:<password>

decryp (to stdout)t:
openssl enc -md sha512 -pbkdf2 -d -aes-256-cbc -salt -in <encrypted binary file> -pass pass:<password>