Need help with my wireless card.

Hey guys. I’m having problems connecting to my wireless router. i assume my card is a Broadcom BCM4318 because when i run the command ‘/sbin/lspci’ i get:

06:01.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)

I assume i have the correct drivers because when i do ‘usr/sbin/iwconfig’ i get:

wlan0 IEEE 802.11g ESSID:""
Mode:Managed Channel:0 Access Point: Not-Associated
Tx-Power=0 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

But i guess the biggest hint that something isn’t working is when i use the command ‘sudo /usr/sbin/iwlist wlan0 scan’

wlan0 Interface doesn’t support scanning : Network is down

Any help would be most useful.

what does dmesg show ? anything about missing firmware ?


i did try that but there’s just so much stuff in there i really don’t know what to look for. i did find this if it’s any help:

b43-phy0: Broadcom 4318 WLAN found
phy0: Selected rate control algorithm ‘pid’
Broadcom 43xx driver loaded Features: PMLR, Firmware-ID: FW13 ]

ok,you’ve got the firmware, have you configured it via YaST - network devices - network settings ?


Yeah i think so.

it says:
BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (Not connected)
MAC : 00:1d:60:54:2a:78

Device Name: wlan0
Started automatically at boot
IP address assigned using DHCP

and i put in the name of my wireless thing, and the WPA-Personal key, which i’m sure is right.

in the global settings do i want to have Network Setup Method as ‘user controlled with Network Manager’ or ‘Traditional Method with ifup’.

Also what does the hostname do? currently it’s ‘linux-wibo’, should i change it?

you can use either, most people stick with network manager. don’t worry about hostnames. now you have filled in all the info. on the bottom-right of your screen should be network manager. click on it & select new connection,then wireless.Your router/hub should appear on the list. click on it & fill in the details. then click on next,next,save. you should now be able to connect