need help with init 3 for nvidia install

i did it for many years from 10.2 onward. i thought these were the steps -
Ctrl-Alt-F2
login as root
type init 3
then navigate to your driver and install.
then reboot, or init5 i forget which

i must have forgotten something because now when i do -
Ctrl-Alt-F2
login as root
type init 3
all i get is the mouse cursor blinking and not letting me write any text what-so-ever.

can someone tell me which bit i did wrong because right now i’m using the Driver: “nouveau” and i uninstalled the nvidia one because i’m using tumbleweed and want to install it the correct way. thanks

Yes, but unfortunately I don’t know how to do it correctly… 12.1 switched to systemd, which replaces the old system V runlevel system. But you’re looking for the command that gets systemd to run without X I think, I just don’t know what it is.

But, as a work around, it appears from this page: openSUSE:Systemd tips - openSUSE, that the instruction for booting to runlevel 3 from this page (under “3rd thing to try”): SDB:Configuring graphics cards - openSUSE, might do the trick. Of course this is not a good answer, but I don’t know how to use systemd.

hi,

this the way I do it…

open a terminal and do:

sudo echo "blacklist nouveau" >> /etc/modprobe.d/50-blacklist.conf

That step is for making the nVIDIA installer happy, it doesn’t like Open Source :wink:

open yast -> editor for systemfiles (in english) -> system -> kernel -> change this to yes “NO-KMS-IN-INITRD”

That’s because I don’t think nVIDIA:s driver like Kernel mode switching, might have changed but I don’t think so…

reboot

At the Grub menu, add a 3 to the boot line and hit enter, that will make it boot to init 3.

log in as root and install as you usually do.

Kind Regards Thermal…

I’ve never tried it that way. I always reboot and type “init 3” in at the grub screen (without the quotes).

How do you install the driver finally? I’m asking because if you install the driver from nvidia repo, none of the step you described is needed.

  • nouveau will be blacklisted in /etc/modprobe.d/nvidia.conf. No need to blacklist it twice.
  • If enable, KMS will be disable by the postinstall scriplet of the rpm package. No need to rebuild the initial ramdisk twice.
#  **rpm -q --scripts x11-video-nvidiaG02 | grep -A3 KMS
**# recreate initrd without KMS, if the use of KMS is enabled in initrd
if grep -q NO_KMS_IN_INITRD=\"no\" /etc/sysconfig/kernel; then
  sed -i 's/NO_KMS_IN_INITRD.*/NO_KMS_IN_INITRD="yes"/g' /etc/sysconfig/kernel
  mkinitrd
fi
exit 0

  • (Normally) you don’t need to boot in runlevel 3 to install the driver.

thermalgrease wrote:

>
> hi,
>
> this the way I do it…
>
> open a terminal and do:
>
> Code:
> --------------------
> sudo echo “blacklist nouveau” >>
/etc/modprobe.d/50-blacklist.conf
> --------------------
>
> -That step is for making the nVIDIA installer happy,
it doesn’t like
> Open Source- :wink:
>
> open yast → editor for systemfiles (in english) →
system → kernel →
> change this to yes “NO-KMS-IN-INITRD”
>
> -That’s because I don’t think nVIDIA:s driver like
Kernel mode
> switching, might have changed but I don’t think
so…-
>
> reboot
>
> At the Grub menu, add a 3 to the boot line and
hit enter, that will
> make it boot to init 3.
>
> log in as root and install as you usually do.
>
>
>
> Kind Regards -Thermal…-
>
>
I do it basically the same way except:

Code:

sudo echo “blacklist nouveau” >>
/etc/modprobe.d/50-nvidia.conf

Seems to work fine. Found this change in the wiki
procedures for Nvidia somewhere, not sure which is
correct.


Russ

The OP is using Tumbleweed + Nouveau… I didn’t know there was a nvidia repo for Tumbleweed, and he knew how to install the nvidia run file. Did I somehow give incorrect adwise? If so pardon.

Kind Regards Thermal…

On 2011-12-11 17:06, potatomash wrote:
> type init 3
> all i get is the mouse cursor blinking and not letting me write any
> text what-so-ever.

“Init 3” should work, too. In my case it takes long to work, you may have
to wait a bit. If it doesn’t, raise a bug.

But first try booting with systemV - at the grub display, use F5 to change.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Yes, I was about to add that it does make sense if you install the driver manually. But “install as you usually do” was unclear. Your advise is correct otherwise. People installing from repo (and NOT using Tumbleweed) don’t need to apply these steps though.

hehe

isn’t “install as you usually do” crystal clear?? what…

:wink:

lol!

Problem is with systemd. Nouveau needs to be blacklisted, KMS needs to be set at yes, or use “nomodeset” at boot, and booting has to be done with sysvinit. With systemd there’s no real “init 3”, so you’ll end up with a running X server which disallows the driver to be built.

I have only used the 290.10 driver with OpenSUSE 12.1 and it works for me to install it when booting to that systemd version of “init 3”. No problem at all, I just reinstalled it to make sure. Perhaps nvidia adopted the installer to systemd, I will try later with an older driver.
Only thing I noticed is that it takes a long time before you get a login promt when using “init 3” from grub.

In that case - as I suspected - your own advice didn’t apply to you. That’s why I asked how you finally installed the driver. “install as you usually do” wasn’t just unclear but also unsaid.

AFAIK there are no issue with runlevel 3. You can choose runlevel 3 during setup and it will boot in console mode in systemd too. To change the default runlevel in systemd, set the symlink /etc/systemd/system/default.target to the desired runlevel target in /lib/systemd/system.

A system that boots in runlevel 3 will have this symlink:


# readlink /etc/systemd/system/default.target
/lib/systemd/system/runlevel3.target

Anytime you do a init x you are left with a blinking cursor just press enter to get back to command, I assume it is still that way with 12.1 I’m still at 11.4

On 2011-12-11 22:06, thermalgrease wrote:
> Only thing I noticed is that it takes a long time before you get a
> login promt when using “init 3” from grub.

Yes, because systemd hides the messages.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

On 2011-12-11 22:56, gogalthorp wrote:
>
> Anytime you do a init x you are left with a blinking cursor just press
> enter to get back to command, I assume it is still that way with 12.1
> I’m still at 11.4

I don’t see that behaviour.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Maybe it has changed but it has always been like that on my machine since 10.1

I’m afraid I don’t understand what you getting at, I have no problem, The OP wanted to install the run-file from init 3 (that what my “install as you usually do” meant, since I aswered him). I provided a way for him to get to init 3 with no Nouveau in the way when he started to install. Then I noticed Knurpht’s post about systemd and that you couldn’t install the driver booting with that. I tried and it worked hence the question about if the nvidia driver had been adopted to systemd.

I fail to see what your questions have to do with me, I have no interest changing default runlevel. And what do you mean about my own advice didn’t apply to me? I’m sorry but I feel you must have this thread all wrong or you just want to pick on me for some reason?

Kind Regards Thermal…

On 2011-12-11 23:56, gogalthorp wrote:
>
> Maybe it has changed but it has always been like that on my machine
> since 10.1

Never since 5.3 in any of mine :slight_smile:


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

I have not noticed that it takes a long time to get to the end of your system startup when you enter the option 3, which takes you to run level 3 in openSUSE 11.4, like entering init 3 from a desktop except some things may keep going on in the background while your desktop starts, which you normally don’t see on startup. It is my understanding that run levels don’t exist per say when using systemd though they are simulated for many things to still work properly while using systemd in openSUSE 12.1. For anyone that does need to go to the old run level 3 in order to install the nVIDIA video driver or any driver that needs to be run in that mode might want to look at my fastboot bash script. If skips the actual boot process, reloading the kernel directly and fastboot allows you to specify a load option 3, useful for loading video drivers. You can find the script here:

FastBoot for Grub Legacy Menu using Kexec - Version 1.32 - Blogs - openSUSE Forums

Thank You,