Need help with file associations

I am having a problem setting up the default app for my image files. Currently they are associated with Gimp. I want to have them associated with another program that allows me to view the files. The ways I have tried to change it are as follows

  1. In dolphin I right click a file and choose properties click the File Type Options button and in the dialog boxes Application Preference Order I select the program I want to open the files with move it to the top click apply and then when I click the file to open it Gimp opens it If I re select the file and choose properties again Gimp is back on top of the List again.

  2. In KDE Control Center I have tried changing them through this tool and it doesn’t change it either.

My Current Setup is openSUSE 13.1 with KDE Plasma Desktop.

I have tried changing the default and logging out and back on for changes to take affect but nothing seems to allow me to change the files association.

Any help is appreciated

Both should work.
Have you tried to logout/login for the change to take effect? (or run “kbuildsycoca4”)

I have logout/login for changes to take effect but it didn’t work.

Never heard of kbuikdsycoca4 is that a command line tool?

Ok this is the results of running the above command line

kbuildsycoca4 running...
"KConfigIni: In file /home/argedion/.local/share/applications/mimeapps.list, line 36: " Invalid entry (missing '=') 
kbuildsycoca4(30973) KConfigGroup::readXdgListEntry: List entry text/html in "/home/argedion/.local/share/applications/mimeapps.list" is not compliant with XDG standard (missing trailing semicolon).

Sorry. I forgot that “kbuildsycoca4” is only called automatically on login if you installed new packages.

Never heard of kbuikdsycoca4 is that a command line tool?

Yes. Just type that in a terminal window (Konsole f.e., or even in the Alt+F2 dialog). It notifies all parts of KDE that the settings have changed.

This should actually be called automatically when you change the file associations, but on some systems (like mine) this doesn’t work. And that’s a long standing bug that was already there in KDE3 times. But no solution (not even the cause) has been found yet:

Ok found the issue well not really but I did get it solved :slight_smile:

in my .local/share/applications/mimeapps.list

I deleted the file and rebooted the computer I then choose the app i wanted associated with the file and it worked great :slight_smile:

Right, the file associations are stored there.

So maybe that file got corrupted somehow, and that confused KDE?

The issue I mentioned is something different though. You could see that you are affected by that one when the progress indicator in that “Updating system configuration” dialog (which appears after you click on “Apply” or “OK”) just endlessly loops and never actually finishes.
In that case, the configuration is saved correctly but the system is not notified of the change, so you have to call “kbuildsycoca4” manually.

Glad it’s working now for you, though! :slight_smile:

In my mimeapps.list it only records the changes; so it may have been a permissions issue that preventing writing the changes. It appears that removing it would return you to the default associations and the first change you made would create a new list of changes.

Yes, of course.
It’s a user-specific override for the system-wide file associations.

But you’re right in that wrong permissions of that file could have caused that problem as well.
And when you remove the file, it would get re-created with the correct permissions of course, when you change again some file associations.