Need help using ImageWriter to upgrade from 11.1 to 12.2

I need to upgrade from OpenSuse 11.1 to 12.2 without a cd. File retention is not a concern. I can’t seem to get a hold of ImageWriter so I can creat a usb boot device to install 12.2.

In early attempts at getting ImageWriter onto the system, I did a poor job of trying to add an ImageWriter repo (see Extra Info below) so I could “zypper in”. This is the output of “zypper in kiwi-tools-imagewriter” (I used kiwi-tools-imagewriter because of info gained from this thread):

root's password:
Error building the cache:
|] Repository type can't be determined.
Warning: Disabling repository 'ImageWriter' because of the above error.
Loading repository data...
Warning: Repository 'openSUSE-11.1-Update' appears to outdated. Consider using a different mirror or server.
Reading installed packages...
'kiwi-tools-imagewriter' not found.
Resolving package dependencies...
Nothing to do.

I went into YaST and removed the faulty ImageWriter repo I had added. Then I ran the same command as above and got basically the same message without the condescending bit about my ****** repo.

Can I make an OpenSuse 12.2 boot stick? Can I do it without ImageWriter? If not, how the hell do I get ImageWriter?

**Extra Info:
So basically, for unfortunately microsoft-related reasons, my pc took a dump and I was forced to reformat. This gave me a great excuse to get back into Linux. I’ve used Crunchbang in the past and really enjoyed it but I wanted to try a new distro, especially one that didn’t make it so easy for me to screw up my system by tinkering around. So, I used my roommate’s netbook to download unetbootin. Used unetbootin to load OpenSuse onto a flash drive. Unfortuantely, unetbootin only has OpenSuse Factory and 11.1. So I used 11.1 and figured I’d just update to 12.2. I was wrong. I’ve tried using unetbootin and manually choosing an updated OpenSuse 12.2 iso (specifically the Live GNOME iso and the NET iso) but when I tried to boot from it I kept getting errors about not being able to find the kernel.

If any more info is needed, I’m happy to provide.

**TL;DR - **Can’t get ImageWriter to work, need to make usb boot device for OpenSuse 12.2 while using OpenSuse 11.1

11.1 is end of life

Check this

On 2013-01-03 10:26, caf4926 wrote:

> Check this

which says to use imagewriter, thus his problem.

Cheers / Saludos,

Carlos E. R.
(from 11.4, with Evergreen, x86_64 “Celadon” (Minas Tirith))

Imagewriter wasn’t in 11.1 though

Old repos are active here
Index of /pub/linux/suse/opensuse/discontinued/distribution/11.1/repo

Index of /pub/linux/suse/opensuse/discontinued/update/11.1

Or for windows version

To get imagewriter for 11.1? AFAIK a no go. But …you can use “dd” to create a USB install medium. If you don’t know how / cannot find out how, get back here and we’ll get you through. To prepare, download a LiveCD with the desktop of your choice (KDE / GNOME), and have an empty USB medium (min. 1 GB) ready.

Actually, after making this post I blindly stumbled onto a website that gave decent instructions on how to use “dd”. Worked like a charm. Currently posting from a significantly upgraded OpenSUSE. Now I just need to figure out how the hell to use it…

Good !! I hope you performed a clean install, and did not attempt to upgrade the installed system.