Need help setting up headset/microphone. OS 12.2/KDE


I have spent at least 2 hours googling, searching, adjusting settings and I’m about to flip out. This is so frustrating. All I wanted to do was talk to my friends on Teamspeak. That is all. I have a headset with 2 connectors, 1 for the headphones and 1 for the mic. They are plugged in the correct sockets. The sound works fine (in fact regardless of what I do with any settings, the sound always seems to work for some reason). Microphone? Hell no.

I have been through Kmix, pavu, yast, god knows what. Tried for some help in the IRC channel, and disabling pulseaudio seemed to open a few doors. But still I have not been able to get the microphone to work in Teamspeak. One thing is I have no idea how to test the devices I have plugged in. I’m pretty sure Teamspeak is installed fine, but I have no way of knowing which sound/microphone channels to use or which are operational. I have tried all the channels I can see in Kmix. So far I have been fiddling with options and testing through Teamspeak, which I don’t think is the best way.

If someone out there could please help me, I am at my witt’s end. If one is willing to help me, I suggest following a few simple rules:

  1. Assume I am a complete idiot. Please outline how to execute all steps, including navigating through menus or using the console.
  2. I have a fresh install of openSuse 12.2. Assume I have ruined/deleted any audio settings and packages.
  3. Remove/reinstall any and all existing audio softwares/packages/you name it, using only necessary packages. I would like to use the Kmix front end please.

The outcome I desire is to not only have my headset working (which it currently is) but also to be able to use my microphone. Having an understanding of how it’s set up would be good too. The Kmix and Phonon documentation is god awful.

yast==>Sound==>Other==>Volume==> Is the mic volume low ?

No, I’ve been through that (not that you knew). Every volume is on max.

That’s part of the confusion, there are at least 2 mics, and also Line in? Front, Back, Line, and also Front Mic Boost and Back Mic Boost. Anyway, I put them all on 100%, all Boost on 100%. Everything on that screen 100%.

In Kmix I have used all 3 the same way, with Capture 1/2/3 on full as well. Nothing seems to work.

If it helps I have a Plantronics Gamecom headset. Asrock Pro4 motherboard. There seems to be a couple options to plug in the headset, but only 1 for the mic so I’m pretty confident about that. The mic mute on the headset itself is off of course.

You could investigate a couple of possibilities …

One is that despite your best efforts, your mixer is not configured properly. If you post your audio configuration we can check to see if that is a possible cause. You can do that by configuring your mic as best possible, then with your pc connected to the internet open a terminal/bash-shell to launch a diagnostic script with this command:


and select the UPLOAD/SHARE option, and allow the script to complete, after which in the bash shell/terminal you will see a web site/url address where your PC’s audio configuration has been uploaded to. Please post the web site/url address here and we can look to see if there may be an explanation there.

The other possibility is that pulse audio needs to be configured to work with your application. I don’t know if it will help, but if you have not done so already, try installing ‘pavucontrol’ and then follow guidance in this blog: … I do note you referred to an app called ‘pavu’ which I have never heard of.

Thank you very much for your help, I’m pretty sure through my searching I’ve seen you help people with these issues before. Here is the first bit:

By pavu I did mean pavucontrol. The first time I looked at it, I was just getting the same information that Kmix had with a slightly different layout, so I put the mic on there as well and still had no results. I’ll look at your blog closely now and see if I can get somewhere with that. Not sure how long it will take me, I have to go to work in 5 mins so I’ll probably come back to it in about 5 hours.

Might I also add that it might be prudent to ensure I have all the correct packages installed? I did add/remove stuff like pavucontrol.](

These are my input devices on pavucontrol. This is why I’m so fkn confused. I can’t see any mics there. I’m certain I plugged it in correctly.

I’ll be back after work.

Thanks. It would be useful to see the pavucontrol configuration tab (and what the drop down menu selections may be).

It would also be useful to see the output URL/Address provided by the diagnostic script. is the script I ran (posted it earlier, but np).

I have 2 devices, seems to be my mb and graphics card? I’m trying to use my mb obviously so I usually stuck with the Intel device.](](

Also I did check the microphone works on another computer.

After looking at the screens you told me to get some snapshots of, I made some adjustments and got it to work (I think).

I used Digital Stereo output + Analog Input (sounded as close to a headphone as I could see), and then turned the other device off.](

I then checked the Input devices, and found that the rear microphone worked (why the rear, I have nfi).](

By that I mean the bar moves when I talk. Same happens in Teamspeak now too.

So I think all is fine, but I don’t have the time to do a proper test with friends online. Probably will need to tweak volume, but I assume it will go fine.

Thank you for your help. A couple questions:

Did I select the best option for headphones?

Can you give me a summary of what packages I need for this, as I have installed/uninstalled a few and lost track now. I like to know what is installed and why, I don’t want unnecessary junk on.

Could this have been done with Kmix, or am I stuck with Pulse Audio? In the end I would rather only have 1 and uninstall the other. Would changing the volume in Kmix also change the volume in Pulse?

Anyway, I will get back to you later as to how the test goes. Thanks again for your help.

Edit: Actually I do have some fuzzyness in the headphones now. God ****it just when I thought things were good. Any ideas?

Excellent. Yes in pavucontrol’s configuration Tabe I also will have an ‘output + input’ selection, where my understanding is the naming convention means ‘output’ is for sound to be directed toward speakers/headsets and ‘input’ is so that sound will be accepted by a microphone or input line.

I can’t say as I don’t have those headphones. But I believe under pavucontrol one needs in the configuration tab to select an option with both ‘input’ and ‘output’.

pavucontrol is needed to get better pulseaudio control. I also recommend alsa-utils if not installed by default.

I don’t know. I think it depends on what the default pulse audio selection was. If the default selections was wrong (misconfigured) then I do not think with pulse audio enabled that kmix would have been sufficient.

I believe pulseaudio can be disabled (and removed) but given openSUSE is now only packaged and tested with pulseaudio enabled, there is IMHO a high probability of breakage with a disabling (or removal) of pulseaudio approach.

I believe so, but I’m not certain. It may be application specific.

Glad to read this is working.

Sorry, I don’t know what ‘fuzziness’ means in the context of audio.

If you have surround sound speakers connected, you could try different settings in the pavucontrol configuration tab (ensuring the selection also has an ‘input’ tab).

Ok now I’m going insane, because now I have no sound.

The microphone Input seems to register sounds, but now the headphones play no sounds. The headphones do emit a sound, the kind of sound you get if you turn the volume up on your speakers really really high with nothing actually playing, you have that background little fuzz.

I’m on the verge of downloading Microsoft Windows. This really is ridiculous.

Edit: Current Pulse settings.](](](](

i have two microphone ports on my machine(one in front and other at the back) and when i tested mine it worked with the ones on the back but did not work with the ones in the front of the box and i did have this buzzing noise with the ones win the front. It might be a dud port. Forgot to mention that when plugged into the dud port it did show the device in the mixer

I recommend BEFORE you change ANY settings, you record what you have in place first. That way you can always go back to a functional setting. Randomly fiddling is a bankrupt approach and leads down the slope toward frustration and mistakes.

I sense frustration, but I do not understand that comment. Windows is a good OS. Most my friends use Windows. Whats wrong with that ?

Note also - on this forum we are NOT developers nor packagers of openSUSE. Instead we are volunteers (unpaid) who give up our own free time to attempt to help.

That illustrates 5.1 surround sound selected. Maybe your speakers/wiring does not support that. Go back to your previous settings that worked.

I do appreciate the fact that you are not paid or obliged to help people here, and do so as a volunteer. In searching I have seen your name come up a few times oldcpu so I do thank you. My anger isn’t directed at you of course, I’m just so frustrated. I’ve spent a whole lot of hours on something as simple as trying to get sound and a microphone to work… it really is trying my patience. If it were some more complicated issue at least there would be a good reason, but sound? Come on…

There’s a reason people turn to linux systems rather than Windows systems, despite the fact that most software and computers are designed around Windows. Not everyone’s reasons are the same, but yet here we are together. I don’t want to run windows partly out of principle, and partly because I like the philosophies behind open source. I also suspected that linux had a lot more to offer in the long run. To me, installing windows is a step backwards and a big fail on my part. I don’t want to do that.

The settings that work for sound are “Analog Stereo Output.” However there is no + Input options for an Analog Stereo Output (to see the list of options, check back a few posts), only for surround sound options (none of which work with my headphones). Also the background little fuzz is always there. This seems like a dead-end, I can either to have sound or a microphone. Is anyone aware of another way to configure my sound so I can get both?

I struggle a bit to understand what this background ‘fuzz’ sounds like.

I do note one can obtain noise in the backround if one has the capture or boost levels too high.

Try to back off in the capture levels. You can use kmix to do this, in addition to using pavucontrol.

I also like GNU/Linux, likely for the same reasons as you. But also in my case I have been using GNU/Linux since 1998 (and not using MS-Windows) so I struggle significantly if and when forced to use MS-Windows.

While most my colleagues, friends and relatives, use MS-Windows, I do note they have massive frustrations themselves at times … frustrations that I fortunately hardly ever have with GNU/Linux (likely due to the length of time I have been using the same GNU/Linux distribution - myself not being a distro hopper). I have been told of friends spending hours with the Windows system trying to get the audio to work they way they like, so from my view GNU/Linux, which does have problems, is not unique here as so does MS-Windows have problems - and indeed can have problems in similar areas. A lot boils down to one’s familiarity and the familiarity of one’s nominal support channels (which tends to be more support for Windows)

That is the sound I am talking about, you know the one where you put the volume way too high. That’s the sound I’m getting, however it is occuring at normal volumes. If I drop the volume lower, I won’t hear anything.

This however is a secondary issue. Primary is the fact I can’t use both pieces of my headphones at the same time…

On 2013-04-05, Maeldun <> wrote:
> Ok now I’m going insane, because now I have no sound.

To lighten the spirits, can I suggest your computer likes to play either dumb or death!? :slight_smile:

> The microphone Input seems to register sounds, but now the headphones
> play no sounds. The headphones do emit a sound, the kind of sound you
> get if you turn the volume up on your speakers really really high with
> nothing actually playing, you have that background little fuzz.

OK. I have a headset (headphones + microsphone) and a complex hardware setup and agree that the plethora of Linux’s
sound layers (ALSA/PulseAudio/etc…) is unfortunately very confusing. The only way to make things work is to understand
what each layer does. Start from the bottom-up (hardware → hardware interfaces → software inferfaces). If necessary
disable and uninstall PulseAudio (you can always put it back later). So let’s begin with the hardware:

  1. What is your sound card?
  2. What is your headset and does it connect only via 3.5mm, optical, or via USB connection (mine uses all three)?
  3. What is your graphics card? (and yes this is relevant).

> I’m on the verge of downloading Microsoft Windows. This really is
> ridiculous.

Linux is not free; you just pay with time rather than money.

There’s no point getting frustrated with configuration problems because while Linux gives you the freedom of choice, you
must accept responsibility for making those choices `informed choices’. If you’re not comfortable with that, then Linux
or at least openSUSE’s version of Linux isn’t for you. This is not a deficiency of Linux or of you, but merely a
mismatch between your choice of OS and your expections concerning loss of control.

The community support here is very strong, with some regulars clearly having an immense experience base to draw on (much
moreso than I). In order to tackle a problem however, you must have mindset of taking an active interest in
understanding relevant issues rather than dismissing any perceived difficulty as `ridiculous’. That way, it’s much
easier for the community to volunteer help in your direction.

Ok you’re right. Thanks for setting me straight.

I don’t have a separate sound card. My mobo: ASRock Z77 Extreme4 Motherboard [Z77-EXTREME4] - $135.00 : PC Case Gear
My GPU: ASUS GeForce GTX 660 DirectCU II 2GB OC [ENGTX660-DC2O-2GD5] - $259.00 : PC Case Gear
Headset: Plantronics | GameCom 777 (I don’t have the USB adapter). Using the 2 sound connections, 3.5mm I guess.

On 2013-04-05, Maeldun <> wrote:
> Ok you’re right. Thanks for setting me straight.

Pleasure :).

> I don’t have a separate sound card. My mobo: ‘ASRock Z77 Extreme4
> Motherboard [Z77-EXTREME4] - $135.00 : PC Case Gear’
> (
> My GPU: ‘ASUS GeForce GTX 660 DirectCU II 2GB OC [ENGTX660-DC2O-2GD5] -
> $259.00 : PC Case Gear’ (
> Headset: ‘Plantronics | GameCom 777’
> ( (I don’t have the
> USB adapter). Using the 2 sound connections, 3.5mm I guess.

OK. So you have some very nice gaming hardware. Your graphic card presumably will report having nvidia audio hardware
that you will want to disable (set to `off’) within pavucontrol’s configuration tab (assuming you’re still using
PulseAudio). Actually, you will probably want disable everything apart from the internal audio integral to your sound
card - and (I know sounds odd) reboot (empirical tip…).

How are you testing audio? If you are using Skype - fire up Skype BEFORE pavucontrol and ideally just after initiating
the echo test call. If you testing it using a game, then you might need another software layer (such as openAL)
installed. Otherwise it would be helpful to know if at least you can hear the test sound coming from YaST’s audio
configuration dialogue box.

If this all fails, then I would suggest disabling PulseAudio within YaST, uninstalling PulseAudio within the YaST’s
software manager, disabling nvidia’s sound devices within YaST’s sound dialogue and anything else that’s isn’t going to
your integral sound card. Reboot, and try again. If that fails, then it’s down to command line to diagnose your ALSA
configuration - but that’s something I’m not familiar with, because I’ve never needed to do so… yet.